summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--main.patch38
3 files changed, 45 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36dc37612f7d..24eac4ebf71e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = system76-power-git
pkgdesc = System76 Power Management
pkgver = 111
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pop-os/system76-power
install = system76-power-git.install
arch = any
@@ -13,8 +13,10 @@ pkgbase = system76-power-git
conflicts = system76-power
source = system76::git+https://github.com/pop-os/system76-power.git#branch=master
source = graphics.patch
+ source = main.patch
sha1sums = SKIP
sha1sums = e486644709099b6348dc96d5f468ae289840dade
+ sha1sums = 84d590e0f15ac601a74ab09ac7206a62c81edb84
pkgname = system76-power-git
diff --git a/PKGBUILD b/PKGBUILD
index 554911fffba4..8c2c730d4ee6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=system76
_pkgbase=system76-power
pkgname=system76-power-git
pkgver=111
-pkgrel=1
+pkgrel=2
pkgdesc="System76 Power Management"
arch=('any')
url="https://github.com/pop-os/system76-power"
@@ -21,10 +21,12 @@ makedepends=('rust')
source=(
'system76::git+https://github.com/pop-os/system76-power.git#branch=master'
'graphics.patch'
+ 'main.patch'
)
sha1sums=(
'SKIP'
'e486644709099b6348dc96d5f468ae289840dade'
+ '84d590e0f15ac601a74ab09ac7206a62c81edb84'
)
pkgver() {
@@ -35,6 +37,7 @@ pkgver() {
build() {
cd ${startdir}
patch -p0 < ${startdir}/graphics.patch
+ patch -p0 < ${startdir}/main.patch
cd ${srcdir}/${_pkgname}
diff --git a/main.patch b/main.patch
new file mode 100644
index 000000000000..fda09c86b85e
--- /dev/null
+++ b/main.patch
@@ -0,0 +1,38 @@
+--- src/system76/src/main.rs 2018-09-21 21:38:37.639982440 -0700
++++ src/system76/src/main.rs.new 2018-09-21 21:38:34.933315808 -0700
+@@ -110,22 +110,21 @@
+ )
+ )
+ .get_matches();
+-
+- if let Err(why) = logging::setup_logging(
+- if matches.is_present("verbose") {
+- LevelFilter::Debug
+- } else if matches.is_present("quiet") {
+- LevelFilter::Off
+- } else {
+- LevelFilter::Info
+- }
+- ) {
+- eprintln!("failed to set up logging: {}", why);
+- process::exit(1);
+- }
+
+ let res = match matches.subcommand() {
+- ("daemon", Some(_matches)) => {
++ ("daemon", Some(matches)) => {
++ if let Err(why) = logging::setup_logging(
++ if matches.is_present("verbose") {
++ LevelFilter::Debug
++ } else if matches.is_present("quiet") {
++ LevelFilter::Off
++ } else {
++ LevelFilter::Info
++ }
++ ) {
++ eprintln!("failed to set up logging: {}", why);
++ process::exit(1);
++ }
+ if unsafe { libc::geteuid() } == 0 {
+ daemon::daemon(matches.is_present("experimental"))
+ } else {