summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore12
-rw-r--r--PKGBUILD21
3 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 276fe0c746e5..32a5157f96d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = system76-wallpapers
pkgdesc = A collection of System76 Wallpapers
- pkgver = 18.04.1+1522964526+17.10~4666c43
+ pkgver = 18.04.2~1611351210~23.04~52abc1e
pkgrel = 1
- url = https://launchpad.net/system76-wallpapers
+ url = https://github.com/pop-os/system76-wallpapers
arch = any
- license = GPL
- source = https://launchpad.net/~system76-dev/+archive/stable/+files/system76-wallpapers_18.04.1+1522964526+17.10~4666c43.tar.xz
- sha256sums = 5d9ba5295a08b0f49481db1ef46488f8a0fedaa9e4fc9d5e2a55aa52c94cab16
+ license = LGPL-2.0-or-later
+ source = https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+sourcefiles/system76-wallpapers/18.04.2~1611351210~23.04~52abc1e~dev/system76-wallpapers_18.04.2~1611351210~23.04~52abc1e~dev.tar.xz
+ validpgpkeys = 63C46DF0140D738961429F4E204DD8AEC33A7AFF
+ sha256sums = 91b78608a9769fae1d3062805cd73288629b04bf94ec64ba8e4acb35a63591d5
pkgname = system76-wallpapers
-
diff --git a/.gitignore b/.gitignore
index 5f2e227c89ad..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,7 @@
-src/
-pkg/
+# Ignore everything
+*
-*.tar.*
-*.tgz
-*.tbz2
-*.zip
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index bcb4ddb8de3c..d4a0a4d2b55a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
-# Maintainer: Timo Schwichtenberg <therealbassx at yahoo dot de>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+# Contributor: Timo Schwichtenberg <therealbassx at yahoo dot de>
# Contributor: Link Dupont <link@fastmail.com>
-
pkgname=system76-wallpapers
-pkgver=18.04.1+1522964526+17.10~4666c43
+pkgver=18.04.2~1611351210~23.04~52abc1e
pkgrel=1
pkgdesc="A collection of System76 Wallpapers"
arch=('any')
-url="https://launchpad.net/system76-wallpapers"
-license=('GPL')
-source=("https://launchpad.net/~system76-dev/+archive/stable/+files/${pkgname}_${pkgver}.tar.xz")
-sha256sums=('5d9ba5295a08b0f49481db1ef46488f8a0fedaa9e4fc9d5e2a55aa52c94cab16')
+url="https://github.com/pop-os/system76-wallpapers"
+license=('LGPL-2.0-or-later')
+source=("https://launchpad.net/~system76-dev/+archive/ubuntu/stable/+sourcefiles/$pkgname/$pkgver~dev/${pkgname}_${pkgver}~dev.tar.xz")
+sha256sums=('91b78608a9769fae1d3062805cd73288629b04bf94ec64ba8e4acb35a63591d5')
+validpgpkeys=('63C46DF0140D738961429F4E204DD8AEC33A7AFF') # Pop OS (ISO Signing Key) <info@system76.com>
package() {
- cd "${srcdir}"
- install -m755 -d ${pkgdir}/usr/share/backgrounds
- install -m644 -D 4666c43e06ff1f7c4314f1e5e8fa4b36aafb8347_artful/backgrounds/* ${pkgdir}/usr/share/backgrounds/
- install -m644 -D 4666c43e06ff1f7c4314f1e5e8fa4b36aafb8347_artful/${pkgname}.xml ${pkgdir}/usr/share/gnome-background-properties/${pkgname}.xml
+ install -Dm644 archive/backgrounds/* -t "$pkgdir/usr/share/backgrounds"
+ install -Dm644 "archive/$pkgname.xml" -t "$pkgdir/usr/share/gnome-background-properties"
}