summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
-rw-r--r--systemd-brcmfmac-git.install5
3 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..289860aa26b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = systemd-brcmfmac-git
+ pkgdesc = Disable the `brcmfmac` module on shutdown
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/TimurKiyivinski/systemd-brcmfmac
+ install = systemd-brcmfmac-git.install
+ arch = x86_64
+ license = MIT
+ source = git+https://github.com/TimurKiyivinski/systemd-brcmfmac.git
+ sha256sums = SKIP
+
+pkgname = systemd-brcmfmac-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed3bf034f327
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Timur Kiyui <timur@linux.com>
+
+pkgname=systemd-brcmfmac-git
+pkgver=0.1
+pkgrel=1
+pkgdesc='Disable the `brcmfmac` module on shutdown'
+arch=('x86_64')
+url='https://github.com/TimurKiyivinski/systemd-brcmfmac'
+license=('MIT')
+source=('git+https://github.com/TimurKiyivinski/systemd-brcmfmac.git')
+sha256sums=('SKIP')
+install='systemd-brcmfmac-git.install'
+
+package() {
+ install -dm755 "$pkgdir/etc/systemd/system/"
+ cp "$srcdir/${pkgname/-git/}/remove-brcmfmac.service" "$pkgdir/etc/systemd/system/"
+}
diff --git a/systemd-brcmfmac-git.install b/systemd-brcmfmac-git.install
new file mode 100644
index 000000000000..53ee5ce85fd7
--- /dev/null
+++ b/systemd-brcmfmac-git.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo ">>> PACKAGES NOTES"
+ echo ">>> --------------"
+ echo ">>> Remember to run \`systemctl enable remove-brcmfmac.service\`"
+}