summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 966221bf2bf2..543c85925f8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 10 21:55:35 UTC 2015
+# Thu Dec 10 22:10:07 UTC 2015
pkgbase = systemd-cron-next
pkgdesc = systemd generator to generate timers/services from crontab and anacrontab files
- pkgver = 1.0.0.rc1
- pkgrel = 3
+ pkgver = 1.0.0.rc2
+ pkgrel = 1
url = https://github.com/systemd-cron/systemd-cron-next
arch = any
license = GPL3
@@ -13,8 +13,8 @@ pkgbase = systemd-cron-next
provides = anacron
replaces = cron
replaces = anacron
- source = https://github.com/systemd-cron/systemd-cron-next/archive/v1.0.0-rc1.zip
- md5sums = a7d5415795cd166d258f72e5cebcfaee
+ source = https://github.com/systemd-cron/systemd-cron-next/archive/v1.0.0-rc2.zip
+ md5sums = 2784d761ddd1e0a2ebcca48984281145
pkgname = systemd-cron-next
diff --git a/PKGBUILD b/PKGBUILD
index 0a7e62632a2b..51be8bacf8c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Konstantin Stepanov <me@kstep.me>
pkgname=systemd-cron-next
-pkgver=1.0.0.rc1
-pkgrel=3
+pkgver=1.0.0.rc2
+_gitver=1.0.0-rc2
+pkgrel=1
pkgdesc="systemd generator to generate timers/services from crontab and anacrontab files"
url="https://github.com/systemd-cron/systemd-cron-next"
arch=('any')
@@ -10,11 +11,11 @@ depends=('systemd')
makedepends=('rust')
provides=('cron' 'anacron')
replaces=('cron' 'anacron')
-source=('https://github.com/systemd-cron/systemd-cron-next/archive/v1.0.0-rc1.zip')
-md5sums=('a7d5415795cd166d258f72e5cebcfaee')
+source=("https://github.com/systemd-cron/systemd-cron-next/archive/v${_gitver}.zip")
+md5sums=('2784d761ddd1e0a2ebcca48984281145')
build() {
- cd "$srcdir/systemd-cron-next-1.0.0-rc1"
+ cd "${srcdir}/${pkgname}-${_gitver}"
if which multirust; then
multirust override stable
fi
@@ -23,7 +24,6 @@ build() {
}
package() {
- cd "$srcdir/systemd-cron-next-1.0.0-rc1"
- sed -i -e 's/^install: build$/install:/' Makefile
+ cd "${srcdir}/${pkgname}-${_gitver}"
make install
}