summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 32 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10ac5603e5d2..41d94238a5e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemd-light
pkgver = 244.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.github.com/systemd/systemd
arch = x86_64
makedepends = acl
@@ -11,12 +11,10 @@ pkgbase = systemd-light
makedepends = pam
makedepends = libelf
makedepends = intltool
- makedepends = iptables
makedepends = kmod
makedepends = libcap
makedepends = libidn2
makedepends = libgcrypt
- makedepends = libmicrohttpd
makedepends = libxslt
makedepends = util-linux
makedepends = linux-api-headers
@@ -30,8 +28,10 @@ pkgbase = systemd-light
makedepends = libxkbcommon
makedepends = bash-completion
makedepends = gnu-efi-libs
+ makedepends = iptables
makedepends = audit
makedepends = cryptsetup
+ makedepends = libmicrohttpd
makedepends = libseccomp
options = strip
source = git+https://github.com/systemd/systemd-stable#tag=50a79652baa8650dc2bf7fe5979e67eb673a218e?signed
@@ -54,6 +54,7 @@ pkgbase = systemd-light
source = 30-systemd-tmpfiles.hook
source = 30-systemd-udev-reload.hook
source = 30-systemd-update.hook
+ source = clearlinux::git+https://github.com/clearlinux-pkgs/systemd#tag=244-270
validpgpkeys = 63CDA1E5D3FC22B998D20DD6327F26951A015CC4
validpgpkeys = 5C251B5FC54EB2F80F407AAAC54CA336CFEB557E
sha512sums = SKIP
@@ -76,6 +77,7 @@ pkgbase = systemd-light
sha512sums = da7a97d5d3701c70dd5388b0440da39006ee4991ce174777931fea2aa8c90846a622b2b911f02ae4d5fffb92680d9a7e211c308f0f99c04896278e2ee0d9a4dc
sha512sums = a50d202a9c2e91a4450b45c227b295e1840cc99a5e545715d69c8af789ea3dd95a03a30f050d52855cabdc9183d4688c1b534eaa755ebe93616f9d192a855ee3
sha512sums = 825b9dd0167c072ba62cabe0677e7cd20f2b4b850328022540f122689d8b25315005fa98ce867cf6e7460b2b26df16b88bb3b5c9ebf721746dce4e2271af7b97
+ sha512sums = SKIP
pkgname = systemd-light
pkgdesc = system and service manager
@@ -85,7 +87,6 @@ pkgname = systemd-light
depends = acl
depends = bash
depends = dbus
- depends = iptables
depends = kbd
depends = kmod
depends = hwids
@@ -100,9 +101,9 @@ pkgname = systemd-light
depends = util-linux
depends = xz
depends = pcre2
+ depends = iptables
depends = libsmack
depends = apparmor
- optdepends = libmicrohttpd: remote journald capabilities
optdepends = quota-tools: kernel-level quota management
optdepends = systemd-sysvcompat: symlink package to provide sysvinit binaries
optdepends = polkit: allow administration as unprivileged user
@@ -127,7 +128,6 @@ pkgname = systemd-light
backup = etc/pam.d/systemd-user
backup = etc/systemd/coredump.conf
backup = etc/systemd/journald.conf
- backup = etc/systemd/journal-remote.conf
backup = etc/systemd/journal-upload.conf
backup = etc/systemd/logind.conf
backup = etc/systemd/sleep.conf
@@ -137,6 +137,7 @@ pkgname = systemd-light
backup = etc/systemd/networkd.conf
backup = etc/systemd/resolved.conf
backup = etc/systemd/timesyncd.conf
+ backup = etc/systemd/journal-remote.conf
pkgname = systemd-light-libs
pkgdesc = systemd client libraries
diff --git a/PKGBUILD b/PKGBUILD
index c87ed95edba5..3a8bc6727393 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,10 @@ _security=(seccomp !selinux !apparmor !smack)
# Specify non-empty to enable these features
_audit="y" # audit framework support
_cryptsetup="y" # Disk encryption (LUKS)
-_clear="" # Clearlinux patches
+_curl="y" # Enable support for uploading journals
+_http="y" # Enable embedded HTTP server in journald
+_qrcode="y" # Enable qrcode output support in journal
+_clear="y" # Clearlinux patches
pkgbase=systemd-light
_pkgbase=${pkgbase%-light}
@@ -35,12 +38,12 @@ pkgname=('systemd-light' 'systemd-light-libs')
# Can be from either systemd or systemd-stable
_tag='50a79652baa8650dc2bf7fe5979e67eb673a218e' # git rev-parse v${pkgver}
pkgver=244.1
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://www.github.com/systemd/systemd'
makedepends=('acl' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
- 'intltool' 'iptables' 'kmod' 'libcap' 'libidn2' 'libgcrypt'
- 'libmicrohttpd' 'libxslt' 'util-linux' 'linux-api-headers'
+ 'intltool' 'kmod' 'libcap' 'libidn2' 'libgcrypt'
+ 'libxslt' 'util-linux' 'linux-api-headers'
'python-lxml' 'quota-tools' 'shadow' 'git'
'meson' 'pcre2' 'kexec-tools' 'libxkbcommon'
'bash-completion')
@@ -94,12 +97,12 @@ _backports=(
_reverts=(
)
-if [ "$_bootloader" = 'systemd' ]; then
- makedepends+=('gnu-efi-libs')
-fi
+[ "$_bootloader" = 'systemd' ] && makedepends+=('gnu-efi-libs')
+[ "$_network" = 'systemd' ] && makedepends+=('iptables')
[ -n "$_audit" ] && makedepends+=('audit')
[ -n "$_cryptsetup" ] && makedepends+=('cryptsetup')
+[ -n "$_http" ] && makedepends+=('libmicrohttpd')
if [ -n "$_clear" ]; then
local _clrrel=270
@@ -217,14 +220,19 @@ build() {
-Daudit=$(is_nonempty "$_audit")
-Dbacklight=$(is_systemd "$_backlight")
+ -Dbzip2=$(bool_opt 'importd' "${_features[@]}")
-Defi=$(is_systemd "$_bootloader")
-Dgnu-efi=$(is_systemd "$_bootloader")
-Dhibernate=$(is_nonempty "$_hibernate")
-Dlibcryptsetup=$(is_nonempty "$_cryptsetup")
+ -Dlibcurl=$(is_nonempty "$_libcurl")
+ -Dlibiptc=$(is_systemd "$_network")
+ -Dmicrohttpd=$(is_nonempty "$_http")
-Dnetworkd=$(is_systemd "$_network")
-Dnss-mymachines=$(bool_opt 'machined' "${_features[@]}")
-Dnss-resolve=$(is_systemd "$_resolver")
-Dopenssl=$(is_systemd "$_resolver")
+ -Dqrencode=$(is_nonempty "$_qrcode")
-Dresolve=$(is_systemd "$_resolver")
-Dtimedated=$(is_systemd "$_timesync")
-Dtimesyncd=$(is_systemd "$_timesync")
@@ -258,21 +266,19 @@ check() {
package_systemd-light() {
pkgdesc='system and service manager'
license=('GPL2' 'LGPL2.1')
- depends=('acl' 'bash' 'dbus' 'iptables' 'kbd' 'kmod' 'hwids' 'libcap'
+ depends=('acl' 'bash' 'dbus' 'kbd' 'kmod' 'hwids' 'libcap'
'libgcrypt' "systemd-light-libs=$pkgver" 'libidn2' 'libidn2.so' 'lz4' 'pam' 'libelf'
'util-linux' 'xz' 'pcre2')
provides=("systemd=$pkgver" 'nss-myhostname' "systemd-tools=$pkgver" "udev=$pkgver")
replaces=('systemd' 'nss-myhostname' 'systemd-tools' 'udev')
conflicts=('systemd' 'nss-myhostname' 'systemd-tools' 'udev')
- optdepends=('libmicrohttpd: remote journald capabilities'
- 'quota-tools: kernel-level quota management'
+ optdepends=('quota-tools: kernel-level quota management'
'systemd-sysvcompat: symlink package to provide sysvinit binaries'
'polkit: allow administration as unprivileged user'
'curl: machinectl pull-tar and pull-raw')
backup=(etc/pam.d/systemd-user
etc/systemd/coredump.conf
etc/systemd/journald.conf
- etc/systemd/journal-remote.conf
etc/systemd/journal-upload.conf
etc/systemd/logind.conf
etc/systemd/sleep.conf
@@ -292,7 +298,7 @@ package_systemd-light() {
esac
case "$_network" in
- "systemd") backup+=(etc/systemd/networkd.conf);;
+ "systemd") depends+=('iptables'); backup+=(etc/systemd/networkd.conf);;
"none") ;;
*) optdepends+=("${_network}: replacement for systemd-networkd");;
esac
@@ -309,6 +315,12 @@ package_systemd-light() {
*) optdepends+=("${_timesync}: replacement for systemd-timesyncd");;
esac
+ [ -n "$_curl" ] && optdepends+=('curl: machinectl pull-tar and pull-raw')
+ [ -n "$_http" ] && {
+ optdepends+=('libmicrohttpd: remote journald capabilities')
+ backup+=(etc/systemd/journal-remote.conf)
+ }
+
for opt in seccomp selinux smack; do
if [ "$(bool_opt "$opt" "${_security[@]}")" = "true" ]; then
depends+=("lib${opt}")
@@ -325,7 +337,7 @@ package_systemd-light() {
DESTDIR="$pkgdir" meson install -C build
# we'll create this on installation
- rmdir "$pkgdir"/var/log/journal/remote
+ [ -n "$_http" ] && rmdir "$pkgdir"/var/log/journal/remote
# runtime libraries shipped with systemd-libs
install -d -m0755 systemd-libs