summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e93981beb1f..2b9c955dfaa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = systemtap
pkgdesc = Infrastructure to simplify the gathering of information about the running Linux system
pkgver = 5.0
- pkgrel = 1
+ pkgrel = 2
url = https://sourceware.org/systemtap/
install = systemtap.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index a8994403d2f0..36a3f5e8ec4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=systemtap
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Infrastructure to simplify the gathering of information about the running Linux system"
url="https://sourceware.org/systemtap/"
arch=('x86_64')
@@ -40,7 +40,13 @@ build() {
make
}
+check() {
+ cd "${pkgname}-${pkgver}"
+ make check
+}
+
package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/usr/include/sys"
}