summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--systemtap.install4
3 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa4ed7c6fc00..8ddfd4d49488 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,12 @@
-# Generated by mksrcinfo v8
-# Sun Mar 5 09:28:04 UTC 2017
pkgbase = systemtap
pkgdesc = SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system.
pkgver = 3.1
- pkgrel = 2
+ pkgrel = 3
url = http://sourceware.org/systemtap/
+ install = systemtap.install
arch = i686
arch = x86_64
- arch = armv7h
- arch = armv6h
license = GPL
- makedepends = gcc
depends = elfutils
depends = nss
depends = python2
@@ -18,8 +14,8 @@ pkgbase = systemtap
depends = texlive-latexextra
depends = latex2html
optdepends = sqlite3
- source = http://sourceware.org/systemtap/ftp/releases/systemtap-3.1.tar.gz
- sha1sums = 2927ee7e780b45e47d770798f80dfd5be62e095d
+ source = systemtap-3.1.tar.gz::https://sourceware.org/systemtap/ftp/releases/systemtap-3.1.tar.gz
+ sha512sums = 07b322d5745f570296e287db80f1e370da87eb65073815cf24d532827900453c1cb9ee74b5496b4f3919d176b960caad4479edc2dadf27b5c58898fb7398264d
pkgname = systemtap
diff --git a/PKGBUILD b/PKGBUILD
index 6a4f9d5e7fa8..752ed5a49f04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
+# $Id$
+# Maintainer : Christian Rebischke <Chris.Rebischke@archlinux.org>
+# Contributor:dront78 <dront78@gmail.com>
pkgname=systemtap
pkgver=3.1
-pkgrel=2
+pkgrel=3
pkgdesc="SystemTap provides free software (GPL) infrastructure to simplify the gathering of information about the running Linux system."
url="http://sourceware.org/systemtap/"
-arch=('i686' 'x86_64' 'armv7h' 'armv6h')
+arch=('i686' 'x86_64')
license=('GPL')
depends=('elfutils' 'nss' 'python2' 'texlive-fontsextra' 'texlive-latexextra' 'latex2html')
-makedepends=('gcc')
optdepends=('sqlite3')
-source=(http://sourceware.org/systemtap/ftp/releases/$pkgname-$pkgver.tar.gz)
-sha1sums=('2927ee7e780b45e47d770798f80dfd5be62e095d')
+source=("${pkgname}-${pkgver}.tar.gz::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('07b322d5745f570296e287db80f1e370da87eb65073815cf24d532827900453c1cb9ee74b5496b4f3919d176b960caad4479edc2dadf27b5c58898fb7398264d')
+install='systemtap.install'
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --sysconfdir=/etc || return 1
+ ./configure --prefix=/usr --sysconfdir=/etc
make
}
@@ -22,4 +25,3 @@ package() {
make DESTDIR="${pkgdir}" install
}
-# vim:set ts=2 sw=2 et:
diff --git a/systemtap.install b/systemtap.install
new file mode 100644
index 000000000000..d168c58fc234
--- /dev/null
+++ b/systemtap.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "CONFIG_DEBUG_INFO is disabled on default. You need to recompile"
+ echo "the kernel with CONFIG_DEBUG_INFO enabled."
+}