summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
-rw-r--r--stack.yaml40
3 files changed, 34 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ab5aa24031c..ceea59303e0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = taffybar
pkgdesc = A desktop bar similar to xmobar, but with more GUI
- pkgver = 3.2.3
+ pkgver = 3.3.0
pkgrel = 1
- url = http://github.com/travitch/taffybar
+ url = http://github.com/taffybar/taffybar
install = taffybar.install
arch = i686
arch = x86_64
@@ -12,16 +12,15 @@ pkgbase = taffybar
depends = zlib
depends = libxss
depends = libdbusmenu-gtk3
- source = https://github.com/taffybar/taffybar/archive/v3.2.3.tar.gz
+ source = https://github.com/taffybar/taffybar/archive/v3.3.0.tar.gz
source = taffybar.install
source = taffybar.service
source = stack.yaml
source = https://raw.githubusercontent.com/taffybar/taffybar/13b32fc2bc62129093494e939339a979d641691c/xmonad.hs.example
- sha256sums = 74333f8177677d4acb509d09ca3727b726b70d1b6cfc1a5439d236eabc6556b3
+ sha256sums = 41d19c12694c7fe9526d4082993f2c1f07e12ea133c494c7d017da1d2c370b32
sha256sums = 554340a052abecb78fbb959d1a05b8f4f4db947fc151e7f0f8c49f2300f1ab6d
sha256sums = f4a08e887ba527a24f4cecc22393023bf7230172cc76f840ddfc5cfc54182a7e
- sha256sums = 0bd90a3b0859ccb7a5319ce7906a7c4611153035cb75ee5a1127d34325cc03d4
+ sha256sums = ad02a7524b7c9bd9ae28babfbbb30519b3eb10ff40e3e493aee051bd36c0b715
sha256sums = 1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb
pkgname = taffybar
-
diff --git a/PKGBUILD b/PKGBUILD
index e034bf1751dc..63c93774c2cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com
# Maintainer: Leif Warner <abimelech@gmail.com>
pkgname=taffybar
-pkgver=3.2.3
+pkgver=3.3.0
pkgrel=1
license=('BSD3')
pkgdesc="A desktop bar similar to xmobar, but with more GUI"
-url="http://github.com/travitch/taffybar"
+url="http://github.com/taffybar/taffybar"
arch=('i686' 'x86_64')
depends=("gmp" "zlib" 'libxss' 'libdbusmenu-gtk3')
makedepends=('stack')
@@ -17,10 +17,10 @@ source=("https://github.com/taffybar/taffybar/archive/v${pkgver}.tar.gz"
"https://raw.githubusercontent.com/taffybar/taffybar/13b32fc2bc62129093494e939339a979d641691c/xmonad.hs.example"
)
-sha256sums=('74333f8177677d4acb509d09ca3727b726b70d1b6cfc1a5439d236eabc6556b3'
+sha256sums=('41d19c12694c7fe9526d4082993f2c1f07e12ea133c494c7d017da1d2c370b32'
'554340a052abecb78fbb959d1a05b8f4f4db947fc151e7f0f8c49f2300f1ab6d'
'f4a08e887ba527a24f4cecc22393023bf7230172cc76f840ddfc5cfc54182a7e'
- '0bd90a3b0859ccb7a5319ce7906a7c4611153035cb75ee5a1127d34325cc03d4'
+ 'ad02a7524b7c9bd9ae28babfbbb30519b3eb10ff40e3e493aee051bd36c0b715'
'1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb')
# PKGBUILD functions
diff --git a/stack.yaml b/stack.yaml
index 28558e8d41e1..a84f453c50b6 100644
--- a/stack.yaml
+++ b/stack.yaml
@@ -1,12 +1,15 @@
+flags: {}
+extra-package-dbs: []
packages:
- '.'
extra-deps:
- ConfigFile-1.1.4
- broadcast-chan-0.2.1.1
+- dbus-1.2.21
- dbus-hslogger-0.1.0.1
# gtk-sni-tray for a clean tray
-- gtk-sni-tray-0.1.6.0
+- gtk-sni-tray-0.1.8.0
# GTK3 for my-taffybar
- gtk3-0.15.5
# For gtk3
@@ -17,33 +20,40 @@ extra-deps:
- pango-0.13.8.1
# From base taffybar
-- gi-glib-2.0.24
-- haskell-gi-0.24.5
-- haskell-gi-base-0.24.4
+- gi-glib-2.0.25
+- haskell-gi-0.25.0
+- haskell-gi-base-0.25.0
# From manual "finding out the package and finding the most recent version"
- gi-cairo-connector-0.1.0
- gi-cairo-render-0.1.0
-- gi-pango-1.0.23
-- gi-gtk-hs-0.3.9
+- gi-cairo-1.0.25
+- gi-gmodule-2.0.1
+- gi-pango-1.0.24
+- gi-gtk-hs-0.3.10
# Seeing that theoretically the `g_spec_param_uref` linking issue has been fixed,
# gi-gobject is fixed to the most recent version
-# Source : https://github.com/haskell-gi/haskell-gi/issues/298 and
+# Source : https://github.com/haskell-gi/haskell-gi/issues/298 and
# https://github.com/haskell-gi/haskell-gi/issues/301
-- gi-gobject-2.0.24
+- gi-gobject-2.0.26
+- gi-gio-2.0.28
# From gi-pango
-- gi-harfbuzz-0.0.3
-- gi-dbusmenu-0.4.6
-- gi-dbusmenugtk3-0.4.7
-- gi-gdkx11-3.0.8
-- gi-xlib-2.0.7
+- gi-harfbuzz-0.0.4
+- gi-dbusmenu-0.4.9
+- gi-dbusmenugtk3-0.4.10
+- gi-gdkx11-3.0.11
+- gi-xlib-2.0.10
- gtk-strut-0.1.3.0
- rate-limit-1.4.1
-- status-notifier-item-0.3.0.5
+- status-notifier-item-0.3.1.0
- time-units-1.0.0
- xml-helpers-1.0.0
- safe-0.3.19
+- MissingH-1.4.3.0
+- xdg-desktop-entry-0.1.1.1
-resolver: lts-16.26
+
+
+resolver: lts-18.5
allow-newer: true
ghc-options:
$everything: -split-sections -haddock