summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO55
-rw-r--r--PKGBUILD84
-rw-r--r--dynamic-compilation.patch12
-rw-r--r--stack.yaml25
4 files changed, 45 insertions, 131 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d28c9d3dd8fb..e438b0a6456e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,61 +7,20 @@ pkgbase = taffybar
arch = i686
arch = x86_64
license = BSD3
- makedepends = ghc
- depends = ghc-libs
- depends = haskell-alsa-mixer
- depends = haskell-configfile
- depends = haskell-either
- depends = haskell-gi-pango
- depends = haskell-broadcast-chan
- depends = haskell-http-client
- depends = haskell-http-types
- depends = haskell-http-client-tls
- depends = haskell-gi-cairo-connector
- depends = haskell-gi-cairo-render
- depends = haskell-hstringtemplate
- depends = haskell-http
- depends = haskell-x11
- depends = haskell-scotty
- depends = haskell-dyre
- depends = haskell-enclosed-exceptions
- depends = haskell-dbus
- depends = haskell-multimap
- depends = haskell-network
- depends = haskell-network-uri
- depends = haskell-old-locale
- depends = haskell-parsec
- depends = haskell-rate-limit
- depends = haskell-safe
- depends = haskell-split
- depends = haskell-stm
- depends = haskell-text
- depends = haskell-time-locale-compat
- depends = haskell-tuple
- depends = haskell-gi-cairo
- depends = haskell-gi
- depends = haskell-gi-base
- depends = haskell-utf8-string
- depends = haskell-xdg-basedir
- depends = haskell-dbus-hslogger
- depends = haskell-xml-helpers
- depends = haskell-status-notifier-item
- depends = haskell-gi-gdkx11
- depends = haskell-gi-gtk
- depends = haskell-gtk-strut
- depends = gtk-sni-tray
- depends = haskell-gi-gtk-hs
- depends = xmonad
- depends = xmonad-contrib
+ makedepends = stack
+ depends = gmp
+ depends = zlib
+ depends = libxss
+ depends = libdbusmenu-gtk3
source = https://github.com/taffybar/taffybar/archive/v3.2.1.tar.gz
- source = dynamic-compilation.patch
source = taffybar.install
source = taffybar.service
+ source = stack.yaml
source = https://raw.githubusercontent.com/taffybar/taffybar/13b32fc2bc62129093494e939339a979d641691c/xmonad.hs.example
sha256sums = 51ca3f4dd505a9d5fb03a3150898bcd090e037ca851f04a4ce4185135bf537ca
- sha256sums = ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7
sha256sums = 554340a052abecb78fbb959d1a05b8f4f4db947fc151e7f0f8c49f2300f1ab6d
sha256sums = f4a08e887ba527a24f4cecc22393023bf7230172cc76f840ddfc5cfc54182a7e
+ sha256sums = 7a9ed0c527e2306b193f9e38bba3d740b60d6c8e17869a172daa752c79df3ad1
sha256sums = 1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb
pkgname = taffybar
diff --git a/PKGBUILD b/PKGBUILD
index 44cb9ff3f466..36ee89b30410 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,102 +7,44 @@ license=('BSD3')
pkgdesc="A desktop bar similar to xmobar, but with more GUI"
url="http://github.com/travitch/taffybar"
arch=('i686' 'x86_64')
-depends=("ghc-libs"
- "haskell-alsa-mixer"
- "haskell-configfile"
- "haskell-either"
- "haskell-gi-pango"
- "haskell-broadcast-chan"
- "haskell-http-client"
- "haskell-http-types"
- "haskell-http-client-tls"
- "haskell-gi-cairo-connector"
- "haskell-gi-cairo-render"
- "haskell-hstringtemplate"
- "haskell-http"
- "haskell-x11"
- "haskell-scotty"
- "haskell-dyre"
- "haskell-enclosed-exceptions"
- "haskell-dbus"
- "haskell-multimap"
- "haskell-network"
- "haskell-network-uri"
- "haskell-old-locale"
- "haskell-parsec"
- "haskell-rate-limit"
- "haskell-safe"
- "haskell-split"
- "haskell-stm"
- "haskell-text"
- "haskell-time-locale-compat"
- "haskell-tuple"
- "haskell-gi-cairo"
- "haskell-gi"
- "haskell-gi-base"
- "haskell-utf8-string"
- "haskell-xdg-basedir"
- "haskell-dbus-hslogger"
- "haskell-xml-helpers"
- "haskell-status-notifier-item"
- "haskell-gi-gdkx11"
- "haskell-gi-gtk"
- "haskell-gtk-strut"
- "gtk-sni-tray"
- "haskell-gi-gtk-hs"
- "xmonad"
- "xmonad-contrib")
-makedepends=('ghc')
+depends=("gmp" "zlib" 'libxss' 'libdbusmenu-gtk3')
+makedepends=('stack')
install=taffybar.install
source=("https://github.com/taffybar/taffybar/archive/v${pkgver}.tar.gz"
- "dynamic-compilation.patch"
"taffybar.install"
"taffybar.service"
+ "stack.yaml"
"https://raw.githubusercontent.com/taffybar/taffybar/13b32fc2bc62129093494e939339a979d641691c/xmonad.hs.example"
)
sha256sums=('51ca3f4dd505a9d5fb03a3150898bcd090e037ca851f04a4ce4185135bf537ca'
- 'ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7'
'554340a052abecb78fbb959d1a05b8f4f4db947fc151e7f0f8c49f2300f1ab6d'
'f4a08e887ba527a24f4cecc22393023bf7230172cc76f840ddfc5cfc54182a7e'
+ '7a9ed0c527e2306b193f9e38bba3d740b60d6c8e17869a172daa752c79df3ad1'
'1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb')
# PKGBUILD functions
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- # See https://github.com/willdonnelly/dyre/issues/5
- #sed -i -e 's/Dyre.ghcOpts = \["-threaded", "-rtsopts"\]/Dyre.ghcOpts = \["-threaded", "-rtsopts", "-dynamic"\]/' src/System/Taffybar.hs
- patch -p1 -i ../dynamic-compilation.patch
+ mv ../stack.yaml .
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- runhaskell Setup configure -O --enable-shared --disable-library-vanilla \
- --enable-executable-dynamic \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
- --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
- -fnetwork-uri
- runhaskell Setup build
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+ mkdir -p "taffybar/bin"
+ stack --jobs "$[$(nproc)+1]" --local-bin-path "taffybar/bin/" install -- taffybar
+
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
- install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ cd "${srcdir}/${pkgname}-${pkgver}"/taffybar
- runhaskell Setup copy --destdir="${pkgdir}"
+ install -Dm755 "bin/taffybar" "${pkgdir}/usr/bin/taffybar"
- install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm 644 CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 ../LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 ../CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 ../README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm 644 ${srcdir}/taffybar.service -t "${pkgdir}/usr/lib/systemd/user"
install -Dm 644 ${srcdir}/xmonad.hs.example -t "{$pkgdir}/usr/share/doc/${pkgname}"
diff --git a/dynamic-compilation.patch b/dynamic-compilation.patch
deleted file mode 100644
index 26b681cee7fa..000000000000
--- a/dynamic-compilation.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN taffybar-1.0.1.orig/src/System/Taffybar.hs taffybar-1.0.1/src/System/Taffybar.hs
---- taffybar-1.0.1.orig/src/System/Taffybar.hs 2018-04-09 17:02:33.000000000 +1100
-+++ taffybar-1.0.1/src/System/Taffybar.hs 2018-04-15 20:59:15.297837819 +1100
-@@ -298,7 +298,7 @@
- { Dyre.projectName = "taffybar"
- , Dyre.realMain = realMain
- , Dyre.showError = showError
-- , Dyre.ghcOpts = ["-threaded", "-rtsopts"]
-+ , Dyre.ghcOpts = ["-threaded", "-rtsopts", "-dynamic"]
- , Dyre.rtsOptsHandling = Dyre.RTSAppend ["-I0", "-V0"]
- }
-
diff --git a/stack.yaml b/stack.yaml
new file mode 100644
index 000000000000..957c9dd42a61
--- /dev/null
+++ b/stack.yaml
@@ -0,0 +1,25 @@
+packages:
+- '.'
+
+extra-deps:
+- ConfigFile-1.1.4
+- broadcast-chan-0.2.0.2
+- dbus-hslogger-0.1.0.1
+- gio-0.13.4.1
+- gtk-sni-tray-0.1.6.0
+- gtk-strut-0.1.3.0
+- libxml-sax-0.7.5
+- rate-limit-1.4.1
+- spool-0.1
+- status-notifier-item-0.3.0.1
+- time-units-1.0.0
+- xml-helpers-1.0.0
+- gi-cairo-connector-0.0.1
+- gi-cairo-render-0.0.1
+- gi-dbusmenu-0.4.4
+- gi-dbusmenugtk3-0.4.5
+- gi-gdkx11-3.0.5
+- gi-xlib-2.0.5
+resolver: lts-14.27
+
+ghc-options: {"$locals": -ddump-to-file -ddump-hi}