summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
-rw-r--r--dynamic-compilation.patch23
-rw-r--r--taffybar.install8
4 files changed, 57 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcd98d2c5d4d..afc6ec86f5d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
# Generated by mksrcinfo v8
-# Sat Jan 27 20:43:21 UTC 2018
+# Mon Apr 16 07:10:42 UTC 2018
pkgbase = taffybar
pkgdesc = A desktop bar similar to xmobar, but with more GUI
- pkgver = 0.4.6
+ pkgver = 1.0.1
pkgrel = 1
url = http://github.com/travitch/taffybar
+ install = taffybar.install
arch = i686
arch = x86_64
license = BSD3
depends = ghc
+ depends = haskell-alsa-mixer
+ depends = haskell-configfile
+ depends = haskell-either
depends = haskell-hstringtemplate
depends = haskell-http
depends = haskell-x11
@@ -16,28 +20,32 @@ pkgbase = taffybar
depends = haskell-dbus
depends = haskell-dyre
depends = haskell-enclosed-exceptions
- depends = haskell-gtk2
+ depends = haskell-gtk
depends = haskell-gtk-traymanager
depends = haskell-mtl
+ depends = haskell-multimap
depends = haskell-network
depends = haskell-network-uri
depends = haskell-old-locale
depends = haskell-parsec
+ depends = haskell-rate-limit
depends = haskell-safe
depends = haskell-split
depends = haskell-stm
depends = haskell-text
depends = haskell-time-locale-compat
+ depends = haskell-tuple
depends = haskell-utf8-string
depends = haskell-xdg-basedir
+ depends = haskell-xml-helpers
depends = xmonad
depends = xmonad-contrib
- source = http://hackage.haskell.org/packages/archive/taffybar/0.4.6/taffybar-0.4.6.tar.gz
+ source = http://hackage.haskell.org/packages/archive/taffybar/1.0.1/taffybar-1.0.1.tar.gz
source = dynamic-compilation.patch
- source = ghc_8.2.patch
- sha256sums = 620918469d79d33067808114bdf8d4d6f5a5ae6d77ff672a37ea04ecc5e0caf5
- sha256sums = ab4f83891b764938d4750e7a1835761028b3c8761f7f6089053b3696325851d3
- sha256sums = 127746e08c91035adb38c9e6f046bd7a5377d95c9cb61d81a186e3e20f5dd808
+ source = taffybar.install
+ sha256sums = 1632917430972d656235c4f27b485d0ea09c5df4089088281ba523380e3efda9
+ sha256sums = ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7
+ sha256sums = bcbdbd6d8644fda65102eb7b033b7e0b27f5a2a1f4de0d832cf7914c23c3496e
pkgname = taffybar
diff --git a/PKGBUILD b/PKGBUILD
index a7f32b4feae5..b373be780f9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,15 @@
# Maintainer: Leif Warner <abimelech@gmail.com>
pkgname=taffybar
-pkgver=0.4.6
+pkgver=1.0.1
pkgrel=1
license=('BSD3')
pkgdesc="A desktop bar similar to xmobar, but with more GUI"
url="http://github.com/travitch/taffybar"
arch=('i686' 'x86_64')
depends=("ghc"
+ "haskell-alsa-mixer"
+ "haskell-configfile"
+ "haskell-either"
"haskell-hstringtemplate"
"haskell-http"
"haskell-x11"
@@ -14,41 +17,43 @@ depends=("ghc"
"haskell-dbus"
"haskell-dyre"
"haskell-enclosed-exceptions"
- "haskell-gtk2"
+ "haskell-gtk"
"haskell-gtk-traymanager"
"haskell-mtl"
+ "haskell-multimap"
"haskell-network"
"haskell-network-uri"
"haskell-old-locale"
"haskell-parsec"
+ "haskell-rate-limit"
"haskell-safe"
"haskell-split"
"haskell-stm"
"haskell-text"
"haskell-time-locale-compat"
+ "haskell-tuple"
"haskell-utf8-string"
"haskell-xdg-basedir"
+ "haskell-xml-helpers"
"xmonad"
"xmonad-contrib")
+install=taffybar.install
source=("http://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"dynamic-compilation.patch"
- "ghc_8.2.patch")
+ "taffybar.install")
-sha256sums=('620918469d79d33067808114bdf8d4d6f5a5ae6d77ff672a37ea04ecc5e0caf5'
- 'ab4f83891b764938d4750e7a1835761028b3c8761f7f6089053b3696325851d3'
- '127746e08c91035adb38c9e6f046bd7a5377d95c9cb61d81a186e3e20f5dd808')
+sha256sums=('1632917430972d656235c4f27b485d0ea09c5df4089088281ba523380e3efda9'
+ 'ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7'
+ 'bcbdbd6d8644fda65102eb7b033b7e0b27f5a2a1f4de0d832cf7914c23c3496e')
# PKGBUILD functions
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- # Submitted upstream: https://github.com/travitch/taffybar/pull/247
- patch -p1 -i ../ghc_8.2.patch
- #sed -i -e "s/time >= 1.4 && < 1.7/time >= 1.4 \&\& < 1.9/" taffybar.cabal
# See https://github.com/willdonnelly/dyre/issues/5
patch -p1 -i ../dynamic-compilation.patch
- #sed -i -e 's/Dyre.ghcOpts = ["-threaded", "-rtsopts"]/Dyre.ghcOpts = \["-threaded", "-rtsopts", "-dynamic"\]/' src/System/Taffybar.hs
+ #sed -i -e 's/Dyre.ghcOpts = \["-threaded", "-rtsopts"\]/Dyre.ghcOpts = \["-threaded", "-rtsopts", "-dynamic"\]/' src/System/Taffybar.hs
}
build() {
@@ -58,7 +63,7 @@ build() {
--enable-executable-dynamic \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
--libsubdir=\$compiler/site-local/\$pkgid \
- -fnetwork-uri
+ -fnetwork-uri
runhaskell Setup build
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
@@ -73,6 +78,11 @@ package() {
install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
runhaskell Setup copy --destdir="${pkgdir}"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 taffybar.hs.example -t "${pkgdir}/usr/share/doc/${pkgname}"
+
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
diff --git a/dynamic-compilation.patch b/dynamic-compilation.patch
index db6e37f5e372..26b681cee7fa 100644
--- a/dynamic-compilation.patch
+++ b/dynamic-compilation.patch
@@ -1,13 +1,12 @@
-Index: taffybar-0.4.6/src/System/Taffybar.hs
-===================================================================
---- taffybar-0.4.6.orig/src/System/Taffybar.hs
-+++ taffybar-0.4.6/src/System/Taffybar.hs
-@@ -195,7 +195,7 @@ defaultParams :: Dyre.Params TaffybarCon
- defaultParams = Dyre.defaultParams { Dyre.projectName = "taffybar"
- , Dyre.realMain = realMain
- , Dyre.showError = showError
-- , Dyre.ghcOpts = ["-threaded", "-rtsopts"]
-+ , Dyre.ghcOpts = ["-threaded", "-rtsopts", "-dynamic"]
- , Dyre.rtsOptsHandling = Dyre.RTSAppend ["-I0", "-V0"]
- }
+diff -ruN taffybar-1.0.1.orig/src/System/Taffybar.hs taffybar-1.0.1/src/System/Taffybar.hs
+--- taffybar-1.0.1.orig/src/System/Taffybar.hs 2018-04-09 17:02:33.000000000 +1100
++++ taffybar-1.0.1/src/System/Taffybar.hs 2018-04-15 20:59:15.297837819 +1100
+@@ -298,7 +298,7 @@
+ { Dyre.projectName = "taffybar"
+ , Dyre.realMain = realMain
+ , Dyre.showError = showError
+- , Dyre.ghcOpts = ["-threaded", "-rtsopts"]
++ , Dyre.ghcOpts = ["-threaded", "-rtsopts", "-dynamic"]
+ , Dyre.rtsOptsHandling = Dyre.RTSAppend ["-I0", "-V0"]
+ }
diff --git a/taffybar.install b/taffybar.install
new file mode 100644
index 000000000000..e3c92122faab
--- /dev/null
+++ b/taffybar.install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+post_install(){
+
+ echo 'Place a taffybar.hs config file in $HOME/.config/taffybar to use.'
+ echo 'There is an example one at /usr/share/doc/taffybar/taffbar.hs.example'
+
+}