summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD33
-rw-r--r--taffybar.install5
-rw-r--r--xmonad.hs.example19
4 files changed, 68 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26958a5deee4..b4520a1048c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,25 @@
-# Generated by mksrcinfo v8
-# Thu Apr 26 00:28:23 UTC 2018
pkgbase = taffybar
pkgdesc = A desktop bar similar to xmobar, but with more GUI
- pkgver = 1.0.1
- pkgrel = 1
+ pkgver = 2.1.1
+ pkgrel = 4
url = http://github.com/travitch/taffybar
install = taffybar.install
arch = i686
arch = x86_64
license = BSD3
- depends = ghc
+ makedepends = ghc
+ depends = ghc-libs
depends = haskell-alsa-mixer
depends = haskell-configfile
depends = haskell-either
depends = haskell-hstringtemplate
depends = haskell-http
depends = haskell-x11
- depends = haskell-cairo
- depends = haskell-dbus
depends = haskell-dyre
- depends = haskell-enclosed-exceptions
depends = haskell-gtk
depends = haskell-gtk-traymanager
+ depends = haskell-enclosed-exceptions
+ depends = haskell-dbus
depends = haskell-mtl
depends = haskell-multimap
depends = haskell-network
@@ -35,17 +33,30 @@ pkgbase = taffybar
depends = haskell-text
depends = haskell-time-locale-compat
depends = haskell-tuple
+ depends = haskell-gi-cairo
+ depends = haskell-gi
+ depends = haskell-gi-base
depends = haskell-utf8-string
depends = haskell-xdg-basedir
+ depends = haskell-dbus-hslogger
depends = haskell-xml-helpers
+ depends = haskell-status-notifier-item
+ depends = haskell-gi-gobject
+ depends = haskell-gi-gdkx11
+ depends = haskell-gi-gtk
+ depends = haskell-gtk-strut
+ depends = gtk-sni-tray
+ depends = haskell-gi-gtk-hs
depends = xmonad
depends = xmonad-contrib
- source = http://hackage.haskell.org/packages/archive/taffybar/1.0.1/taffybar-1.0.1.tar.gz
+ source = http://hackage.haskell.org/packages/archive/taffybar/2.1.1/taffybar-2.1.1.tar.gz
source = dynamic-compilation.patch
source = taffybar.install
- sha256sums = 1632917430972d656235c4f27b485d0ea09c5df4089088281ba523380e3efda9
+ source = https://raw.githubusercontent.com/taffybar/taffybar/master/xmonad.hs.example
+ sha256sums = 1352a3d2937a4694010e55fbb353779d53223c3ec4b2e18847d388c59b07778d
sha256sums = ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7
- sha256sums = c26eab02338c89d54310979178d4b8f6ff315071f563b609f9ff750c0d2c1cae
+ sha256sums = ce653be1ce3bd057e5779fb129e91708e34a5c686e1c3d65798790559330185f
+ sha256sums = 1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb
pkgname = taffybar
diff --git a/PKGBUILD b/PKGBUILD
index e1654b8b6a46..37776d19829a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
+# Maintainer: Solomon Choina <shlomochoina@gmail.com
# Maintainer: Leif Warner <abimelech@gmail.com>
pkgname=taffybar
-pkgver=1.0.1
-pkgrel=1
+pkgver=2.1.1
+pkgrel=4
license=('BSD3')
pkgdesc="A desktop bar similar to xmobar, but with more GUI"
url="http://github.com/travitch/taffybar"
arch=('i686' 'x86_64')
-depends=("ghc"
+depends=("ghc-libs"
"haskell-alsa-mixer"
"haskell-configfile"
"haskell-either"
"haskell-hstringtemplate"
"haskell-http"
"haskell-x11"
- "haskell-cairo"
- "haskell-dbus"
"haskell-dyre"
- "haskell-enclosed-exceptions"
"haskell-gtk"
"haskell-gtk-traymanager"
+ "haskell-enclosed-exceptions"
+ "haskell-dbus"
"haskell-mtl"
"haskell-multimap"
"haskell-network"
@@ -32,19 +32,33 @@ depends=("ghc"
"haskell-text"
"haskell-time-locale-compat"
"haskell-tuple"
+ "haskell-gi-cairo"
+ "haskell-gi"
+ "haskell-gi-base"
"haskell-utf8-string"
"haskell-xdg-basedir"
+ "haskell-dbus-hslogger"
"haskell-xml-helpers"
+ "haskell-status-notifier-item"
+ "haskell-gi-gobject"
+ "haskell-gi-gdkx11"
+ "haskell-gi-gtk"
+ "haskell-gtk-strut"
+ "gtk-sni-tray"
+ "haskell-gi-gtk-hs"
"xmonad"
"xmonad-contrib")
+makedepends=('ghc')
install=taffybar.install
source=("http://hackage.haskell.org/packages/archive/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"dynamic-compilation.patch"
- "taffybar.install")
+ "taffybar.install"
+ "https://raw.githubusercontent.com/taffybar/taffybar/master/xmonad.hs.example")
-sha256sums=('1632917430972d656235c4f27b485d0ea09c5df4089088281ba523380e3efda9'
+sha256sums=('1352a3d2937a4694010e55fbb353779d53223c3ec4b2e18847d388c59b07778d'
'ff90b6e3d05b3bb94cfc2365708bbabbb96fd9a9a4919c0face6f8d2b69037e7'
- 'c26eab02338c89d54310979178d4b8f6ff315071f563b609f9ff750c0d2c1cae')
+ 'ce653be1ce3bd057e5779fb129e91708e34a5c686e1c3d65798790559330185f'
+ '1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb')
# PKGBUILD functions
@@ -83,6 +97,7 @@ package() {
install -Dm 644 CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm 644 taffybar.hs.example -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 ${srcdir}/xmonad.hs.example -t "{$pkgdir}/usr/share/doc/${pkgname}"
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
diff --git a/taffybar.install b/taffybar.install
index acfdd2a13c06..8549f8dad454 100644
--- a/taffybar.install
+++ b/taffybar.install
@@ -2,7 +2,8 @@
post_install(){
- note 'Place a taffybar.hs config file in $HOME/.config/taffybar to use.'
- note 'There is an example one at /usr/share/doc/taffybar/taffbar.hs.example'
+ msg2 'Place a taffybar.hs config file in $HOME/.config/taffybar to use.'
+ msg2 'There is an example one at /usr/share/doc/taffybar/taffbar.hs.example'
+ msg2 'there is an example xmonad.hs in the above folder'
}
diff --git a/xmonad.hs.example b/xmonad.hs.example
new file mode 100644
index 000000000000..7533b7ee4ea5
--- /dev/null
+++ b/xmonad.hs.example
@@ -0,0 +1,19 @@
+module Main where
+
+import XMonad
+import XMonad.Hooks.EwmhDesktops (ewmh)
+import XMonad.Hooks.ManageDocks
+import System.Taffybar.Support.PagerHints (pagerHints)
+
+ -- xmonad entrypoint
+main = xmonad $
+
+ -- docks allows xmonad to handle taffybar
+ docks $
+
+ -- gives taffybar logger information
+ ewmh $
+ pagerHints
+
+ -- xmonad config
+ defaultConfig