summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3f516075b12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 15:21:39 UTC 2019
+pkgbase = taglib-sharp
+ pkgdesc = Library for reading and writing metadata in media files for Mono
+ pkgver = 2.1.0.0
+ pkgrel = 3
+ url = https://github.com/mono/taglib-sharp
+ arch = any
+ license = LGPL2.1
+ depends = mono
+ source = https://github.com/mono/taglib-sharp/archive/taglib-sharp-2.1.0.0.tar.gz
+ sha256sums = 8221fccfc2e834eebb24404f2c0ca26b2788af646a172266f89627a5d339bdec
+
+pkgname = taglib-sharp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..391dbc4a50d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Daniel Isenmann <daniel@archlinux.org>
+# Contributor: Carlos Ruiz <cailovirtual@gmail.com>
+
+pkgname=taglib-sharp
+pkgver=2.1.0.0
+pkgrel=3
+pkgdesc="Library for reading and writing metadata in media files for Mono"
+arch=('any')
+url="https://github.com/mono/taglib-sharp"
+license=('LGPL2.1')
+depends=('mono')
+source=(https://github.com/mono/taglib-sharp/archive/$pkgname-$pkgver.tar.gz)
+sha256sums=('8221fccfc2e834eebb24404f2c0ca26b2788af646a172266f89627a5d339bdec')
+
+prepare() {
+ cd $pkgname-$pkgname-$pkgver
+ sed -i 's/gmcs/mcs/' configure.ac
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $pkgname-$pkgname-$pkgver
+ ./configure --prefix=/usr --disable-docs
+ make
+}
+
+package() {
+ cd $pkgname-$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}