summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e45a23535f02..67b9c7f8c747 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tangram
pkgdesc = Browser for your pinned tabs
pkgver = 1.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://apps.gnome.org/app/re.sonny.Tangram
arch = any
license = GPL3
@@ -14,7 +14,9 @@ pkgbase = tangram
conflicts = gigagram
conflicts = tangram-web
replaces = tangram-web
- source = tangram::git+https://github.com/sonnyp/Tangram.git#tag=v1.4.0
+ source = git+https://github.com/sonnyp/Tangram.git#tag=v1.4.0
+ source = git+https://github.com/sonnyp/troll.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = tangram
diff --git a/PKGBUILD b/PKGBUILD
index 9853c25db0ec..c06b92cd4a76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sonny Piers <sonny at fastmail dot net>
pkgname=tangram
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Browser for your pinned tabs"
arch=('any')
url="https://apps.gnome.org/app/re.sonny.Tangram"
@@ -12,11 +12,20 @@ makedepends=('git' 'meson')
#checkdepends=('appstream-glib')
conflicts=('gigagram' "$pkgname-web")
replaces=("$pkgname-web")
-source=("$pkgname::git+https://github.com/sonnyp/Tangram.git#tag=v$pkgver")
-sha256sums=('SKIP')
+source=("git+https://github.com/sonnyp/Tangram.git#tag=v$pkgver"
+ 'git+https://github.com/sonnyp/troll.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$srcdir/Tangram"
+ git submodule init
+ git config submodule.src/troll.url "$srcdir/troll"
+ git submodule update
+}
build() {
- arch-meson "$pkgname" build
+ arch-meson Tangram build
meson compile -C build
}