summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--taskcoach.changelog74
3 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..706cb12ae343
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = taskcoach
+ pkgdesc = A simple open source todo manager to manage personal tasks and todo lists
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = http://www.taskcoach.org
+ changelog = taskcoach.changelog
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = wxpython2.8
+ depends = curl
+ depends = twisted
+ source = http://downloads.sourceforge.net/sourceforge/taskcoach/TaskCoach-1.4.2.tar.gz
+ md5sums = ef131184e8d7236d80bd07080fe2b014
+
+pkgname = taskcoach
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c14e8c8267d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
+
+pkgname=taskcoach
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="A simple open source todo manager to manage personal tasks and todo lists"
+arch=('any')
+url="http://www.taskcoach.org"
+license=('GPL3')
+depends=('python2' 'wxpython2.8' 'curl' 'twisted')
+changelog=taskcoach.changelog
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/TaskCoach-$pkgver.tar.gz)
+md5sums=('ef131184e8d7236d80bd07080fe2b014')
+
+build() {
+ cd $srcdir/TaskCoach-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/TaskCoach-$pkgver
+ python2 setup.py install --root=$pkgdir --prefix=/usr
+
+ install -D -m644 icons.in/taskcoach.png $pkgdir/usr/share/pixmaps/taskcoach.png
+ install -D -m644 build.in/linux_common/taskcoach.desktop $pkgdir/usr/share/applications/taskcoach.desktop
+}
diff --git a/taskcoach.changelog b/taskcoach.changelog
new file mode 100644
index 000000000000..ca21511f2d3c
--- /dev/null
+++ b/taskcoach.changelog
@@ -0,0 +1,74 @@
+2014-04-01 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Depends array updated
+
+2011-11-18 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Added the changelog directive
+ Added a package() function
+
+2010-10-20 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Depends array modified to correctly require python2
+
+2010-10-20 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Architecture changed to "any"
+ Running setup script with python2
+ Added python (3.x) to the depends array
+
+2009-06-25 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Using $srcdir and $pkgdir variables
+
+2009-06-13 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ setup.patch no more needed
+
+2009-06-10 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Added a patch for the setup.py script
+
+2009-05-11 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ Home site URL updated
+
+2008-11-12 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ taskcoach.desktop is installed from the source archive
+
+2008-10-14 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ added curl to the dependencies
+ taskcoach.png is installed from the source archive
+
+2008-08-22 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ wxGTK 2.8.8 patch removed
+
+2008-07-07 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUIULD :
+ added a patch for wxGTK 2.8.8
+
+2008-05-20 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ license changed to GPL3
+
+2008-03-26 Angelo "Encelo" Theodorou <encelo@users.sourceforge.net>
+
+ * PKGBUILD :
+ added x86_64 to the arch array
+ downloading from downloads.sourceforge.net