summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
-rw-r--r--tastyworks.pngbin0 -> 52076 bytes
3 files changed, 29 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e783701b418f..500724d40c96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,23 @@
pkgbase = tastyworks
pkgdesc = One of the fastest, most reliable, and most secure trading platforms in the world.
pkgver = 0.27.0
- pkgrel = 1
+ pkgrel = 2
url = https://tastyworks.com/technology.html
arch = x86_64
license = Other
depends = java-runtime
+ depends = lib32-glibc
+ depends = lib32-gcc-libs
+ depends = lib32-libx11
+ depends = lib32-libxext
+ depends = lib32-libxi
+ depends = lib32-libxtst
+ depends = lib32-libxrender
+ depends = lib32-alsa-lib
source = https://download.tastyworks.com/desktop/0.27.0/tastyworks-0.27.0.rpm
- source = https://claytrader.com/wp-content/themes/ClayTrader/images/resources/tastyworks.png
+ source = tastyworks.png
sha256sums = 1e512ea67dc99f0a1108764c960a47e1f4e97ff51c7a62a386843611c22d1965
- sha256sums = 0b566ce89d2030d2fe5e1aa2133c868e23da0c0accc3708b1960e2db7ebe7bcb
+ sha256sums = f47e738b37d5e804ce62581acaabe41efdd8a6f626a396a02b10714ddd1e1f5b
pkgname = tastyworks
diff --git a/PKGBUILD b/PKGBUILD
index 90f705d7b11e..47e1f5ffbbc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,35 @@
pkgname=tastyworks
pkgver=0.27.0
-pkgrel=1
+pkgrel=2
pkgdesc="One of the fastest, most reliable, and most secure trading platforms in the world."
arch=('x86_64')
url="https://tastyworks.com/technology.html"
license=('Other')
-depends=('java-runtime')
+depends=('java-runtime' 'lib32-glibc' 'lib32-gcc-libs'
+ 'lib32-libx11' 'lib32-libxext' 'lib32-libxi'
+ 'lib32-libxtst' 'lib32-libxrender' 'lib32-alsa-lib')
source=("https://download.tastyworks.com/desktop/$pkgver/$pkgname-$pkgver.rpm"
- "https://claytrader.com/wp-content/themes/ClayTrader/images/resources/tastyworks.png")
+ "tastyworks.png")
sha256sums=('1e512ea67dc99f0a1108764c960a47e1f4e97ff51c7a62a386843611c22d1965'
- '0b566ce89d2030d2fe5e1aa2133c868e23da0c0accc3708b1960e2db7ebe7bcb')
+ 'f47e738b37d5e804ce62581acaabe41efdd8a6f626a396a02b10714ddd1e1f5b')
+
+# I'm not sure that the all the lib32 stuff is actually needed. The application seemed to be working
+# fine without it but the "official" install requested those packages. I'll leave them there for
+# now but need to contact tastyworks team for clarification and do some more research.
package() {
cd "$srcdir"
install -d "$pkgdir/opt/$pkgname"
- cp -r "$srcdir/opt/$pkgname/" "$pkgdir/opt/"
+ cp -r "$srcdir/opt/$pkgname/" "$pkgdir/opt/"
- sed -i 's|Name=tastyworks|Name=TastyWorks|' "$srcdir/opt/$pkgname/$pkgname.desktop"
- sed -i 's|Comment=tastyworks|Comment=Trading Platform|' "$srcdir/opt/$pkgname/$pkgname.desktop"
- sed -i 's|Categories=Unknown|Categories=Internet|' "$srcdir/opt/$pkgname/$pkgname.desktop"
+ sed -i 's|Name=tastyworks|Name=TastyWorks|' "$srcdir/opt/$pkgname/$pkgname.desktop"
+ sed -i 's|Comment=tastyworks|Comment=Trading Platform|' "$srcdir/opt/$pkgname/$pkgname.desktop"
+ sed -i 's|Icon=/opt/tastyworks/tastyworks.png|Icon=tastyworks|' "$srcdir/opt/$pkgname/$pkgname.desktop"
+ sed -i 's|Categories=Unknown|Categories=Internet|' "$srcdir/opt/$pkgname/$pkgname.desktop"
- install -Dm 644 "$srcdir/opt/$pkgname/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm 644 "$pkgname.png" "$pkgdir/opt/$pkgname/$pkgname.png"
-} \ No newline at end of file
+ install -Dm 644 "$srcdir/opt/$pkgname/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm 644 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
diff --git a/tastyworks.png b/tastyworks.png
new file mode 100644
index 000000000000..7e3c57d12633
--- /dev/null
+++ b/tastyworks.png
Binary files differ