summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29ad94e5f505..3f283efa6285 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = tauon-music-box
- pkgdesc = A streamlined music player that uses BASS
- pkgver = 5.0.4
+ pkgdesc = A modern streamlined music player
+ pkgver = 5.1.0
pkgrel = 1
url = https://github.com/taiko2k/tauonmb
- arch = x86_64
- license = custom
+ arch = any
+ license = GPL3
depends = python3
depends = noto-fonts
depends = noto-fonts-emoji
@@ -25,14 +25,19 @@ pkgbase = tauon-music-box
depends = python-musicbrainzngs
depends = python-discogs-client
depends = alsa-plugins
+ depends = gstreamer
+ depends = gst-plugins-base
optdepends = ffmpeg: File transcoding
optdepends = noto-fonts-cjk: Matching font for CJK characters
optdepends = p7zip: 7z archive extraction support
optdepends = unrar: RAR archive extraction support
optdepends = python-plexapi: PLEX client streaming
optdepends = picard: Tag editing
- source = https://github.com/Taiko2k/tauonmb/releases/download/v5.0.4/Tauon.Music.Box.v5.0.4.Linux.Bass.64bit.zip
- sha1sums = 64f548b1c807767d533faca1eed154ca97f8a9e7
+ optdepends = gst-plugins-good: Extra GStreamer codecs
+ optdepends = gst-plugins-bad: Extra GStreamer codecs
+ optdepends = gst-plugins-ugly: Extra GStreamer codecs
+ source = https://github.com/Taiko2k/tauonmb/releases/download/v5.1.0/Tauon.Music.Box.v5.1.0.Linux.zip
+ sha1sums = ef382a1b4c6811204d7083df41442bb86d53d724
pkgname = tauon-music-box
diff --git a/PKGBUILD b/PKGBUILD
index 0e2e2f519042..cbf16eb71605 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Maintainer: Taiko2k <captain dot gxj at gmail dot com>
pkgname='tauon-music-box'
-pkgdesc='A streamlined music player that uses BASS'
+pkgdesc='A modern streamlined music player'
url="https://github.com/taiko2k/tauonmb"
-arch=('x86_64')
-license=('custom')
+arch=('any')
+license=('GPL3')
-pkgver=5.0.4
+pkgver=5.1.0
pkgrel=1
-depends=('python3' 'noto-fonts' 'noto-fonts-emoji' 'noto-fonts-extra' 'sdl2_image' 'python-pillow' 'python-pylast' 'python-gobject' 'xdg-utils' 'python-beautifulsoup4' 'python-requests' 'python-cairo' 'python-stagger' 'python-hsaudiotag3k' 'python-flask' 'python-setproctitle' 'flac' 'python-musicbrainzngs' 'python-discogs-client' 'alsa-plugins')
+depends=('python3' 'noto-fonts' 'noto-fonts-emoji' 'noto-fonts-extra' 'sdl2_image' 'python-pillow' 'python-pylast' 'python-gobject' 'xdg-utils' 'python-beautifulsoup4' 'python-requests' 'python-cairo' 'python-stagger' 'python-hsaudiotag3k' 'python-flask' 'python-setproctitle' 'flac' 'python-musicbrainzngs' 'python-discogs-client' 'alsa-plugins' 'gstreamer' 'gst-plugins-base')
-optdepends=('ffmpeg: File transcoding' 'noto-fonts-cjk: Matching font for CJK characters' 'p7zip: 7z archive extraction support' 'unrar: RAR archive extraction support' 'python-plexapi: PLEX client streaming' 'picard: Tag editing')
+optdepends=('ffmpeg: File transcoding' 'noto-fonts-cjk: Matching font for CJK characters' 'p7zip: 7z archive extraction support' 'unrar: RAR archive extraction support' 'python-plexapi: PLEX client streaming' 'picard: Tag editing' 'gst-plugins-good: Extra GStreamer codecs' 'gst-plugins-bad: Extra GStreamer codecs' 'gst-plugins-ugly: Extra GStreamer codecs')
-source=('https://github.com/Taiko2k/tauonmb/releases/download/v5.0.4/Tauon.Music.Box.v5.0.4.Linux.Bass.64bit.zip')
+source=('https://github.com/Taiko2k/tauonmb/releases/download/v5.1.0/Tauon.Music.Box.v5.1.0.Linux.zip')
-sha1sums=('64f548b1c807767d533faca1eed154ca97f8a9e7')
+sha1sums=('ef382a1b4c6811204d7083df41442bb86d53d724')
package() {
@@ -25,7 +25,6 @@ package() {
install -D -m755 "$srcdir/$pkgname/extra/tauonmb.desktop" "$pkgdir/usr/share/applications/tauonmb.desktop"
install -D -m755 "$srcdir/$pkgname/extra/tauonmb-symbolic.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/tauonmb-symbolic.svg"
install -D -m755 "$srcdir/$pkgname/extra/tauonmb.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/tauonmb.svg"
- install -D -m644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cp -R "$srcdir/$pkgname/" "$pkgdir/opt/$pkgname"
}