summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
-rw-r--r--tautulli.service2
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b4f8864aae..ef3752a4f008 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = tautulli
pkgdesc = A Python based monitoring and tracking tool for Plex Media Server.
- pkgver = 2.7.6
+ pkgver = 2.13.4
pkgrel = 1
url = https://github.com/Tautulli/Tautulli
install = tautulli.install
arch = any
license = GPL
- makedepends = python-setuptools
makedepends = curl
- depends = python-pytz
- source = tautulli-2.7.6.tar.gz::https://github.com/Tautulli/Tautulli/archive/v2.7.6.tar.gz
+ makedepends = python-setuptools
+ optdepends = python-pyopenssl: creating self signed certificates
+ optdepends = python-pycryptodomex: encrypting notifications to iOS/Android Tautulli Remote app
+ source = tautulli-2.13.4.tar.gz::https://github.com/Tautulli/Tautulli/archive/v2.13.4.tar.gz
source = tautulli.tmpfiles
source = tautulli.service
source = tautulli.sysusers
- sha256sums = 990c7262e899725ed09e1ce7d8a8061f980fee1ba4aa87cb666ba7930dc5ab7e
+ sha256sums = 134573f77f60488060b672f834e8f12633702729fc9faaf6c449e04942ecf315
sha256sums = a054b8abfabb44d35a97642050286751f77d22e22f3d00077960b370051aa4f4
- sha256sums = 8363c0de54806e43e59cfde564ff57a49883895cfc0e725282889658a224624a
+ sha256sums = 9c0171e17c042bf6809e22991e10b67d16e5bae4289c276514fd4566fc993412
sha256sums = e6bb046d1022f0d2623f42c092f993c395a938a1f2a16c2986e76506bbfb54f8
pkgname = tautulli
diff --git a/PKGBUILD b/PKGBUILD
index 7b15cf41f4de..d0a413fca40e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,19 @@
# Based on package by: Denis Saintilma <1068des@gmail.com>
pkgname=tautulli
-pkgver=2.7.6
+pkgver=2.13.4
pkgrel=1
pkgdesc="A Python based monitoring and tracking tool for Plex Media Server."
arch=('any')
url="https://github.com/Tautulli/Tautulli"
license=('GPL')
makedepends=(
- 'python-setuptools'
'curl'
+ 'python-setuptools'
)
-depends=(
- 'python-pytz'
+optdepends=(
+ 'python-pyopenssl: creating self signed certificates'
+ 'python-pycryptodomex: encrypting notifications to iOS/Android Tautulli Remote app'
)
install='tautulli.install'
source=("$pkgname-$pkgver.tar.gz::https://github.com/Tautulli/Tautulli/archive/v$pkgver.tar.gz"
@@ -23,9 +24,9 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/Tautulli/Tautulli/archive/v
'tautulli.service'
'tautulli.sysusers')
-sha256sums=('990c7262e899725ed09e1ce7d8a8061f980fee1ba4aa87cb666ba7930dc5ab7e'
+sha256sums=('134573f77f60488060b672f834e8f12633702729fc9faaf6c449e04942ecf315'
'a054b8abfabb44d35a97642050286751f77d22e22f3d00077960b370051aa4f4'
- '8363c0de54806e43e59cfde564ff57a49883895cfc0e725282889658a224624a'
+ '9c0171e17c042bf6809e22991e10b67d16e5bae4289c276514fd4566fc993412'
'e6bb046d1022f0d2623f42c092f993c395a938a1f2a16c2986e76506bbfb54f8')
package() {
diff --git a/tautulli.service b/tautulli.service
index f5031b1ed7f7..1ca16ba27cce 100644
--- a/tautulli.service
+++ b/tautulli.service
@@ -10,4 +10,4 @@ ExecStart=/usr/bin/python /usr/lib/tautulli/PlexPy.py --nolaunch --config /var/l
SyslogIdentifier=tautulli
[Install]
-WantedBy=default.target
+WantedBy=multi-user.target