summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a598426ce456
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = tclln
+ pkgdesc = TclLN is a library for integrating a tcl-shell with custom commands
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/TestudoAquatilis/tclln
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ license = LGPLv3
+ makedepends = git
+ makedepends = gcc
+ makedepends = make
+ depends = tcl
+ depends = glib2
+ source = git+https://github.com/TestudoAquatilis/tclln.git
+ md5sums = SKIP
+
+pkgname = tclln
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fa91bce5268
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=tclln
+pkgver=0.9
+pkgrel=1
+pkgdesc="TclLN is a library for integrating a tcl-shell with custom commands"
+url="https://github.com/TestudoAquatilis/tclln"
+arch=('x86_64' 'i686' 'armv7h')
+license=('LGPLv3')
+depends=('tcl' 'glib2')
+optdepends=()
+makedepends=('git' 'gcc' 'make')
+conflicts=()
+replaces=()
+backup=()
+#install='foo.install'
+source=("git+https://github.com/TestudoAquatilis/tclln.git")
+md5sums=('SKIP')
+
+build () {
+ cd "${pkgname}"
+ make lib
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm744 libtclln.so "$pkgdir/usr/lib/libtclln.so"
+ install -Dm644 tclln.pc "$pkgdir/usr/lib/pkgconfig/tclln.pc"
+ install -Dm644 tclln.h "$pkgdir/usr/include/tclln.h"
+}
+
+# vim:set ts=2 sw=2 et: