summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--configure.patch11
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adb9fa141283
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tcloo
+ pkgdesc = Tcl extension for object oriented programming. Tcl 8.5 Only!!!
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://sourceforge.net/projects/tcl/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ depends = tcl85
+ source = http://downloads.sourceforge.net/project/tcl/TclOO%20Package/1.0.2/TclOO1.0.2.tar.gz
+ source = configure.patch
+ md5sums = 1f0d0a86cbbd4955450b42d754c29f15
+ md5sums = e1a87ff1e902fd95434e5b8abe335258
+
+pkgname = tcloo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..219c33a80786
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
+pkgname=tcloo
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Tcl extension for object oriented programming. Tcl 8.5 Only!!!"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/tcl/"
+license=('GPL')
+depends=('glibc' 'tcl85')
+md5sums=(
+'1f0d0a86cbbd4955450b42d754c29f15'
+'e1a87ff1e902fd95434e5b8abe335258'
+)
+
+source=(
+http://downloads.sourceforge.net/project/tcl/TclOO%20Package/$pkgver/TclOO$pkgver.tar.gz
+configure.patch
+)
+
+build() {
+
+ cd $srcdir/TclOO$pkgver
+ patch -p0 <../configure.patch
+ ./configure --prefix=/usr || return 1
+ make || return 1
+
+}
+
+package() {
+
+ cd $srcdir/TclOO$pkgver
+ make DESTDIR=$pkgdir install || return 1
+ #chmod 644 $pkgdir/usr/lib/TclOO0.6/libTclOOstub0.6.a
+
+}
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..1a9a3fd7f7dd
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,11 @@
+--- configure.orig 2015-03-20 11:44:35.629898487 -0600
++++ configure 2015-03-20 11:44:44.773121058 -0600
+@@ -5020,7 +5020,7 @@
+ esac
+ result="Using ${TCL_INCLUDES}"
+ else
+- if test ! -f "${TCL_SRC_DIR}/generic/tclInt.h" ; then
++ if test ! -f "${TCL_SRC_DIR}/tclInt.h" ; then
+ as_fn_error $? "Cannot find private header tclInt.h in ${TCL_SRC_DIR}" "$LINENO" 5
+ fi
+ result="Using srcdir found in tclConfig.sh: ${TCL_SRC_DIR}"