summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 26 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb09c57de6b1..767142a42bcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
pkgbase = tdrop-git
pkgdesc = A WM-Independent dropdown window and terminal creator
- pkgver = 0.1.r23.g682ec14
+ pkgver = 0.4.0.r6.gca08ab9
pkgrel = 1
url = https://github.com/noctuid/tdrop
arch = any
license = Simplified BSD
makedepends = git
depends = bash
+ depends = coreutils
+ depends = gawk
+ depends = procps-ng
depends = xdotool
depends = xorg-xwininfo
depends = xorg-xprop
- optdepends = tmux: session starting support
- optdepends = tmuxinator: session starting support
- optdepends = sxhkd: for a tdrop keybinding
+ optdepends = sxhkd
+ optdepends = tmux
+ optdepends = tmuxinator
+ optdepends = tmuxp
+ optdepends = xorg-xrandr
provides = tdrop
- source = git://github.com/noctuid/tdrop.git
+ source = git+https://github.com/noctuid/tdrop
md5sums = SKIP
pkgname = tdrop-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a0ce8bfa6338..77a3bfedc9e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,33 @@
-# Maintainer: Fox Kiester <noct[at]openmailbox[dot]org>
+# Maintainer: Fox Kiester <noct[at]posteo[dot]net>
_pkgname=tdrop
pkgname=tdrop-git
-pkgver=0.1.r23.g682ec14
+pkgver=0.4.0.r6.gca08ab9
pkgrel=1
pkgdesc="A WM-Independent dropdown window and terminal creator"
arch=('any')
url="https://github.com/noctuid/tdrop"
license=('Simplified BSD')
-depends=('bash' 'xdotool' 'xorg-xwininfo' 'xorg-xprop')
-optdepends=('tmux: session starting support'
- 'tmuxinator: session starting support'
- 'sxhkd: for a tdrop keybinding'
- 'xorg-xrandr: multiple monitor resizing support')
+depends=('bash' 'coreutils' 'gawk' 'procps-ng' 'xdotool' 'xorg-xwininfo'
+ 'xorg-xprop')
+optdepends=(
+ # keybinding support
+ 'sxhkd'
+ # session starting support
+ 'tmux'
+ 'tmuxinator'
+ 'tmuxp'
+ # multiple monitor support
+ 'xorg-xrandr'
+)
makedepends=('git')
provides=("${_pkgname}")
md5sums=('SKIP')
-source=("git://github.com/noctuid/${_pkgname}.git")
+source=("git+https://github.com/noctuid/${_pkgname}")
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {