summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
-rw-r--r--teams.patch9
4 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d130c0ab6764..4836268679e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = teams
pkgdesc = Microsoft Teams for Linux is your chat-centered workspace in Office 365
pkgver = 1.4.00.4855
- pkgrel = 1
+ pkgrel = 2
url = https://teams.microsoft.com/downloads
arch = x86_64
license = custom
@@ -18,7 +18,9 @@ pkgbase = teams
replaces = ms-teams
noextract = teams_1.4.00.4855_amd64.deb
source = https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/teams_1.4.00.4855_amd64.deb
+ source = teams.patch
sha256sums = a91dbdf646f12659fdf8d08831aa06ab1bf4cc6fb981841c36a350f29bd714bc
+ sha256sums = eb6189854bd0ac1c1ac21de21e952603b33b11e0e43ec07d291bc645320fcca8
pkgname = teams
diff --git a/.gitignore b/.gitignore
index f71c635dafda..4b7e4b99e847 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!teams.patch
diff --git a/PKGBUILD b/PKGBUILD
index 9c66bb806c99..62f629053a3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=teams
pkgver=1.4.00.4855
-pkgrel=1
+pkgrel=2
pkgdesc="Microsoft Teams for Linux is your chat-centered workspace in Office 365"
arch=('x86_64')
url="https://teams.microsoft.com/downloads"
@@ -12,13 +12,18 @@ optdepends=("libappindicator-gtk3: Systray indicator support"
"org.freedesktop.secrets: Keyring password store support")
conflicts=("ms-teams")
replaces=("ms-teams")
-source=("https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/${pkgname}_${pkgver}_amd64.deb")
+source=("https://packages.microsoft.com/repos/ms-teams/pool/main/t/teams/${pkgname}_${pkgver}_amd64.deb"
+ "${pkgname}.patch")
noextract=("${pkgname}_${pkgver}_amd64.deb")
-sha256sums=('a91dbdf646f12659fdf8d08831aa06ab1bf4cc6fb981841c36a350f29bd714bc')
+sha256sums=('a91dbdf646f12659fdf8d08831aa06ab1bf4cc6fb981841c36a350f29bd714bc'
+ 'eb6189854bd0ac1c1ac21de21e952603b33b11e0e43ec07d291bc645320fcca8')
package() {
bsdtar -O -xf "${pkgname}_${pkgver}_amd64.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+ # Fix the order of items in the startup script so that the meeting links will work again
+ patch -d "${pkgdir}" -p1 <"${pkgname}".patch
+
# Move license
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
mv "${pkgdir}/usr/share/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"
diff --git a/teams.patch b/teams.patch
new file mode 100644
index 000000000000..24fea9acdaf9
--- /dev/null
+++ b/teams.patch
@@ -0,0 +1,9 @@
+--- a/usr/bin/teams 2021-03-12 10:24:04.000000000 +0100
++++ b/usr/bin/teams 2021-03-12 10:28:00.836868352 +0100
+@@ -8,5 +8,5 @@
+
+ mkdir -p "$TEAMS_LOGS"
+
+-nohup "$TEAMS_PATH" --disable-namespace-sandbox --disable-setuid-sandbox "$@" > "$TEAMS_LOGS/teams-startup.log" 2>&1 &
++nohup "$TEAMS_PATH" "$@" --disable-namespace-sandbox --disable-setuid-sandbox > "$TEAMS_LOGS/teams-startup.log" 2>&1 &
+