summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8387c4df2df2..58140ee5d575 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = teamviewer9
pkgdesc = All-In-One Software for Remote Support and Online Meetings
pkgver = 9.0.32150
- pkgrel = 1
+ pkgrel = 2
url = http://www.teamviewer.com
install = teamviewer.install
arch = i686
arch = x86_64
license = custom
depends = bash
+ provides = teamviewer=9
+ conflicts = teamviewer
options = !strip
source = teamviewer_9.0.32150.i686.rpm::http://download.teamviewer.com/download/version_9x/teamviewer_linux.rpm
sha256sums = 12f00b1dff5e4fc2f49b50dd1e76a7c9fc6920f5d524a2d96879f0bfdc415aa7
diff --git a/PKGBUILD b/PKGBUILD
index a446cf4e5128..35407b0f28cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,16 @@
# Multilib is required. Wine is not required.
# TODO: Does not autostart with startxfce4. Maybe it works with gdm.
-# TODO: Fix 10.0.46203 or wait for new version
-# Test requirements
-# Test in i686 and x86_64
-# Test with root and two non root users. One non root user should start with a blank home dir.
-# Test with outgoing, incoming, and swap connections.
+# Test requirements, [X]=pass for most versions, [x]=pass for some versions, ?=not tested
+# [X] Works in i686 and x86_64
+# [X] Outgoing connections
+# [X] Incoming and swap connection on manual start
+# [x] Auto start and accept connections in text mode
+# [ ] Auto start and accept connections in graphics mode startxfce4
+# [?] Auto start and accept connections in graphics mode gdm
+# [ ] Transfer control from text TV server to graphics TV server when GUI is loaded startxfce4, requires auto start
+# [ ] Transfer clipboard
set -u
pkgname='teamviewer9'
@@ -25,7 +29,7 @@ pkgver=9.0.32150
#pkgver=10.0.41499
#pkgver=10.0.46203 # Patched to work in user (standalone) mode. Does not work with teamviewerd.service.
#pkgver=11.0.50678
-pkgrel=1
+pkgrel=2
_pkgver_major="${pkgver%%.*}"
if [ "${pkgname%-quicksupport}" != "${pkgname}" ]; then
@@ -88,7 +92,8 @@ depends=('bash')
depends_i686=('alsa-lib' 'fontconfig' 'freetype2' 'gcc-libs' 'glib2' 'libice' 'libsm' 'libxdamage' 'libxrandr' 'libxtst' 'pcre' 'zlib' 'libxinerama' 'libpng12' 'qt4')
# From Debian: 'libjpeg6-turbo' 'expat' 'libxau' 'libxdmcp' 'libxcb' 'libx11' 'libxfixes' 'libxext' 'libxrender' 'libxi' 'libxtst' 'util-linux'
depends_x86_64=("${depends_i686[@]/#/lib32-}")
-#conflicts=('teamviewer')
+provides=("teamviewer=${_pkgver_major}")
+conflicts=('teamviewer')
options=('!strip')
install="${pkgname%%[0-9]*}.install"
_verwatch=('https://www.teamviewer.com/en/download/linux.aspx' '\s\+<span id="_ctl2_Version">v\([0-9\.]\+\)</span>.*' 'f')
@@ -276,8 +281,9 @@ check() {
./teamviewer_setup "${_checklibs}"
fi
cat '/tmp/teamviewer-PKGBUILD.tmp'
+ # 9.0.32150 shows a bogus dependency on libwine.so.1
# 10.0.35002 beta shows a bogus dependency on libwine.so.2
- if [ "${pkgver}" != '10.0.35002' ] && grep 'missing' '/tmp/teamviewer-PKGBUILD.tmp'; then
+ if [ "${pkgver}" != '10.0.35002' ] && [ "${pkgver}" != '9.0.32150' ] && grep 'missing' '/tmp/teamviewer-PKGBUILD.tmp'; then
rm -f '/tmp/teamviewer-PKGBUILD.tmp'
false
fi