summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--aur-fixes.diff50
3 files changed, 41 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4e7a033b8cf..5abae348cf00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Feb 21 09:44:31 UTC 2017
+# Thu Mar 30 16:00:50 UTC 2017
pkgbase = telegram-desktop
pkgdesc = Official desktop version of Telegram messaging app.
- pkgver = 1.0.14
+ pkgver = 1.0.26
pkgrel = 1
url = https://desktop.telegram.org/
arch = i686
@@ -53,11 +53,11 @@ pkgbase = telegram-desktop
depends = xcb-util-image
depends = xcb-util-renderutil
depends = hicolor-icon-theme
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.0.14
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.0.26
source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtbase-opensource-src-5.6.2.tar.xz
source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtimageformats-opensource-src-5.6.2.tar.xz
source = https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtwayland-opensource-src-5.6.2.tar.xz
- source = git+https://chromium.googlesource.com/external/gyp
+ source = git+https://chromium.googlesource.com/external/gyp#commit=702ac58e4772
source = telegramdesktop.desktop
source = tg.protocol
source = aur-fixes.diff
@@ -68,7 +68,7 @@ pkgbase = telegram-desktop
sha256sums = SKIP
sha256sums = 41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
- sha256sums = 7993641b29a0fe4379aa7bbd15a1fbd349b28a4894be102937716d97cafa0ee2
+ sha256sums = 6b2f5d0e8e1fc6cd3cfa2255db1f68ced80d6e9246b92df603c3a45aa6e42f4e
pkgname = telegram-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 7686253e3e6a..afa489fe50a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=telegram-desktop
-pkgver=1.0.14
+pkgver=1.0.26
pkgrel=1
pkgdesc='Official desktop version of Telegram messaging app.'
arch=('i686' 'x86_64')
@@ -64,7 +64,7 @@ source=(
"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtbase-opensource-src-$qt_version.tar.xz"
"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtimageformats-opensource-src-$qt_version.tar.xz"
"https://download.qt.io/official_releases/qt/${qt_version%.*}/$qt_version/submodules/qtwayland-opensource-src-$qt_version.tar.xz"
- "git+https://chromium.googlesource.com/external/gyp"
+ "git+https://chromium.googlesource.com/external/gyp#commit=702ac58e4772"
"telegramdesktop.desktop"
"tg.protocol"
"aur-fixes.diff"
@@ -77,7 +77,7 @@ sha256sums=(
'SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
- '7993641b29a0fe4379aa7bbd15a1fbd349b28a4894be102937716d97cafa0ee2'
+ '6be6c0f18ecb1f2f54d79222f3776e308ddc95f2edff752effebe6788904ecfb'
)
prepare() {
@@ -108,6 +108,8 @@ prepare() {
fi
cd "$srcdir/tdesktop"
+ git submodule init
+ git submodule update
git apply "$srcdir/aur-fixes.diff"
}
diff --git a/aur-fixes.diff b/aur-fixes.diff
index af16b163c437..8b798c58ee5a 100644
--- a/aur-fixes.diff
+++ b/aur-fixes.diff
@@ -1,5 +1,5 @@
diff --git a/Telegram/SourceFiles/platform/linux/linux_libs.cpp b/Telegram/SourceFiles/platform/linux/linux_libs.cpp
-index 372a012f..a356ad4a 100644
+index d7a44f40..4586fcd6 100644
--- a/Telegram/SourceFiles/platform/linux/linux_libs.cpp
+++ b/Telegram/SourceFiles/platform/linux/linux_libs.cpp
@@ -45,6 +45,7 @@ bool loadLibrary(QLibrary &lib, const char *name, int version) {
@@ -10,7 +10,7 @@ index 372a012f..a356ad4a 100644
if (!load(lib_gtk, "gtk_init_check", gtk_init_check)) return false;
if (!load(lib_gtk, "gtk_menu_new", gtk_menu_new)) return false;
if (!load(lib_gtk, "gtk_menu_get_type", gtk_menu_get_type)) return false;
-@@ -106,6 +107,10 @@ bool setupGtkBase(QLibrary &lib_gtk) {
+@@ -112,6 +113,10 @@ bool setupGtkBase(QLibrary &lib_gtk) {
if (!load(lib_gtk, "g_slist_free", g_slist_free)) return false;
DEBUG_LOG(("Library gtk functions loaded!"));
@@ -21,7 +21,7 @@ index 372a012f..a356ad4a 100644
if (!gtk_init_check(0, 0)) {
gtk_init_check = nullptr;
DEBUG_LOG(("Failed to gtk_init_check(0, 0)!"));
-@@ -128,6 +133,7 @@ bool setupAppIndicator(QLibrary &lib_indicator) {
+@@ -134,6 +139,7 @@ bool setupAppIndicator(QLibrary &lib_indicator) {
} // namespace
@@ -30,7 +30,7 @@ index 372a012f..a356ad4a 100644
f_gtk_menu_new gtk_menu_new = nullptr;
f_gtk_menu_get_type gtk_menu_get_type = nullptr;
diff --git a/Telegram/SourceFiles/platform/linux/linux_libs.h b/Telegram/SourceFiles/platform/linux/linux_libs.h
-index 1ecae702..80b7e4f4 100644
+index 22421218..266239f4 100644
--- a/Telegram/SourceFiles/platform/linux/linux_libs.h
+++ b/Telegram/SourceFiles/platform/linux/linux_libs.h
@@ -52,6 +52,9 @@ bool load(QLibrary &lib, const char *name, Function &func) {
@@ -43,12 +43,12 @@ index 1ecae702..80b7e4f4 100644
typedef gboolean (*f_gtk_init_check)(int *argc, char ***argv);
extern f_gtk_init_check gtk_init_check;
-diff --git a/Telegram/SourceFiles/stdafx.cpp b/Telegram/SourceFiles/stdafx.cpp
-index 3cc98b84..781ad18f 100644
---- a/Telegram/SourceFiles/stdafx.cpp
-+++ b/Telegram/SourceFiles/stdafx.cpp
-@@ -34,6 +34,7 @@ Q_IMPORT_PLUGIN(QGenericEnginePlugin)
- #elif defined Q_OS_LINUX // Q_OS_LINUX
+diff --git a/Telegram/SourceFiles/qt_static_plugins.cpp b/Telegram/SourceFiles/qt_static_plugins.cpp
+index 1d4896a6..3efd7caa 100644
+--- a/Telegram/SourceFiles/qt_static_plugins.cpp
++++ b/Telegram/SourceFiles/qt_static_plugins.cpp
+@@ -30,6 +30,7 @@ Q_IMPORT_PLUGIN(QGenericEnginePlugin)
+ #elif defined Q_OS_LINUX // Q_OS_WIN | Q_OS_MAC
Q_IMPORT_PLUGIN(QWebpPlugin)
Q_IMPORT_PLUGIN(QXcbIntegrationPlugin)
+Q_IMPORT_PLUGIN(QWaylandIntegrationPlugin)
@@ -56,10 +56,10 @@ index 3cc98b84..781ad18f 100644
Q_IMPORT_PLUGIN(QGenericEnginePlugin)
Q_IMPORT_PLUGIN(QNetworkManagerEnginePlugin)
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
-index 76a6f3e6..0e54d450 100644
+index fb22932c..01b54dfe 100644
--- a/Telegram/gyp/Telegram.gyp
+++ b/Telegram/gyp/Telegram.gyp
-@@ -79,21 +79,18 @@
+@@ -81,21 +81,18 @@
],
'defines': [
@@ -82,11 +82,11 @@ index 76a6f3e6..0e54d450 100644
'<(minizip_loc)',
'<(sp_media_key_tap_loc)',
+ '/usr/include/breakpad',
+ '<(submodules_loc)/GSL/include',
+ '<(submodules_loc)/variant/include',
],
- 'sources': [
- '<@(qrc_files)',
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
-index a8adbaa2..536e22f3 100644
+index a3212210..12868c6b 100644
--- a/Telegram/gyp/qt.gypi
+++ b/Telegram/gyp/qt.gypi
@@ -38,7 +38,6 @@
@@ -96,8 +96,8 @@ index a8adbaa2..536e22f3 100644
- 'qtharfbuzzng',
],
'qt_version%': '<(qt_version)',
- 'linux_path_qt%': '/usr/local/tdesktop/Qt-<(qt_version)',
-@@ -91,19 +90,9 @@
+ 'conditions': [
+@@ -97,19 +96,9 @@
'<@(qt_libs)',
'Qt5DBus',
'Qt5Core',
@@ -120,7 +120,7 @@ index a8adbaa2..536e22f3 100644
],
}],
],
-@@ -208,7 +197,6 @@
+@@ -219,7 +208,6 @@
'<(qt_loc)/plugins/platforminputcontexts',
],
'libraries': [
@@ -128,7 +128,7 @@ index a8adbaa2..536e22f3 100644
'<@(qt_libs_release)',
'<(linux_lib_ssl)',
'<(linux_lib_crypto)',
-@@ -221,12 +209,32 @@
+@@ -232,12 +220,32 @@
'gthread-2.0',
'glib-2.0',
'pthread',
@@ -162,6 +162,18 @@ index a8adbaa2..536e22f3 100644
'-pthread',
'-g',
'-rdynamic',
+diff --git a/Telegram/gyp/settings_linux.gypi b/Telegram/gyp/settings_linux.gypi
+index fde88dcd..1fd1b9cb 100644
+--- a/Telegram/gyp/settings_linux.gypi
++++ b/Telegram/gyp/settings_linux.gypi
+@@ -25,7 +25,6 @@
+ '-pipe',
+ '-g',
+ '-Wall',
+- '-Werror',
+ '-W',
+ '-fPIC',
+ '-Wno-unused-variable',
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
index b42e7443..a2597725 100644
--- a/Telegram/gyp/telegram_linux.gypi