summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--aur-fixes.diff21
3 files changed, 24 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8456d57f5838..9078d8c74653 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed May 31 11:21:12 UTC 2017
+# Mon Jun 26 11:06:18 UTC 2017
pkgbase = telegram-desktop
pkgdesc = Official desktop version of Telegram messaging app.
pkgver = 1.1.7
@@ -75,7 +75,7 @@ pkgbase = telegram-desktop
sha256sums = SKIP
sha256sums = 41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17
sha256sums = d4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb
- sha256sums = b8ced823bf98391e06a8ed5f3e1b4a16aa0e3f15a83c592b97babe6335df0558
+ sha256sums = 2bc0d9236e4f6a3b4e1f366e6873f99bda5ba002bfa4fbcd8f465c723a66cf07
pkgname = telegram-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 02ed5e55e6ba..f0da2ce6b270 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -84,7 +84,7 @@ sha256sums=(
'SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
- 'b8ced823bf98391e06a8ed5f3e1b4a16aa0e3f15a83c592b97babe6335df0558'
+ '2bc0d9236e4f6a3b4e1f366e6873f99bda5ba002bfa4fbcd8f465c723a66cf07'
)
prepare() {
diff --git a/aur-fixes.diff b/aur-fixes.diff
index 906a524fea9e..a0f87bcee090 100644
--- a/aur-fixes.diff
+++ b/aur-fixes.diff
@@ -43,6 +43,27 @@ index 80160d16..68a0622c 100644
'<(submodules_loc)/GSL/include',
'<(submodules_loc)/variant/include',
],
+diff --git a/Telegram/gyp/list_sources.py b/Telegram/gyp/list_sources.py
+index c8fd21f6..a653846a 100644
+--- a/Telegram/gyp/list_sources.py
++++ b/Telegram/gyp/list_sources.py
+@@ -23,6 +23,7 @@ import sys
+ import os
+ import re
+ import time
++import codecs
+
+ def eprint(*args, **kwargs):
+ print(*args, file=sys.stderr, **kwargs)
+@@ -32,7 +33,7 @@ def check_non_empty_moc(file_path):
+ if not os.path.isfile(file_path):
+ return False
+ if re.search(r'\.h$', file_path):
+- with open(file_path, "r") as f:
++ with codecs.open(file_path, mode="r", encoding="utf-8") as f:
+ for line in f:
+ if re.search(r'(^|\s)Q_OBJECT(\s|$)', line):
+ return True
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
index 81c13a18..caa93b5b 100644
--- a/Telegram/gyp/qt.gypi