summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ad546257065..8329efa7571e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegram-desktop-systemqt-notoemoji
pkgdesc = Official Telegram Desktop client (with noto emoji)
- pkgver = 1.4.4
- pkgrel = 2
+ pkgver = 1.4.7
+ pkgrel = 1
url = https://desktop.telegram.org/
arch = x86_64
license = GPL3
@@ -21,7 +21,7 @@ pkgbase = telegram-desktop-systemqt-notoemoji
optdepends = libnotify: desktop notifications
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.4.4
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.4.7
source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip
source = variant::git+https://github.com/mapbox/variant
source = Catch::git+https://github.com/philsquared/Catch
diff --git a/PKGBUILD b/PKGBUILD
index c03d54312861..472233939a53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,14 @@
# Thanks Nicholas Guriev <guriev-ns@ya.ru> for the patches!
# https://github.com/mymedia2/tdesktop
+# Telegram API credentials. The defaults below are Telegram's test keys.
+# You may use you your own here for better API performance
+_api_id='17349'
+_api_hash='344583e45741c457fe1862106095a5eb'
+
pkgname=telegram-desktop-systemqt-notoemoji
-pkgver=1.4.4
-pkgrel=2
+pkgver=1.4.7
+pkgrel=1
pkgdesc='Official Telegram Desktop client (with noto emoji)'
arch=('x86_64')
url="https://desktop.telegram.org/"
@@ -83,6 +88,7 @@ build() {
export CXXFLAGS="$CXXFLAGS $EXTRA_FLAGS"
gyp \
-Dbuild_defines=${GYP_DEFINES} \
+ -Dapi_id=${_api_id} -Dapi_hash=${_api_hash} \
-Gconfig=Release \
--depth=Telegram/gyp --generator-output=../.. -Goutput_dir=out Telegram/gyp/Telegram.gyp --format=cmake
NUM=$((`wc -l < out/Release/CMakeLists.txt` - 2))