summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--CMakeLists.inj5
-rw-r--r--PKGBUILD27
-rw-r--r--libtgvoip-2.patch81
-rw-r--r--no-gtk2.patch9
-rw-r--r--tdesktop.patch105
6 files changed, 75 insertions, 176 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9773f63deeb..5e1bfa80734c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegram-desktop-systemqt-notoemoji
pkgdesc = Official Telegram Desktop client (with noto emoji)
- pkgver = 1.3.9
- pkgrel = 2
+ pkgver = 1.3.10
+ pkgrel = 1
url = https://desktop.telegram.org/
arch = x86_64
license = GPL3
@@ -21,32 +21,32 @@ pkgbase = telegram-desktop-systemqt-notoemoji
optdepends = libnotify: desktop notifications
provides = telegram-desktop
conflicts = telegram-desktop
- source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.3.9
+ source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.3.10
+ source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip
+ source = variant::git+https://github.com/mapbox/variant
source = GSL::git+https://github.com/Microsoft/GSL.git
- source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git
- source = variant::git+https://github.com/mapbox/variant.git
source = Catch::git+https://github.com/philsquared/Catch
+ source = crl::git+https://github.com/telegramdesktop/crl.git
source = https://s3.amazonaws.com/aur-telegram-desktop-notoemoji/noto-emoji-v1.tar.xz
+ source = build-time-optimize.patch.in
source = tg.protocol
source = CMakeLists.inj
source = tdesktop.patch
source = no-gtk2.patch
- source = build-time-optimize.patch.in
source = libtgvoip.patch
- source = libtgvoip-2.patch
+ sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = 376a4860e37b0f60892f362e954f976a563c632579167003b4aacbb24b6fea6aabb4e6952baf6d1a546b961936935cc49cf0e0ce9570320245b6bb326cb149e5
- sha512sums = b87414ceaae19185a8a5749cea1f6d9f3fc3c69b8dd729e3db8790cde00b987c3c827cd30baf0eac579d1884e34aa2f37bb90778c3c0bc9ca211d75a82891b9d
- sha512sums = ccbfca942e9fc5ce94a7e9c74429f3463886a35d887aad39ea74a95a2bfc664e5d6641bf1c46e1cf9b786c8aaa21449ac6bbbbc52c84dea550add80d8ea060d4
- sha512sums = 37eda4cd7c88f8b55f7bc6786dd23af691060c9040b8e5d65dda07ab234397af23c3f699abe2bfec8919f501ce45b8f1d25180f5077480b1ca966308c62f8ecb
- sha512sums = c05351aa9f6503daa6ef8b01adb73c7e71fd01377d833f47f826e184d78dd79628ce7c686ae23a40b7468adcd5af0af9ebce4783113957b6126892aca83c7712
sha512sums = fa7042f370ae4e2e14d083395743cdee25bfedc39ab5273b5d1ab12fb074757cf76dab065f2abcb44cad018920e711142fbf24a2b9cd30f517c5a5b46d6a6182
+ sha512sums = b87414ceaae19185a8a5749cea1f6d9f3fc3c69b8dd729e3db8790cde00b987c3c827cd30baf0eac579d1884e34aa2f37bb90778c3c0bc9ca211d75a82891b9d
+ sha512sums = 2647251940f0d3a2d41ca8a32a592f1ab1e23fe02d3b11d8dc3a54ef34df7c290c9cbf3df76b09970e1cba15c149bc38d49fc824a173d4b21c54edb3c5d5a3da
+ sha512sums = 00b4307143cf599859d9b9b6d7ac4acbe8b407da55a1e3833921e113dc3aed8c61f2e5f2c1c37e81a261ba4b9e6f40d9bf5f8c90c20dcf0820cfb73852cb091d
+ sha512sums = 7a37e0ca582145a56a411585aec0bc94889dc18a80cc038d2efa237e19eebf8b67d56825e068be88f7566b08316ce068d7f20c25729caa33d0e9d6c370325025
sha512sums = d60694dc701aa985b0e82a12c9732b945082470441c687b33167a94f94efcf253baf43bb7280ec160ba338485ee5c62de138e4804cae05f27cc5cf4298166d39
- sha512sums = 251f43bcdfd688a4c7dda082e981569c6cd6332289652576cfdc9f6376eee6e28195ec4a60bcfa002c6358d0f3cbdf215b7d390bbcce2ed560abfc9c606566b5
pkgname = telegram-desktop-systemqt-notoemoji
diff --git a/CMakeLists.inj b/CMakeLists.inj
index 0f12632c29a0..24ed27799bce 100644
--- a/CMakeLists.inj
+++ b/CMakeLists.inj
@@ -11,10 +11,5 @@ include(../../Telegram/gyp/PrecompiledHeader.cmake)
add_precompiled_header(Telegram ../../Telegram/SourceFiles/stdafx.h)
add_precompiled_header(lib_export ../../Telegram/SourceFiles/export/export_pch.h)
-# use gcc-ar and gcc-nm, also from gyp.diff
-# https://github.com/telegramdesktop/tdesktop/commit/1e10529f20507e1d22a287ef5e4de88f72d592ca
-set(CMAKE_NM "/usr/bin/gcc-nm")
-set(CMAKE_RANLIB "/usr/bin/gcc-ranlib")
-
# vim: ft=cmake
# -------------- debian/CMakeLists.inj end --------------
diff --git a/PKGBUILD b/PKGBUILD
index 080057867288..fc2b06de12e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-systemqt-notoemoji
-pkgver=1.3.9
-pkgrel=2
+pkgver=1.3.10
+pkgrel=1
pkgdesc='Official Telegram Desktop client (with noto emoji)'
arch=('x86_64')
url="https://desktop.telegram.org/"
@@ -21,32 +21,32 @@ provides=('telegram-desktop')
_emojiver="v1"
source=(
"tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v$pkgver"
+ "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip"
+ "variant::git+https://github.com/mapbox/variant"
"GSL::git+https://github.com/Microsoft/GSL.git"
- "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git"
- "variant::git+https://github.com/mapbox/variant.git"
"Catch::git+https://github.com/philsquared/Catch"
+ "crl::git+https://github.com/telegramdesktop/crl.git"
"https://s3.amazonaws.com/aur-telegram-desktop-notoemoji/noto-emoji-${_emojiver}.tar.xz"
+ "build-time-optimize.patch.in"
"tg.protocol"
"CMakeLists.inj"
"tdesktop.patch"
"no-gtk2.patch"
- "build-time-optimize.patch.in"
"libtgvoip.patch"
- "libtgvoip-2.patch"
)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'376a4860e37b0f60892f362e954f976a563c632579167003b4aacbb24b6fea6aabb4e6952baf6d1a546b961936935cc49cf0e0ce9570320245b6bb326cb149e5'
- 'b87414ceaae19185a8a5749cea1f6d9f3fc3c69b8dd729e3db8790cde00b987c3c827cd30baf0eac579d1884e34aa2f37bb90778c3c0bc9ca211d75a82891b9d'
- 'ccbfca942e9fc5ce94a7e9c74429f3463886a35d887aad39ea74a95a2bfc664e5d6641bf1c46e1cf9b786c8aaa21449ac6bbbbc52c84dea550add80d8ea060d4'
- '37eda4cd7c88f8b55f7bc6786dd23af691060c9040b8e5d65dda07ab234397af23c3f699abe2bfec8919f501ce45b8f1d25180f5077480b1ca966308c62f8ecb'
- 'c05351aa9f6503daa6ef8b01adb73c7e71fd01377d833f47f826e184d78dd79628ce7c686ae23a40b7468adcd5af0af9ebce4783113957b6126892aca83c7712'
'fa7042f370ae4e2e14d083395743cdee25bfedc39ab5273b5d1ab12fb074757cf76dab065f2abcb44cad018920e711142fbf24a2b9cd30f517c5a5b46d6a6182'
- 'd60694dc701aa985b0e82a12c9732b945082470441c687b33167a94f94efcf253baf43bb7280ec160ba338485ee5c62de138e4804cae05f27cc5cf4298166d39'
- '251f43bcdfd688a4c7dda082e981569c6cd6332289652576cfdc9f6376eee6e28195ec4a60bcfa002c6358d0f3cbdf215b7d390bbcce2ed560abfc9c606566b5')
+ 'b87414ceaae19185a8a5749cea1f6d9f3fc3c69b8dd729e3db8790cde00b987c3c827cd30baf0eac579d1884e34aa2f37bb90778c3c0bc9ca211d75a82891b9d'
+ '2647251940f0d3a2d41ca8a32a592f1ab1e23fe02d3b11d8dc3a54ef34df7c290c9cbf3df76b09970e1cba15c149bc38d49fc824a173d4b21c54edb3c5d5a3da'
+ '00b4307143cf599859d9b9b6d7ac4acbe8b407da55a1e3833921e113dc3aed8c61f2e5f2c1c37e81a261ba4b9e6f40d9bf5f8c90c20dcf0820cfb73852cb091d'
+ '7a37e0ca582145a56a411585aec0bc94889dc18a80cc038d2efa237e19eebf8b67d56825e068be88f7566b08316ce068d7f20c25729caa33d0e9d6c370325025'
+ 'd60694dc701aa985b0e82a12c9732b945082470441c687b33167a94f94efcf253baf43bb7280ec160ba338485ee5c62de138e4804cae05f27cc5cf4298166d39')
prepare() {
cd "$srcdir/tdesktop"
@@ -55,7 +55,9 @@ prepare() {
git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch"
+ git config submodule.Telegram/ThirdParty/crl.url "$srcdir/crl"
git submodule update
+
patch -Np1 -i "$srcdir/tdesktop.patch"
patch -Np1 -i "$srcdir/no-gtk2.patch"
@@ -65,7 +67,6 @@ prepare() {
cd "Telegram/ThirdParty/libtgvoip"
patch -Np1 -i "$srcdir/libtgvoip.patch"
- # patch -Np1 -i "$srcdir/libtgvoip-2.patch"
for x in "" "_125x" "_150x" "_200x" "_250x"; do
cp -vf "$srcdir/noto-emoji-${_emojiver}/emoji$x.webp" "$srcdir/tdesktop/Telegram/Resources/art/emoji$x.webp"
diff --git a/libtgvoip-2.patch b/libtgvoip-2.patch
deleted file mode 100644
index 61fa35b80dd6..000000000000
--- a/libtgvoip-2.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From f2e246c1bfd456646880f4df8062337a53407343 Mon Sep 17 00:00:00 2001
-From: Nicholas Guriev <guriev-ns@ya.ru>
-Date: Thu, 6 Jul 2017 23:19:12 +0300
-Subject: [PATCH 1/2] Remove deprecated call of AES_ctr128_encrypt
-
- * The AES_ctr128_encrypt function is not available in OpenSSL 1.1.0
- without a special compiler flag
- * Fix a small misspelling
----
- VoIPController.cpp | 7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/VoIPController.cpp b/VoIPController.cpp
-index 78e9e4b..c81673f 100644
---- a/VoIPController.cpp
-+++ b/VoIPController.cpp
-@@ -102,6 +102,7 @@ bool VoIPController::didInitWin32TimeScale = false;
- #ifndef TGVOIP_USE_CUSTOM_CRYPTO
- #include <openssl/sha.h>
- #include <openssl/aes.h>
-+#include <openssl/modes.h>
- #include <openssl/rand.h>
-
- void tgvoip_openssl_aes_ige_encrypt(uint8_t* in, uint8_t* out, size_t length, uint8_t* key, uint8_t* iv){
-@@ -131,7 +132,7 @@ void tgvoip_openssl_sha256(uint8_t* msg, size_t len, uint8_t* output){
- void tgvoip_openssl_aes_ctr_encrypt(uint8_t* inout, size_t length, uint8_t* key, uint8_t* iv, uint8_t* ecount, uint32_t* num){
- AES_KEY akey;
- AES_set_encrypt_key(key, 32*8, &akey);
-- AES_ctr128_encrypt(inout, inout, length, &akey, iv, ecount, num);
-+ CRYPTO_ctr128_encrypt(inout, inout, length, &akey, iv, ecount, num, (block128_f) AES_encrypt);
- }
-
- voip_crypto_functions_t VoIPController::crypto={
-@@ -1142,7 +1143,7 @@ simpleAudioBlock random_id:long random_bytes:string raw_data:string = DecryptedA
- if(!micMuted){
- audioInput->Start();
- if(!audioInput->IsInitialized()){
-- LOGE("Erorr initializing audio capture");
-+ LOGE("Error initializing audio capture");
- lastError=TGVOIP_ERROR_AUDIO_IO;
-
- SetState(STATE_FAILED);
-@@ -1150,7 +1151,7 @@ simpleAudioBlock random_id:long random_bytes:string raw_data:string = DecryptedA
- }
- }
- if(!audioOutput->IsInitialized()){
-- LOGE("Erorr initializing audio playback");
-+ LOGE("Error initializing audio playback");
- lastError=TGVOIP_ERROR_AUDIO_IO;
-
- SetState(STATE_FAILED);
-
-From b0c6da9bdc68fd692d3a4e620a75e7f4ef10555b Mon Sep 17 00:00:00 2001
-From: Nicholas Guriev <guriev-ns@ya.ru>
-Date: Fri, 8 Dec 2017 23:16:12 +0300
-Subject: [PATCH 2/2] Add extern "C" wrapper
-
-It perhaps fixes build failure against ancient OpenSSL.
-
-See also: https://github.com/openssl/openssl/commit/17e80c6
----
- VoIPController.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/VoIPController.cpp b/VoIPController.cpp
-index c81673f..1003e50 100644
---- a/VoIPController.cpp
-+++ b/VoIPController.cpp
-@@ -100,10 +100,12 @@ bool VoIPController::didInitWin32TimeScale = false;
- #define SHA256_LENGTH 32
-
- #ifndef TGVOIP_USE_CUSTOM_CRYPTO
-+extern "C" {
- #include <openssl/sha.h>
- #include <openssl/aes.h>
- #include <openssl/modes.h>
- #include <openssl/rand.h>
-+}
-
- void tgvoip_openssl_aes_ige_encrypt(uint8_t* in, uint8_t* out, size_t length, uint8_t* key, uint8_t* iv){
- AES_KEY akey;
diff --git a/no-gtk2.patch b/no-gtk2.patch
index c510ef8b1c0d..f2384e322dc0 100644
--- a/no-gtk2.patch
+++ b/no-gtk2.patch
@@ -1,8 +1,7 @@
-diff --git a/Telegram/SourceFiles/platform/linux/linux_libs.cpp b/Telegram/SourceFiles/platform/linux/linux_libs.cpp
-index b2d12a838..77c6abf7d 100644
---- a/Telegram/SourceFiles/platform/linux/linux_libs.cpp
-+++ b/Telegram/SourceFiles/platform/linux/linux_libs.cpp
-@@ -240,24 +240,12 @@ void start() {
+diff -Naur tdesktop-1.2.6.orig/Telegram/SourceFiles/platform/linux/linux_libs.cpp tdesktop-1.2.6/Telegram/SourceFiles/platform/linux/linux_libs.cpp
+--- tdesktop-1.2.6.orig/Telegram/SourceFiles/platform/linux/linux_libs.cpp 2017-12-30 11:13:48.000000000 +0100
++++ tdesktop-1.2.6/Telegram/SourceFiles/platform/linux/linux_libs.cpp 2018-01-17 11:41:49.593275952 +0100
+@@ -253,24 +253,12 @@
indicatorLoaded = setupAppIndicator(lib_indicator);
}
}
diff --git a/tdesktop.patch b/tdesktop.patch
index 26099853dd6b..ff87d80154c4 100644
--- a/tdesktop.patch
+++ b/tdesktop.patch
@@ -1,5 +1,5 @@
diff --git a/Telegram/Resources/qrc/telegram_linux.qrc b/Telegram/Resources/qrc/telegram_linux.qrc
-index 0554fa179..3ea027406 100644
+index 0554fa17..3ea02740 100644
--- a/Telegram/Resources/qrc/telegram_linux.qrc
+++ b/Telegram/Resources/qrc/telegram_linux.qrc
@@ -1,5 +1,4 @@
@@ -9,10 +9,10 @@ index 0554fa179..3ea027406 100644
</qresource>
</RCC>
diff --git a/Telegram/SourceFiles/core/launcher.cpp b/Telegram/SourceFiles/core/launcher.cpp
-index 207885898..1a70da99a 100644
+index bf21d14d..6b63016e 100644
--- a/Telegram/SourceFiles/core/launcher.cpp
+++ b/Telegram/SourceFiles/core/launcher.cpp
-@@ -37,9 +37,10 @@ void Launcher::init() {
+@@ -44,9 +44,10 @@ void Launcher::init() {
QCoreApplication::setApplicationName(qsl("TelegramDesktop"));
@@ -25,7 +25,7 @@ index 207885898..1a70da99a 100644
initHook();
}
-@@ -57,6 +58,13 @@ int Launcher::exec() {
+@@ -64,6 +65,13 @@ int Launcher::exec() {
Logs::start(this); // must be started before Platform is started
Platform::start(); // must be started before QApplication is created
@@ -40,10 +40,10 @@ index 207885898..1a70da99a 100644
DEBUG_LOG(("Telegram finished, result: %1").arg(result));
diff --git a/Telegram/SourceFiles/platform/linux/linux_libs.h b/Telegram/SourceFiles/platform/linux/linux_libs.h
-index 6f93d69cd..df185d5a2 100644
+index e9e349be..d82963fa 100644
--- a/Telegram/SourceFiles/platform/linux/linux_libs.h
+++ b/Telegram/SourceFiles/platform/linux/linux_libs.h
-@@ -17,7 +17,7 @@ extern "C" {
+@@ -30,7 +30,7 @@ extern "C" {
} // extern "C"
#ifndef TDESKTOP_DISABLE_UNITY_INTEGRATION
@@ -54,7 +54,7 @@ index 6f93d69cd..df185d5a2 100644
diff --git a/Telegram/SourceFiles/qt_functions.cpp b/Telegram/SourceFiles/qt_functions.cpp
new file mode 100644
-index 000000000..4a722b8d7
+index 00000000..4a722b8d
--- /dev/null
+++ b/Telegram/SourceFiles/qt_functions.cpp
@@ -0,0 +1,94 @@
@@ -153,10 +153,10 @@ index 000000000..4a722b8d7
+ flags |= QTextItem::StrikeOut;
+}
diff --git a/Telegram/SourceFiles/qt_static_plugins.cpp b/Telegram/SourceFiles/qt_static_plugins.cpp
-index e29f348c8..122ff0f5d 100644
+index b975c7a8..f2f876b3 100644
--- a/Telegram/SourceFiles/qt_static_plugins.cpp
+++ b/Telegram/SourceFiles/qt_static_plugins.cpp
-@@ -15,13 +15,4 @@ Q_IMPORT_PLUGIN(QWebpPlugin)
+@@ -28,13 +28,4 @@ Q_IMPORT_PLUGIN(QWebpPlugin)
Q_IMPORT_PLUGIN(QCocoaIntegrationPlugin)
Q_IMPORT_PLUGIN(QGenericEnginePlugin)
#elif defined Q_OS_LINUX // Q_OS_WIN | Q_OS_MAC
@@ -171,10 +171,10 @@ index e29f348c8..122ff0f5d 100644
-Q_IMPORT_PLUGIN(QHimePlatformInputContextPlugin)
#endif // Q_OS_WIN | Q_OS_MAC | Q_OS_LINUX
diff --git a/Telegram/SourceFiles/ui/text/text.cpp b/Telegram/SourceFiles/ui/text/text.cpp
-index 944f58479..887c1982f 100644
+index 7d34a19b..a4b3d31a 100644
--- a/Telegram/SourceFiles/ui/text/text.cpp
+++ b/Telegram/SourceFiles/ui/text/text.cpp
-@@ -1750,11 +1750,11 @@ private:
+@@ -1707,11 +1707,11 @@ private:
if (item == -1)
return;
@@ -190,10 +190,10 @@ index 944f58479..887c1982f 100644
auto blockIndex = _lineStartBlock;
auto currentBlock = _t->_blocks[blockIndex].get();
diff --git a/Telegram/SourceFiles/ui/text/text_block.cpp b/Telegram/SourceFiles/ui/text/text_block.cpp
-index 2959cec77..04ad00645 100644
+index a10b5393..4e1eb62d 100644
--- a/Telegram/SourceFiles/ui/text/text_block.cpp
+++ b/Telegram/SourceFiles/ui/text/text_block.cpp
-@@ -332,6 +332,9 @@ TextBlock::TextBlock(const style::font &font, const QString &str, QFixed minResi
+@@ -333,6 +333,9 @@ TextBlock::TextBlock(const style::font &font, const QString &str, QFixed minResi
QStackTextEngine engine(part, blockFont->f);
BlockParser parser(&engine, this, minResizeWidth, _from, part);
@@ -204,10 +204,10 @@ index 2959cec77..04ad00645 100644
CrashReports::ClearAnnotationRef("CrashString");
}
diff --git a/Telegram/SourceFiles/ui/twidget.cpp b/Telegram/SourceFiles/ui/twidget.cpp
-index 0f610cb8a..b005589b6 100644
+index dacb848a..f64c9b66 100644
--- a/Telegram/SourceFiles/ui/twidget.cpp
+++ b/Telegram/SourceFiles/ui/twidget.cpp
-@@ -227,9 +227,9 @@ void sendSynteticMouseEvent(QWidget *widget, QEvent::Type type, Qt::MouseButton
+@@ -248,9 +248,9 @@ void sendSynteticMouseEvent(QWidget *widget, QEvent::Type type, Qt::MouseButton
, button
, QGuiApplication::mouseButtons() | button
, QGuiApplication::keyboardModifiers()
@@ -220,32 +220,32 @@ index 0f610cb8a..b005589b6 100644
ev.setTimestamp(getms());
QGuiApplication::sendEvent(windowHandle, &ev);
diff --git a/Telegram/gyp/PrecompiledHeader.cmake b/Telegram/gyp/PrecompiledHeader.cmake
-index a0e1e0489..bd9bce0c1 100644
+index 5d6830e9..c3f08d3f 100644
--- a/Telegram/gyp/PrecompiledHeader.cmake
+++ b/Telegram/gyp/PrecompiledHeader.cmake
-@@ -114,7 +114,7 @@ function(add_precompiled_header _target _input)
+@@ -112,7 +112,7 @@ function(add_precompiled_header _target _input)
set(_compiler_FLAGS "@${_pch_c_flags_file}")
add_custom_command(
OUTPUT "${_output_c}"
- COMMAND "${CMAKE_C_COMPILER}" ${_compiler_FLAGS} -x c-header -o "${_output_c}" -c "${_pchfile}"
-+ COMMAND "${CMAKE_C_COMPILER}" "$(C_DEFINES)" "$(C_INCLUDES)" "$(C_FLAGS)" -x c-header -o "${_output_c}" -c "${_pchfile}"
++ COMMAND "${CMAKE_C_COMPILER}" ${_compiler_FLAGS} "$(C_DEFINES)" "$(C_INCLUDES)" "$(C_FLAGS)" -x c-header -o "${_output_c}" -c "${_pchfile}"
DEPENDS "${_pchfile}" "${_pch_c_flags_file}"
IMPLICIT_DEPENDS C "${_pch_header}"
COMMENT "Precompiling ${_name} for ${_target} (C)")
-@@ -125,7 +125,7 @@ function(add_precompiled_header _target _input)
+@@ -123,7 +123,7 @@ function(add_precompiled_header _target _input)
set(_compiler_FLAGS "@${_pch_cpp_flags_file}")
add_custom_command(
OUTPUT "${_output_cxx}"
- COMMAND "${CMAKE_CXX_COMPILER}" ${_compiler_FLAGS} -x c++-header -o "${_output_cxx}" -c "${_pchfile}"
-+ COMMAND "${CMAKE_CXX_COMPILER}" "$(CXX_DEFINES)" "$(CXX_INCLUDES)" "$(CXX_FLAGS)" -x c++-header -o "${_output_cxx}" -c "${_pchfile}"
++ COMMAND "${CMAKE_CXX_COMPILER}" ${_compiler_FLAGS} "$(CXX_DEFINES)" "$(CXX_INCLUDES)" "$(CXX_FLAGS)" -x c++-header -o "${_output_cxx}" -c "${_pchfile}"
DEPENDS "${_pchfile}" "${_pch_cpp_flags_file}"
IMPLICIT_DEPENDS CXX "${_pch_header}"
- COMMENT "Precompiling header ${_name} for ${_target} (C++)")
+ COMMENT "Precompiling ${_name} for ${_target} (C++)")
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
-index 65917d9b5..d91e55c7a 100644
+index 84a06153..fd7ca47f 100644
--- a/Telegram/gyp/Telegram.gyp
+++ b/Telegram/gyp/Telegram.gyp
-@@ -74,14 +74,12 @@
+@@ -82,13 +82,11 @@
'codegen.gyp:codegen_numbers',
'codegen.gyp:codegen_style',
'tests/tests.gyp:tests',
@@ -260,7 +260,7 @@ index 65917d9b5..d91e55c7a 100644
'AL_ALEXT_PROTOTYPES',
'TGVOIP_USE_CXX11_LIB',
'<!@(python -c "for s in \'<(build_defines)\'.split(\',\'): print(s)")',
-@@ -90,15 +88,7 @@
+@@ -97,15 +95,7 @@
'include_dirs': [
'<(src_loc)',
'<(SHARED_INTERMEDIATE_DIR)',
@@ -278,10 +278,10 @@ index 65917d9b5..d91e55c7a 100644
'<(submodules_loc)/GSL/include',
'<(submodules_loc)/variant/include',
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
-index 0b783ec21..3f917765a 100644
+index dea127a3..62c95e68 100644
--- a/Telegram/gyp/qt.gypi
+++ b/Telegram/gyp/qt.gypi
-@@ -14,25 +14,21 @@
+@@ -27,25 +27,21 @@
[ 'build_macold', {
'qt_version%': '5.3.2',
}, {
@@ -309,7 +309,7 @@ index 0b783ec21..3f917765a 100644
}]
]
},
-@@ -72,32 +68,13 @@
+@@ -85,32 +81,13 @@
],
}],
[ 'build_linux', {
@@ -345,7 +345,7 @@ index 0b783ec21..3f917765a 100644
],
}],
],
-@@ -127,11 +104,6 @@
+@@ -140,11 +117,6 @@
# '<!@(python <(DEPTH)/list_sources.py [sources] <(qt_moc_list_sources_arg))'
# where [sources] contains all your source files
'qt_moc_list_sources_arg': '--moc-prefix SHARED_INTERMEDIATE_DIR/<(_target_name)/moc/moc_',
@@ -357,7 +357,7 @@ index 0b783ec21..3f917765a 100644
},
'configurations': {
-@@ -180,14 +152,14 @@
+@@ -193,14 +165,14 @@
},
'include_dirs': [
@@ -380,7 +380,7 @@ index 0b783ec21..3f917765a 100644
],
'library_dirs': [
'<(qt_loc)/lib',
-@@ -212,17 +184,10 @@
+@@ -225,17 +197,10 @@
],
'libraries': [
'<(PRODUCT_DIR)/obj.target/liblinux_glibc_wraps.a',
@@ -399,7 +399,7 @@ index 0b783ec21..3f917765a 100644
'-lglib-2.0',
'-lpthread',
],
-@@ -230,7 +195,6 @@
+@@ -243,7 +208,6 @@
'<(qt_loc)/mkspecs/linux-g++',
],
'ldflags': [
@@ -408,10 +408,10 @@ index 0b783ec21..3f917765a 100644
'-rdynamic',
],
diff --git a/Telegram/gyp/qt_moc.gypi b/Telegram/gyp/qt_moc.gypi
-index 464d3c818..f350da8f3 100644
+index fae668dc..99e184a3 100644
--- a/Telegram/gyp/qt_moc.gypi
+++ b/Telegram/gyp/qt_moc.gypi
-@@ -12,7 +12,7 @@
+@@ -25,7 +25,7 @@
'<(SHARED_INTERMEDIATE_DIR)/<(_target_name)/moc/moc_<(RULE_INPUT_ROOT).cpp',
],
'action': [
@@ -421,10 +421,10 @@ index 464d3c818..f350da8f3 100644
# Silence "Note: No relevant classes found. No output generated."
'--no-notes',
diff --git a/Telegram/gyp/qt_rcc.gypi b/Telegram/gyp/qt_rcc.gypi
-index f5624a82b..1129a95c5 100644
+index eebc6967..19a346fe 100644
--- a/Telegram/gyp/qt_rcc.gypi
+++ b/Telegram/gyp/qt_rcc.gypi
-@@ -15,7 +15,7 @@
+@@ -28,7 +28,7 @@
'<(SHARED_INTERMEDIATE_DIR)/<(_target_name)/qrc/qrc_<(RULE_INPUT_ROOT).cpp',
],
'action': [
@@ -434,10 +434,10 @@ index f5624a82b..1129a95c5 100644
'-no-compress',
'<(RULE_INPUT_PATH)',
diff --git a/Telegram/gyp/settings_linux.gypi b/Telegram/gyp/settings_linux.gypi
-index 17219fa2c..b00fd50ea 100644
+index b93bace4..0fcdfd56 100644
--- a/Telegram/gyp/settings_linux.gypi
+++ b/Telegram/gyp/settings_linux.gypi
-@@ -11,7 +11,6 @@
+@@ -24,7 +24,6 @@
'linux_common_flags': [
'-pipe',
'-Wall',
@@ -445,15 +445,6 @@ index 17219fa2c..b00fd50ea 100644
'-W',
'-fPIC',
'-Wno-unused-variable',
-@@ -43,7 +42,7 @@
- 'sources': [ '__Wrong_Official_Build_Target_<(official_build_target)_' ],
- }],
- ],
-- }], [ '"<!(uname -p)" == "x86_64"', {
-+ }], [ '"<!(uname -m)" == "x86_64"', {
- # 32 bit version can't be linked with debug info or LTO,
- # virtual memory exhausted :(
- 'cflags_c': [ '-g' ],
@@ -60,7 +59,6 @@
],
'defines': [
@@ -463,10 +454,10 @@ index 17219fa2c..b00fd50ea 100644
],
'cflags_c': [
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
-index 01231c4d1..00a9c0875 100644
+index f6918c22..50f0d8c7 100644
--- a/Telegram/gyp/telegram_linux.gypi
+++ b/Telegram/gyp/telegram_linux.gypi
-@@ -20,10 +20,11 @@
+@@ -33,10 +33,11 @@
'linux_path_va%': '/usr/local',
'linux_path_vdpau%': '/usr/local',
'linux_path_breakpad%': '/usr/local',
@@ -479,7 +470,7 @@ index 01231c4d1..00a9c0875 100644
'/usr/local/include',
'<(linux_path_ffmpeg)/include',
'<(linux_path_openal)/include',
-@@ -32,6 +33,7 @@
+@@ -45,6 +46,7 @@
'<(linux_path_range)/include',
],
'library_dirs': [
@@ -487,7 +478,7 @@ index 01231c4d1..00a9c0875 100644
'/usr/local/lib',
'<(linux_path_ffmpeg)/lib',
'<(linux_path_openal)/lib',
-@@ -40,25 +42,15 @@
+@@ -53,25 +55,16 @@
'<(linux_path_breakpad)/lib',
],
'libraries': [
@@ -519,17 +510,11 @@ index 01231c4d1..00a9c0875 100644
+ 'minizip',
+ 'opus',
+ 'z',
++ 'lzma',
# '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',
],
'cflags_cc': [
-@@ -87,16 +79,14 @@
- },
- },
- 'conditions': [
-- [ '"<!(uname -p)" != "x86_64"', {
-+ [ '"<!(uname -m)" != "x86_64"', {
- 'ldflags': [
- '-Wl,-wrap,__divmoddi4',
+@@ -118,10 +110,8 @@
],
}], ['not_need_gtk!="True"', {
'cflags_cc': [
@@ -543,10 +528,10 @@ index 01231c4d1..00a9c0875 100644
}]
],
diff --git a/Telegram/gyp/telegram_sources.txt b/Telegram/gyp/telegram_sources.txt
-index 7a103286b..397d2a2ac 100644
+index 5d2f627e..defd475d 100644
--- a/Telegram/gyp/telegram_sources.txt
+++ b/Telegram/gyp/telegram_sources.txt
-@@ -797,14 +797,7 @@
+@@ -713,14 +713,7 @@
<(emoji_suggestions_loc)/emoji_suggestions.cpp
<(emoji_suggestions_loc)/emoji_suggestions.h