summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..18e6375d7f13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = telepathy-kde-accounts-kcm-git
+ pkgdesc = KCM Module for configuring Telepathy Instant Messaging Accounts
+ pkgver = r1109.608947e
+ pkgrel = 1
+ url = http://community.kde.org/Real-Time_Communication_and_Collaboration
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = intltool
+ depends = telepathy-qt5
+ depends = kaccounts-integration-git
+ conflicts = telepathy-kde-accounts-kcm
+ replaces = telepathy-kde-accounts-kcm-frameworks-git
+ source = git://anongit.kde.org/ktp-accounts-kcm.git
+ sha256sums = SKIP
+
+pkgname = telepathy-kde-accounts-kcm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e0fc5dd0b71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
+# Author: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=telepathy-kde-accounts-kcm-git
+pkgver=r1109.608947e
+pkgrel=1
+pkgdesc='KCM Module for configuring Telepathy Instant Messaging Accounts'
+arch=('i686' 'x86_64')
+url='http://community.kde.org/Real-Time_Communication_and_Collaboration'
+license=('GPL')
+depends=('telepathy-qt5' 'kaccounts-integration-git')
+makedepends=('extra-cmake-modules' 'git' 'intltool')
+conflicts=('telepathy-kde-accounts-kcm')
+replaces=('telepathy-kde-accounts-kcm-frameworks-git')
+source=("git://anongit.kde.org/ktp-accounts-kcm.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ktp-accounts-kcm
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../ktp-accounts-kcm \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}