summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
-rw-r--r--no-bpf.patch39
-rw-r--r--shared-bpf.patch11
-rw-r--r--version-fix.patch11
5 files changed, 14 insertions, 88 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97a2cbad5c67..2bb6bfa9d12d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = teleport
pkgdesc = Modern SSH server for teams managing distributed infrastructure
- pkgver = 7.3.3
+ pkgver = 8.0.0
pkgrel = 1
url = https://github.com/gravitational/teleport
arch = i386
@@ -9,23 +9,20 @@ pkgbase = teleport
arch = aarch64
license = Apache
makedepends = go>=1.16.0
+ makedepends = rust
depends = glibc
provides = tctl
provides = tsh
- source = teleport-7.3.3.tar.gz::https://github.com/gravitational/teleport/archive/refs/tags/v7.3.3.tar.gz
- source = teleport-webassets-15ef31441805c81aae1095a59a9b152a779ccd79.tar.gz::https://github.com/gravitational/webassets/archive/15ef31441805c81aae1095a59a9b152a779ccd79.tar.gz
+ source = teleport-8.0.0.tar.gz::https://github.com/gravitational/teleport/archive/refs/tags/v8.0.0.tar.gz
+ source = teleport-webassets-a1039e35e86aec770db6cdb32321c93356477757.tar.gz::https://github.com/gravitational/webassets/archive/a1039e35e86aec770db6cdb32321c93356477757.tar.gz
source = teleport.service
source = teleport@.service
source = teleport.install
- source = no-bpf.patch
- source = version-fix.patch
- sha256sums = 893fb8e06f28eb5ee48989bf8e4fa2358a41d65d3c0372fe95076c948b530514
- sha256sums = 8082e79fb2c192124192c1c2ba09f0bad7be8e3b3bb93ddfa0221ed4351bf80a
+ sha256sums = 63cd8a169723575ee1658aa26622424038079815cf28443f4a3c770e95c1331f
+ sha256sums = 11010e65d44d8b9bb956ffbaf18249c8cb370d36c47d165f9fc905ea624ce25c
sha256sums = 10ac25cea1b5c193d7f968ca28a1da0e54b847f29c2a0186b46fd853194be38a
sha256sums = 4bc17fdde981f91c5d9972ae0555ee5e8b63a6b67e007c28f83ada80823980fd
sha256sums = ce2dd61cae3c0c3684e7e629f98b77551e66ddedca2194250a34f0efbc674f3a
- sha256sums = 12ba2a2b9d5efd5751799c2a1c3ddefe5aea4daf0f5d38fad4ec7923631e5ec0
- sha256sums = 066c64e374afdefdd799daa0e88ae21fef7b290042c5e852c1ec4f8af705fa62
pkgname = teleport
install = teleport.install
diff --git a/PKGBUILD b/PKGBUILD
index d73ecd089b1a..61b2b1271a67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
pkgname=('teleport' 'teleport-client')
_pkgname=teleport
-pkgver=7.3.3
+pkgver=8.0.0
pkgrel=1
pkgdesc="Modern SSH server for teams managing distributed infrastructure"
arch=('i386' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/gravitational/teleport"
license=('Apache')
depends=('glibc')
-makedepends=('go>=1.16.0')
+makedepends=('go>=1.16.0' 'rust')
provides=('tctl' 'tsh')
-_webassets_ref='15ef31441805c81aae1095a59a9b152a779ccd79'
+_webassets_ref='a1039e35e86aec770db6cdb32321c93356477757'
_go_srcpath="go/src/github.com/gravitational"
@@ -21,17 +21,13 @@ source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/gravitational/teleport
"${_pkgname}-webassets-${_webassets_ref}.tar.gz::https://github.com/gravitational/webassets/archive/${_webassets_ref}.tar.gz"
"teleport.service"
"teleport@.service"
- "teleport.install"
- "no-bpf.patch"
- "version-fix.patch")
+ "teleport.install")
-sha256sums=('893fb8e06f28eb5ee48989bf8e4fa2358a41d65d3c0372fe95076c948b530514'
- '8082e79fb2c192124192c1c2ba09f0bad7be8e3b3bb93ddfa0221ed4351bf80a'
+sha256sums=('63cd8a169723575ee1658aa26622424038079815cf28443f4a3c770e95c1331f'
+ '11010e65d44d8b9bb956ffbaf18249c8cb370d36c47d165f9fc905ea624ce25c'
'10ac25cea1b5c193d7f968ca28a1da0e54b847f29c2a0186b46fd853194be38a'
'4bc17fdde981f91c5d9972ae0555ee5e8b63a6b67e007c28f83ada80823980fd'
- 'ce2dd61cae3c0c3684e7e629f98b77551e66ddedca2194250a34f0efbc674f3a'
- '12ba2a2b9d5efd5751799c2a1c3ddefe5aea4daf0f5d38fad4ec7923631e5ec0'
- '066c64e374afdefdd799daa0e88ae21fef7b290042c5e852c1ec4f8af705fa62')
+ 'ce2dd61cae3c0c3684e7e629f98b77551e66ddedca2194250a34f0efbc674f3a')
prepare() {
install -dm755 "${srcdir}/go/src/github.com"
@@ -59,14 +55,8 @@ build() {
export CGO_LDFLAGS="${LDFLAGS}"
export ADDFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- # Remove BPF support
- patch Makefile "${srcdir}/no-bpf.patch"
-
- # Do not generate version number
- patch Makefile "${srcdir}/version-fix.patch"
-
# Build
- make full
+ PATH="${PATH}:${HOME}/.cargo/bin" make full
# Make sure go path is writable so it can be cleaned up
chmod -R u+w "${srcdir}/go"
diff --git a/no-bpf.patch b/no-bpf.patch
deleted file mode 100644
index 8bec5ca178e7..000000000000
--- a/no-bpf.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/Makefile 2021-08-24 21:17:32.000000000 +0200
-+++ b/Makefile 2021-09-05 17:24:49.684217758 +0200
-@@ -81,36 +81,6 @@
- # We don't compile BPF for anything except regular non-FIPS linux/amd64 for now, as other builds
- # have compilation issues that require fixing.
- with_bpf := no
--ifeq ("$(OS)","linux")
--ifeq ("$(ARCH)","amd64")
--ifneq ("$(wildcard /usr/include/bpf/libbpf.h)","")
--with_bpf := yes
--BPF_TAG := bpf
--BPF_MESSAGE := "with BPF support"
--CLANG ?= $(shell which clang || which clang-10)
--CLANG_FORMAT ?= $(shell which clang-format || which clang-format-10)
--LLVM_STRIP ?= $(shell which llvm-strip || which llvm-strip-10)
--KERNEL_ARCH := $(shell uname -m | sed 's/x86_64/x86/')
--INCLUDES :=
--ER_BPF_BUILDDIR := lib/bpf/bytecode
--RS_BPF_BUILDDIR := lib/restrictedsession/bytecode
--
--# Get Clang's default includes on this system. We'll explicitly add these dirs
--# to the includes list when compiling with `-target bpf` because otherwise some
--# architecture-specific dirs will be "missing" on some architectures/distros -
--# headers such as asm/types.h, asm/byteorder.h, asm/socket.h, asm/sockios.h,
--# sys/cdefs.h etc. might be missing.
--#
--# Use '-idirafter': Don't interfere with include mechanics except where the
--# build would have failed anyways.
--CLANG_BPF_SYS_INCLUDES = $(shell $(CLANG) -v -E - </dev/null 2>&1 \
-- | sed -n '/<...> search starts here:/,/End of search list./{ s| \(/.*\)|-idirafter \1|p }')
--
--CGOFLAG = CGO_ENABLED=1 CGO_LDFLAGS="-Wl,-Bstatic -lbpf -lelf -lz -Wl,-Bdynamic"
--endif
--endif
--endif
--
-
- # Reproducible builds are only availalbe on select targets, and only when OS=linux.
- REPRODUCIBLE ?=
diff --git a/shared-bpf.patch b/shared-bpf.patch
deleted file mode 100644
index b2b17e1cfd0a..000000000000
--- a/shared-bpf.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile 2021-10-09 14:32:07.542062668 +0200
-+++ b/Makefile 2021-10-09 14:32:02.011962129 +0200
-@@ -106,7 +106,7 @@
- CLANG_BPF_SYS_INCLUDES = $(shell $(CLANG) -v -E - </dev/null 2>&1 \
- | sed -n '/<...> search starts here:/,/End of search list./{ s| \(/.*\)|-idirafter \1|p }')
-
--CGOFLAG = CGO_ENABLED=1 CGO_LDFLAGS="-Wl,-Bstatic -lbpf -lelf -lz -Wl,-Bdynamic"
-+CGOFLAG = CGO_ENABLED=1 CGO_LDFLAGS="-Wl,-Bstatic -lelf -lz -Wl,-Bdynamic -lbpf"
- endif
- endif
- endif
diff --git a/version-fix.patch b/version-fix.patch
deleted file mode 100644
index 98e9698555e5..000000000000
--- a/version-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile 2021-10-09 14:34:36.674597134 +0200
-+++ b/Makefile 2021-10-09 14:42:35.534833320 +0200
-@@ -146,7 +146,7 @@
- # This is the default build target for convenience of working on
- # a web UI.
- .PHONY: all
--all: version
-+all:
- @echo "---> Building OSS binaries."
- $(MAKE) $(BINARIES)
-