summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b713e0d4ebdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 21:35:21 UTC 2015
+pkgbase = televize-git
+ pkgdesc = CLI aplication to watch Czech television streams
+ pkgver = r14.9b18d85
+ pkgrel = 1
+ url = https://github.com/ziima/televize
+ arch = any
+ license = apache
+ depends = python2
+ depends = mplayer
+ depends = curl
+ depends = bash
+ source = televize-git::git+https://github.com/ziima/televize.git
+ md5sums = SKIP
+
+pkgname = televize-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ca8b2cfb797
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=televize-git
+pkgdesc="CLI aplication to watch Czech television streams"
+pkgver=r14.9b18d85
+pkgrel=1
+arch=('any')
+url="https://github.com/ziima/televize"
+license=('apache')
+depends=('python2' 'mplayer' 'curl' 'bash')
+source=("${pkgname}"::'git+https://github.com/ziima/televize.git')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ sed -i 's%python %python2 /usr/bin/%' televize
+ sed -i '1s/python/&2/' televize.py
+ install -D -m755 ./televize $pkgdir/usr/bin/ct_televize
+ install -D -m755 ./televize.py $pkgdir/usr/bin/televize.py
+}