summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc9b419b05ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = template-glib-git
+ pkgdesc = A templating library for GLib
+ pkgver = 3.27.90
+ pkgrel = 1
+ url = https://git.gnome.org/browse/template-glib
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ depends = glib2
+ depends = gobject-introspection-runtime
+ provides = template-glib
+ conflicts = template-glib
+ source = git+https://git.gnome.org/browse/template-glib
+ sha256sums = SKIP
+
+pkgname = template-glib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d21f708eb11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Ivan Semkin (ivan at semkin dot ru)
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+_pkgname=template-glib
+pkgname=template-glib-git
+pkgver=3.27.90
+pkgrel=1
+pkgdesc="A templating library for GLib"
+url="https://git.gnome.org/browse/template-glib"
+arch=(x86_64)
+license=(LGPL)
+conflicts=(template-glib)
+provides=(template-glib)
+depends=(glib2 gobject-introspection-runtime)
+makedepends=(git meson vala gobject-introspection gtk-doc)
+source=("git+https://git.gnome.org/browse/template-glib")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson ../$_pkgname -Denable_gtk_doc=true
+ ninja
+}
+
+check() {
+ cd build
+ meson test
+}
+
+package() {
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}