summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a222368c25a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = templight-tools-git
+ pkgdesc = Tools to deal with template instantiation profiles generated by templight
+ pkgver = 2b2322b
+ pkgrel = 1
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = clang-trunk
+ makedepends = ninja
+ provides = templight-tools
+ conflicts = templight-tools
+ source = git+https://github.com/mikael-s-persson/templight-tools
+ md5sums = SKIP
+
+pkgname = templight-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e30b2ca945c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: nontlikeuname
+
+pkgname=templight-tools-git
+pkgver=2b2322b
+pkgrel=1
+pkgdesc="Tools to deal with template instantiation profiles generated by templight"
+arch=(any)
+license=('GPL')
+depends=()
+makedepends=('git' 'cmake' 'clang-trunk' 'ninja')
+#checkdepends=(gcc-objc gnustep-make vala rust gcc-fortran mono boost qt5-base) #gtest or googletest
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/mikael-s-persson/templight-tools')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long --always | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ mkdir -p "${srcdir}/build"
+}
+
+build() {
+ cd "$srcdir/build"
+ cmake -GNinja -DCMAKE_INSTALL_PREFIX:PATH=/usr "../${pkgname%-git}"
+ ninja
+}
+
+package() {
+ cd "$srcdir/build"
+ DESTDIR=${pkgdir} ninja install
+}