summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44ddba94414e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tempus-themes-konsole-git
+ pkgdesc = Tempus themes for Konsole
+ pkgver = r13.0667e36
+ pkgrel = 1
+ url = https://protesilaos.com/tempus-themes
+ arch = any
+ license = GPL3
+ depends = konsole
+ provides = tempus-themes-konsole
+ conflicts = tempus-themes-konsole
+ source = git+https://gitlab.com/protesilaos/tempus-themes-konsole.git
+ sha256sums = SKIP
+
+pkgname = tempus-themes-konsole-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed9512c09a2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
+# Contributor: Protesilaos Stavrou <info at protesilaos dot com>
+pkgname=tempus-themes-konsole-git
+pkgver=r13.0667e36
+pkgrel=1
+pkgdesc="Tempus themes for Konsole"
+arch=('any')
+url="https://protesilaos.com/tempus-themes"
+license=('GPL3')
+depends=('konsole')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://gitlab.com/protesilaos/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -d "$pkgdir/usr/share/konsole"
+ install -Dm644 *.colorscheme "$pkgdir/usr/share/konsole"
+}