summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56f8f9f6c890..e9a9a2494482 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ten-hands-bin
pkgdesc = Simplest way to organize and run tasks
pkgver = 2.10.3
- pkgrel = 3
+ pkgrel = 4
url = https://tenhands.app
arch = x86_64
license = MIT
@@ -30,8 +30,9 @@ pkgbase = ten-hands-bin
depends = nss
depends = expat
depends = gdk-pixbuf2
+ provides = ten-hands
source = ten-hands-2.10.3.deb::https://github.com/saisandeepvaddi/ten-hands/releases/download/v2.10.3/ten-hands-app_2.10.3_amd64.deb
- source = LICENSE::https://github.com/saisandeepvaddi/ten-hands/raw/master/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/saisandeepvaddi/ten-hands/master/LICENSE
sha256sums = 5a1a4d3970a46d1fde2ccb506653f637a8b0edac5a77a64d12a45e723b555daa
sha256sums = 6b30b7530e47b208e4da08c8813ca52c63aae00d74d0b2036548069f59588d02
diff --git a/PKGBUILD b/PKGBUILD
index d2ea9e1fdb66..6506a5efb22e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="ten-hands-bin"
+pkgname=ten-hands-bin
pkgver=2.10.3
-pkgrel=3
+pkgrel=4
pkgdesc="Simplest way to organize and run tasks"
arch=('x86_64')
url='https://tenhands.app'
@@ -11,13 +11,13 @@ depends=('at-spi2-core' 'libxcomposite' 'hicolor-icon-theme' 'libxrandr' 'gtk3'
'glibc' 'libxcb' 'libx11' 'libxext' 'alsa-lib' 'libxfixes' 'nspr' 'libxkbcommon' 'gcc-libs' 'dbus' \
'libdrm' 'libcups' 'pango' 'libxdamage' 'nss' 'expat' 'gdk-pixbuf2')
license=('MIT')
-provides=()
+provides=("${pkgname%-bin}=${pkgver}")
+provides=("${pkgname%-bin}")
source=("${pkgname%-bin}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-app_${pkgver}_amd64.deb"
- "LICENSE::${_githuburl}/raw/master/LICENSE")
+ "LICENSE::https://raw.githubusercontent.com/saisandeepvaddi/ten-hands/master/LICENSE")
sha256sums=('5a1a4d3970a46d1fde2ccb506653f637a8b0edac5a77a64d12a45e723b555daa'
'6b30b7530e47b208e4da08c8813ca52c63aae00d74d0b2036548069f59588d02')
-
package() {
- bsdtar -xf data.tar.xz -C "${pkgdir}"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ bsdtar -xf data.tar.xz -C "${pkgdir}"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file