summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 295142784ad0..292750bd7b45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,39 @@
pkgbase = ten-hands-bin
pkgdesc = Simplest way to organize and run tasks
pkgver = 2.10.3
- pkgrel = 1
+ pkgrel = 2
url = https://tenhands.app
arch = x86_64
license = MIT
+ depends = at-spi2-core
+ depends = libxcomposite
+ depends = hicolor-icon-theme
+ depends = libxrandr
+ depends = gtk3
+ depends = mesa
+ depends = cairo
+ depends = glib2
+ depends = glibc
+ depends = libxcb
+ depends = libx11
+ depends = libxext
+ depends = alsa-lib
+ depends = libxfixes
+ depends = nspr
+ depends = libxkbcommon
+ depends = gcc-libs
+ depends = dbus
+ depends = libdrm
+ depends = libcups
+ depends = pango
+ depends = libxdamage
+ depends = nss
+ depends = expat
+ depends = gdk-pixbuf2
provides = saisandeepvaddi
- source = ten-hands-app-2.10.3.deb::https://github.com/saisandeepvaddi/ten-hands/releases/download/v2.10.3/ten-hands-app_2.10.3_amd64.deb
+ source = ten-hands-2.10.3.deb::https://github.com/saisandeepvaddi/ten-hands/releases/download/v2.10.3/ten-hands-app_2.10.3_amd64.deb
+ source = LICENSE::https://github.com/saisandeepvaddi/ten-hands/raw/master/LICENSE
sha256sums = 5a1a4d3970a46d1fde2ccb506653f637a8b0edac5a77a64d12a45e723b555daa
+ sha256sums = e2be0aca1f5c7b3eed2731e4f7124ad2b77510a6c1a38a44b83c6144354349ea
pkgname = ten-hands-bin
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index c4cf023b5d83..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,22 +0,0 @@
-
-MIT License
-
-Copyright (c) 2020 Sai Sandeep Vaddi
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 23f090ac3c9f..d9e25b03b58d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname=ten-hands-bin
-_pkgname=ten-hands-app
+_pkgname=ten-hands
+pkgname="${_pkgname}-bin"
pkgver=2.10.3
-pkgrel=1
+pkgrel=2
pkgdesc="Simplest way to organize and run tasks"
arch=('x86_64')
url='https://tenhands.app'
_githuburl="https://github.com/saisandeepvaddi/ten-hands"
-depends=()
-license=('MIT')
+depends=(at-spi2-core libxcomposite hicolor-icon-theme libxrandr gtk3 mesa cairo glib2 glibc libxcb libx11 libxext \
+ alsa-lib libxfixes nspr libxkbcommon gcc-libs dbus libdrm libcups pango libxdamage nss expat gdk-pixbuf2)
+license=(MIT)
provides=('saisandeepvaddi')
-source=("${_pkgname}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_amd64.deb")
-sha256sums=('5a1a4d3970a46d1fde2ccb506653f637a8b0edac5a77a64d12a45e723b555daa')
+source=("${_pkgname}-${pkgver}.deb::${_githuburl}/releases/download/v${pkgver}/${_pkgname}-app_${pkgver}_amd64.deb"
+ "LICENSE::${_githuburl}/raw/master/LICENSE")
+sha256sums=('5a1a4d3970a46d1fde2ccb506653f637a8b0edac5a77a64d12a45e723b555daa'
+ 'e2be0aca1f5c7b3eed2731e4f7124ad2b77510a6c1a38a44b83c6144354349ea')
package() {
- bsdtar -xf data.tar.xz -C "${pkgdir}/"
+ bsdtar -xf data.tar.xz -C "${pkgdir}"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file