summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD9
3 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff9bb7766795..3931ed9b6cad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = ten-hands-bin
pkgdesc = Simplest way to organize and run tasks
- pkgver = 2.7.0
+ pkgver = 2.10.0
pkgrel = 1
url = https://tenhands.app
arch = x86_64
license = MIT
depends = gtk3
depends = nss
- depends = libxss
provides = ten-hands
- source = ten-hands-bin-2.7.0.deb::https://github.com/saisandeepvaddi/ten-hands/releases/download/v2.7.0/ten-hands-app_2.7.0_amd64.deb
+ source = ten-hands-bin-2.10.0.deb::https://github.com/saisandeepvaddi/ten-hands/releases/download/v2.10.0/ten-hands-app_2.10.0_amd64.deb
source = LICENSE::https://github.com/saisandeepvaddi/ten-hands/raw/master/LICENSE
- sha256sums = bf11b78ef01a94fd0a5bc231629d92b2c513d963fd8b0479caa7c18a641c12b4
+ sha256sums = 98990cc5088ae35becf0360a3e6906728ebca809b5b249598751d5658e7551fd
sha256sums = 6b30b7530e47b208e4da08c8813ca52c63aae00d74d0b2036548069f59588d02
pkgname = ten-hands-bin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c4cf023b5d83
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+
+MIT License
+
+Copyright (c) 2020 Sai Sandeep Vaddi
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 4a344c944726..f4074661dccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=ten-hands-bin
-pkgver=2.7.0
+pkgver=2.10.0
pkgrel=1
pkgdesc="Simplest way to organize and run tasks"
arch=('x86_64')
url='https://tenhands.app'
depends=('gtk3'
- 'nss'
- 'libxss')
+ 'nss')
license=('MIT')
provides=('ten-hands')
source=("${pkgname}-${pkgver}.deb::https://github.com/saisandeepvaddi/ten-hands/releases/download/v${pkgver}/ten-hands-app_${pkgver}_amd64.deb"
'LICENSE::https://github.com/saisandeepvaddi/ten-hands/raw/master/LICENSE')
-sha256sums=('bf11b78ef01a94fd0a5bc231629d92b2c513d963fd8b0479caa7c18a641c12b4'
+sha256sums=('98990cc5088ae35becf0360a3e6906728ebca809b5b249598751d5658e7551fd'
'6b30b7530e47b208e4da08c8813ca52c63aae00d74d0b2036548069f59588d02')
package() {
tar xvf "${srcdir}/data.tar.xz" -C "${pkgdir}/"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-} \ No newline at end of file
+}