summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d56af1bded1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = termenu-git
+ pkgdesc = Interactive in-line menus for Unix-based terminals
+ pkgver = r198.edf68ef
+ pkgrel = 1
+ url = https://github.com/elifiner/termenu
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = termenu
+ conflicts = termenu
+ options = !emptydirs
+ source = git+https://github.com/elifiner/termenu.git
+ md5sums = SKIP
+
+pkgname = termenu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bb9af283be0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+_name=termenu
+pkgname="${_name}"-git
+pkgver=r198.edf68ef
+pkgrel=1
+pkgdesc="Interactive in-line menus for Unix-based terminals"
+arch=('any')
+url="https://github.com/elifiner/termenu"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+provides=('termenu')
+conflicts=('termenu')
+options=(!emptydirs)
+source=("git+https://github.com/elifiner/termenu.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/"${_name}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd "${srcdir}"/"${_name}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}"/"${_name}"
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${_name}"/LICENSE
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}