aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
-rw-r--r--termius.desktop3
-rw-r--r--tos.html219
-rwxr-xr-xupd.sh27
6 files changed, 191 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 601bba9e0b16..6e5751202bb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,31 @@
pkgbase = termius
pkgdesc = Desktop SSH Client
- pkgver = 5.10.1
+ pkgver = 8.11.0
pkgrel = 1
url = https://www.termius.com/
arch = x86_64
license = custom
makedepends = squashfs-tools
+ depends = at-spi2-core
+ depends = dbus
+ depends = e2fsprogs
+ depends = expat
+ depends = gtk3
+ depends = keyutils
+ depends = libbsd
depends = libnotify
- depends = libappindicator-gtk3
+ depends = libsecret
+ depends = libxss
depends = libxtst
depends = nss
- depends = libxss
- source = termius-5.10.1.snap::https://api.snapcraft.io/api/v1/snaps/download/WkTBXwoX81rBe3s3OTt3EiiLKBx2QhuS_45.snap
+ depends = util-linux-libs
+ depends = xdg-utils
+ optdepends = libappindicator-gtk3
+ source = termius-8.11.0.snap::https://api.snapcraft.io/api/v1/snaps/download/WkTBXwoX81rBe3s3OTt3EiiLKBx2QhuS_186.snap
source = termius.desktop
source = tos.html
- sha512sums = 98c6919c0901bc4b1a4d82016fa9a4f5b5f0092e8055324db4dd6d1264956f9b6ef746fb99297c845c0b4c196476a4e029a26cd4ccf60a00206277908080109e
- sha512sums = 9b0788a02b9bf371de07adec8f3e14f4db8bf83dae6dee60d91027d8ba09cbab253b8b714f980d5c62b72d97e4ac11e6c3985139322bdceaad9f2f0232427656
- sha512sums = 53f9c61fba12b72817c5e7f4e0ac520489265fbf425fa46f13129da66632b41a2a128072d9e0e64e37e4e8feb8424bc1c15eed127d630314e6459ceb2dbafb4b
+ sha512sums = 0762faba98f78ed65bcb5509b4d3aa56b910ae0103cd28cf877165669f4c545408a949c2387ff2a12f2a1e9f41249fb5e8af378adc39fd80c12003947f673442
+ sha512sums = f1ce576d42a624842c9d08807c11580421b708b4bd7fac3aa9874769735df87566012e8fc0f993b08618f31d2f38588cd83d8572a2700f35d42e2761984ca5d0
+ sha512sums = 6ac7c082d1adba92dd911f46f9926f702be0f92a9843e6252364477d81364569eeeee9b37170a6d9000fde644588734cb6a11d165fc0aff3dbfbcd6ad353ca96
pkgname = termius
-
diff --git a/.gitignore b/.gitignore
index 7398a6f1b70d..231bf8958fd3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
*.pkg.tar.xz
+*.pkg.tar.zst
*.snap*
diff --git a/PKGBUILD b/PKGBUILD
index f019dc1d5fbf..fd47f3fa7f1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,29 @@
# Contributor: TBK <aur at jjtc dot eu>
pkgname=termius
-pkgver=5.10.1
+pkgver=8.11.0
pkgrel=1
pkgdesc="Desktop SSH Client"
url="https://www.termius.com/"
arch=('x86_64')
license=('custom')
-depends=('libnotify' 'libappindicator-gtk3' 'libxtst' 'nss' 'libxss')
+depends=('at-spi2-core' 'dbus' 'e2fsprogs' 'expat' 'gtk3' 'keyutils' 'libbsd' 'libnotify' 'libsecret' 'libxss' 'libxtst' 'nss' 'util-linux-libs' 'xdg-utils')
+optdepends=('libappindicator-gtk3')
makedepends=('squashfs-tools')
# Get latest version + link from https://snapcraft.io/termius-app || snap info termius-app || run the following
# curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/termius-app | jq '.download_url' -r
# curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/termius-app | jq '.version' -r
source=(
- "$pkgname-$pkgver.snap::https://api.snapcraft.io/api/v1/snaps/download/WkTBXwoX81rBe3s3OTt3EiiLKBx2QhuS_45.snap"
+ "$pkgname-$pkgver.snap::https://api.snapcraft.io/api/v1/snaps/download/WkTBXwoX81rBe3s3OTt3EiiLKBx2QhuS_186.snap"
"termius.desktop"
"tos.html"
)
-sha512sums=('98c6919c0901bc4b1a4d82016fa9a4f5b5f0092e8055324db4dd6d1264956f9b6ef746fb99297c845c0b4c196476a4e029a26cd4ccf60a00206277908080109e'
- '9b0788a02b9bf371de07adec8f3e14f4db8bf83dae6dee60d91027d8ba09cbab253b8b714f980d5c62b72d97e4ac11e6c3985139322bdceaad9f2f0232427656'
- '53f9c61fba12b72817c5e7f4e0ac520489265fbf425fa46f13129da66632b41a2a128072d9e0e64e37e4e8feb8424bc1c15eed127d630314e6459ceb2dbafb4b')
+sha512sums=('0762faba98f78ed65bcb5509b4d3aa56b910ae0103cd28cf877165669f4c545408a949c2387ff2a12f2a1e9f41249fb5e8af378adc39fd80c12003947f673442'
+ 'f1ce576d42a624842c9d08807c11580421b708b4bd7fac3aa9874769735df87566012e8fc0f993b08618f31d2f38588cd83d8572a2700f35d42e2761984ca5d0'
+ '6ac7c082d1adba92dd911f46f9926f702be0f92a9843e6252364477d81364569eeeee9b37170a6d9000fde644588734cb6a11d165fc0aff3dbfbcd6ad353ca96')
prepare() {
- mkdir $pkgname
+ mkdir -p $pkgname
unsquashfs -f -d $pkgname $pkgname-$pkgver.snap
}
@@ -34,13 +35,21 @@ package() {
cd "$srcdir"/$pkgname
cp -r \
+ chrome_100_percent.pak \
+ chrome_200_percent.pak \
+ chrome_crashpad_handler \
icudtl.dat \
+ libEGL.so \
libffmpeg.so \
+ libGLESv2.so \
+ libvk_swiftshader.so \
+ libvulkan.so.1 \
locales \
resources \
resources.pak \
termius-app \
v8_context_snapshot.bin \
+ vk_swiftshader_icd.json \
"$pkgdir"/opt/$pkgname
cd "$srcdir"
@@ -50,6 +59,7 @@ package() {
find "$pkgdir"/opt/$pkgname/ -type f -exec chmod 644 {} \;
chmod 755 "$pkgdir"/opt/$pkgname/termius-app
+ chmod 755 "$pkgdir"/opt/$pkgname/chrome_crashpad_handler
mkdir -p "$pkgdir"/usr/bin
ln -sf /opt/$pkgname/termius-app "$pkgdir"/usr/bin/$pkgname
diff --git a/termius.desktop b/termius.desktop
index 1e359232df40..4ed4401e712c 100644
--- a/termius.desktop
+++ b/termius.desktop
@@ -4,7 +4,8 @@ Comment=Desktop SSH Client
Exec=termius %U
Terminal=false
Type=Application
-StartupNotify=true
Icon=termius
+StartupNotify=true
StartupWMClass=Termius
+MimeType=x-scheme-handler/termius;
Categories=System;TerminalEmulator;
diff --git a/tos.html b/tos.html
index 6e7fea30d388..862984c04054 100644
--- a/tos.html
+++ b/tos.html
@@ -1,103 +1,138 @@
-<h1>Terms and Conditions</h1>
-<p>Last updated: May 30, 2018</p>
-<p>These Terms and Conditions ("Terms", "Terms and Conditions") govern your relationship with https://www.termius.com
- website and Termius mobile application (the "Service") operated by Crystalnix Limited ("us", "we", or "our").</p>
-<p>Please read these Terms and Conditions carefully before using our website and Termius mobile application (the
- "Service").</p>
-<p>Your access to and use of the Service is conditioned on your acceptance of and compliance with these Terms. These
- Terms apply to all visitors, users and others who access or use the Service.</p>
-<p>By accessing or using the Service you agree to be bound by these Terms. If you disagree with any part of the terms
- then you may not access the Service.</p>
+<h2>Terms and Conditions</h2>
+<p>These Terms and Conditions ("Terms", "Terms and Conditions") govern your relationship
+ with https://www.termius.com website and Termius mobile application (the "Service") operated by Termius
+ Corporation ("us", "we", or "our").</p>
+<p>Please read these Terms and Conditions carefully before using our website and Termius
+ mobile application (the "Service").</p>
+<p>Your access to and use of the Service is conditioned on your acceptance of and
+ compliance with these Terms. These Terms apply to all visitors, users and others who access or use the
+ Service.
+</p>
+<p>By accessing or using the Service you agree to be bound by these Terms. If you disagree
+ with any part of the terms then you may not access the Service.</p>
<h2>Subscriptions</h2>
-<p>Some parts of the Service are billed on a subscription basis ("Subscription(s)"). You will be billed in advance on a
- recurring and periodic basis ("Billing Cycle"). Billing cycles are set either on a monthly or annual basis,
- depending on the type of subscription plan you select when purchasing a Subscription.</p>
-<p>At the end of each Billing Cycle, your Subscription will automatically renew under the exact same conditions unless
- you cancel it or Crystalnix Limited cancels it. You may cancel your Subscription renewal either through your online
- account management page or by contacting Crystalnix Limited customer support team.</p>
-<p>A valid payment method, including credit card or PayPal, is required to process the payment for your Subscription.
- You shall provide Crystalnix Limited with accurate and complete billing information including full name, address,
- state, zip code, telephone number, and a valid payment method information. By submitting such payment information,
- you automatically authorize Crystalnix Limited to charge all Subscription fees incurred through your account to any
- such payment instruments.</p>
-<p>Should automatic billing fail to occur for any reason, Crystalnix Limited will issue an electronic invoice
- indicating that you must proceed manually, within a certain deadline date, with the full payment corresponding to
- the billing period as indicated on the invoice.</p>
+<p>Some parts of the Service are billed on a subscription basis ("Subscription(s)").
+ You will be billed in advance on a recurring and periodic basis ("Billing Cycle"). Billing cycles are
+ set
+ either on a monthly or annual basis, depending on the type of subscription plan you select when
+ purchasing a
+ Subscription.</p>
+<p>At the end of each Billing Cycle, your Subscription will automatically renew under
+ the exact same conditions unless you cancel it or Termius Corporation cancels it. You may cancel your
+ Subscription renewal either through your online account management page or by contacting Termius
+ Corporation
+ customer support team.</p>
+<p>A valid payment method, including credit card or PayPal, is required to process the
+ payment for your Subscription. You shall provide Termius Corporation with accurate and complete billing
+ information including full name, address, state, zip code, telephone number, and a valid payment method
+ information. By submitting such payment information, you automatically authorize Termius Corporation to
+ charge all Subscription fees incurred through your account to any such payment instruments.</p>
+<p>Should automatic billing fail to occur for any reason, Termius Corporation will
+ issue an electronic invoice indicating that you must proceed manually, within a certain deadline date,
+ with
+ the full payment corresponding to the billing period as indicated on the invoice.</p>
<h2>Free Trial</h2>
-<p>Crystalnix Limited may, at its sole discretion, offer a Subscription with a free trial for a limited period of time
- ("Free Trial").</p>
-<p>You may be required to enter your billing information in order to sign up for the Free Trial.</p>
-<p>If you do enter your billing information when signing up for the Free Trial, you will not be charged by Crystalnix
- Limited until the Free Trial has expired. On the last day of the Free Trial period, unless you cancelled your
- Subscription, you will be automatically charged the applicable Subscription fees for the type of Subscription you
- have selected.</p>
-<p>At any time and without notice, Crystalnix Limited reserves the right to (i) modify the terms and conditions of the
- Free Trial offer, or (ii) cancel such Free Trial offer.</p>
+<p>Termius Corporation may, at its sole discretion, offer a Subscription with a free
+ trial for a limited period of time ("Free Trial").</p>
+<p>You may be required to enter your billing information in order to sign up for the
+ Free Trial.</p>
+<p>If you do enter your billing information when signing up for the Free Trial, you
+ will not be charged by Termius Corporation until the Free Trial has expired. On the last day of the Free
+ Trial period, unless you cancelled your Subscription, you will be automatically charged the applicable
+ Subscription fees for the type of Subscription you have selected.</p>
+<p>At any time and without notice, Termius Corporation reserves the right to (i) modify
+ the terms and conditions of the Free Trial offer, or (ii) cancel such Free Trial offer.</p>
<h2>Fee Changes</h2>
-<p>Crystalnix Limited, in its sole discretion and at any time, may modify the Subscription fees for the Subscriptions.
- Any Subscription fee change will become effective at the end of the then-current Billing Cycle.</p>
-<p>Crystalnix Limited will provide you with a reasonable prior notice of any change in Subscription fees to give you an
- opportunity to terminate your Subscription before such change becomes effective.</p>
-<p>Your continued use of the Service after the Subscription fee change comes into effect constitutes your agreement to
- pay the modified Subscription fee amount.</p>
+<p>Termius Corporation, in its sole discretion and at any time, may modify the
+ Subscription fees for the Subscriptions. Any Subscription fee change will become effective at the end of
+ the
+ then-current Billing Cycle.</p>
+<p>Termius Corporation will provide you with a reasonable prior notice of any change in
+ Subscription fees to give you an opportunity to terminate your Subscription before such change becomes
+ effective.</p>
+<p>Your continued use of the Service after the Subscription fee change comes into
+ effect constitutes your agreement to pay the modified Subscription fee amount.</p>
<h2>Refunds</h2>
-<p>Certain refund requests for Subscriptions may be considered by Crystalnix Limited on a case-by-case basis and
- granted in sole discretion of Crystalnix Limited.</p>
+<p>Certain refund requests for Subscriptions may be considered by Termius Corporation
+ on a case-by-case basis and granted in sole discretion of Termius Corporation.</p>
<h2>Accounts</h2>
-<p>When you create an account with us, you must provide us information that is accurate, complete, and current at all
- times. Failure to do so constitutes a breach of the Terms, which may result in immediate termination of your
- account on our Service.</p>
-<p>You are responsible for safeguarding the password that you use to access the Service and for any activities or
- actions under your password, whether your password is with our Service or a third-party service.</p>
-<p>You agree not to disclose your password to any third party. You must notify us immediately upon becoming aware of
- any breach of security or unauthorized use of your account.</p>
-<p>You may not use as a username the name of another person or entity or that is not lawfully available for use, a name
- or trade mark that is subject to any rights of another person or entity other than you without appropriate
- authorization, or a name that is otherwise offensive, vulgar or obscene.</p>
+<p>When you create an account with us, you must provide us information that is
+ accurate, complete, and current at all times. Failure to do so constitutes a breach of the Terms, which
+ may
+ result in immediate termination of your account on our Service.</p>
+<p>You are responsible for safeguarding the password that you use to access the Service
+ and for any activities or actions under your password, whether your password is with our Service or a
+ third-party service.</p>
+<p>You agree not to disclose your password to any third party. You must notify us
+ immediately upon becoming aware of any breach of security or unauthorized use of your account.</p>
+<p>You may not use as a username the name of another person or entity or that is not
+ lawfully available for use, a name or trade mark that is subject to any rights of another person or
+ entity
+ other than you without appropriate authorization, or a name that is otherwise offensive, vulgar or
+ obscene.
+</p>
<h2>Intellectual Property</h2>
-<p>The Service and its original content, features and functionality are and will remain the exclusive property of
- Crystalnix Limited and its licensors. The Service is protected by copyright, trademark, and other laws of both the
- New Zealand and foreign countries. Our trademarks and trade dress may not be used in connection with any product or
- service without the prior written consent of Crystalnix Limited.</p>
+<p>The Service and its original content, features and functionality are and will remain
+ the exclusive property of Termius Corporation and its licensors. The Service is protected by copyright,
+ trademark, and other laws of both the USA and foreign countries. Our trademarks and trade dress may not
+ be
+ used in connection with any product or service without the prior written consent of Termius Corporation.
+</p>
<h2>Links To Other Web Sites</h2>
-<p>Our Service may contain links to third-party web sites or services that are not owned or controlled by Crystalnix
- Limited.</p>
-<p>Crystalnix Limited has no control over, and assumes no responsibility for, the content, privacy policies, or
- practices of any third party web sites or services. You further acknowledge and agree that Crystalnix Limited shall
- not be responsible or liable, directly or indirectly, for any damage or loss caused or alleged to be caused by or
- in connection with use of or reliance on any such content, goods or services available on or through any such web
- sites or services.</p>
-<p>We strongly advise you to read the terms and conditions and privacy policies of any third-party web sites or
- services that you visit.</p>
+<p>Our Service may contain links to third-party web sites or services that are not
+ owned or controlled by Termius Corporation.</p>
+<p>Termius Corporation has no control over, and assumes no responsibility for, the
+ content, privacy policies, or practices of any third party web sites or services. You further
+ acknowledge
+ and agree that Termius Corporation shall not be responsible or liable, directly or indirectly, for any
+ damage or loss caused or alleged to be caused by or in connection with use of or reliance on any such
+ content, goods or services available on or through any such web sites or services.</p>
+<p>We strongly advise you to read the terms and conditions and privacy policies of any
+ third-party web sites or services that you visit.</p>
<h2>Limitation Of Liability</h2>
-<p>In no event shall Crystalnix Limited, nor its directors, employees, partners, agents, suppliers, or affiliates, be
- liable for any indirect, incidental, special, consequential or punitive damages, including without limitation, loss
- of profits, data, use, goodwill, or other intangible losses, resulting from (i) your access to or use of or
- inability to access or use the Service; (ii) any conduct or content of any third party on the Service; (iii) any
- content obtained from the Service; and (iv) unauthorized access, use or alteration of your transmissions or
- content, whether based on warranty, contract, tort (including negligence) or any other legal theory, whether or not
- we have been informed of the possibility of such damage, and even if a remedy set forth herein is found to have
- failed of its essential purpose.</p>
+<p>In no event shall Termius Corporation, nor its directors, employees, partners,
+ agents, suppliers, or affiliates, be liable for any indirect, incidental, special, consequential or
+ punitive
+ damages, including without limitation, loss of profits, data, use, goodwill, or other intangible losses,
+ resulting from (i) your access to or use of or inability to access or use the Service; (ii) any conduct
+ or
+ content of any third party on the Service; (iii) any content obtained from the Service; and (iv)
+ unauthorized access, use or alteration of your transmissions or content, whether based on warranty,
+ contract, tort (including negligence) or any other legal theory, whether or not we have been informed of
+ the
+ possibility of such damage, and even if a remedy set forth herein is found to have failed of its
+ essential
+ purpose.</p>
<h2>Disclaimer</h2>
-<p>Your use of the Service is at your sole risk. The Service is provided on an "AS IS" and "AS AVAILABLE" basis. The
- Service is provided without warranties of any kind, whether express or implied, including, but not limited to,
- implied warranties of merchantability, fitness for a particular purpose, non-infringement or course of performance.</p>
-<p>Crystalnix Limited its subsidiaries, affiliates, and its licensors do not warrant that a) the Service will function
- uninterrupted, secure or available at any particular time or location; b) any errors or defects will be corrected;
- c) the Service is free of viruses or other harmful components; or d) the results of using the Service will meet
- your requirements.</p>
+<p>Your use of the Service is at your sole risk. The Service is provided on an "AS IS"
+ and "AS AVAILABLE" basis. The Service is provided without warranties of any kind, whether express or
+ implied, including, but not limited to, implied warranties of merchantability, fitness for a particular
+ purpose, non-infringement or course of performance.</p>
+<p>Termius Corporation its subsidiaries, affiliates, and its licensors do not warrant
+ that a) the Service will function uninterrupted, secure or available at any particular time or location;
+ b) any errors or defects will be corrected; c) the Service is free of viruses or other harmful components;
+ or d) the results of using the Service will meet your requirements.</p>
<h2>Governing Law</h2>
-<p>These Terms shall be governed and construed in accordance with the laws of New Zealand, without regard to its
- conflict of law provisions.</p>
-<p>Our failure to enforce any right or provision of these Terms will not be considered a waiver of those rights. If any
- provision of these Terms is held to be invalid or unenforceable by a court, the remaining provisions of these Terms
- will remain in effect. These Terms constitute the entire agreement between us regarding our Service, and supersede
- and replace any prior agreements we might have between us regarding the Service.</p>
+<p>These Terms shall be governed and construed in accordance with the laws of the USA,
+ without regard to its conflict of law provisions.</p>
+<p>Our failure to enforce any right or provision of these Terms will not be considered
+ a waiver of those rights. If any provision of these Terms is held to be invalid or unenforceable by a
+ court,
+ the remaining provisions of these Terms will remain in effect. These Terms constitute the entire
+ agreement
+ between us regarding our Service, and supersede and replace any prior agreements we might have between
+ us
+ regarding the Service.</p>
<h2>Changes</h2>
-<p>We reserve the right, at our sole discretion, to modify or replace these Terms at any time. If a revision is
- material we will try to provide at least 30 days notice prior to any new terms taking effect. What constitutes a
- material change will be determined at our sole discretion.</p>
-<p>By continuing to access or use our Service after those revisions become effective, you agree to be bound by the
- revised terms. If you do not agree to the new terms, please stop using the Service.</p>
-<h2>Contact Us</h2>
-<p>If you have any questions about these Terms, please contact us.</p> \ No newline at end of file
+<p>We reserve the right, at our sole discretion, to modify or replace these Terms at
+ any time. If a revision is material we will try to provide at least 30 days notice prior to any new
+ terms
+ taking effect. What constitutes a material change will be determined at our sole discretion.</p>
+<p>By continuing to access or use our Service after those revisions become effective,
+ you agree to be bound by the revised terms. If you do not agree to the new terms, please stop using the
+ Service.</p>
+<h2>Contact</h2>
+<p>Termius is always open to feedback, questions, and suggestions. If you would like to
+ talk to us, please feel free to email us at <a href="mailto:policy@termius.com">policy@termius.com</a>.
+</p>
+<p>Last updated: May 13, 2020</p> \ No newline at end of file
diff --git a/upd.sh b/upd.sh
new file mode 100755
index 000000000000..9d2b4f404069
--- /dev/null
+++ b/upd.sh
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+# Get new version info
+URL=$(curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/termius-app | jq '.download_url' -r | cut -d "_" -f2)
+VER=$(curl -H 'X-Ubuntu-Series: 16' https://api.snapcraft.io/api/v1/snaps/details/termius-app | jq '.version' -r)
+
+# Update PKGBUILD
+sed -i "s/_[0-9]\+.snap/_$URL/g" PKGBUILD
+sed -i "s/pkgver=.*$/pkgver=$VER/g" PKGBUILD
+
+# Calc new hash
+updpkgsums
+
+# Build & install pkg
+makepkg -si
+
+# Update .SRCINFO
+makepkg --printsrcinfo > .SRCINFO
+
+# Git ops
+git add .SRCINFO PKGBUILD
+git commit -m "Update to $VER"
+
+# Cleanup
+rm -rf pkg/ src/ *.snap *.pkg.tar.zst
+
+printf "\nAll done!\nRemember to git push!\n"