summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD23
-rwxr-xr-xpython2.patch21
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51379db65223
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 23 20:29:38 UTC 2015
+pkgbase = testoob
+ pkgdesc = Python Testing Out Of (The) Box - An advanced unit testing framework.
+ pkgver = 1.15
+ pkgrel = 2
+ url = http://code.google.com/p/testoob
+ arch = any
+ license = Apache
+ makedepends = setuptools
+ depends = python2
+ source = https://pypi.python.org/packages/source/t/testoob/testoob-1.15.tar.bz2
+ source = python2.patch
+ md5sums = 604d2556ac01ca8f5d189ad8ffe2c8e5
+ md5sums = db1313e249d228ba34d9f161a220dd98
+
+pkgname = testoob
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..30895f4206e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Oleg Plakhotniuk <olegus EIGHT AT gmail DOT com>
+
+pkgname=testoob
+pkgver=1.15
+pkgrel=2
+pkgdesc="Python Testing Out Of (The) Box - An advanced unit testing framework."
+arch=('any')
+url="http://code.google.com/p/testoob"
+license=('Apache')
+depends=('python2')
+makedepends=('setuptools')
+source=('https://pypi.python.org/packages/source/t/testoob/testoob-1.15.tar.bz2'
+ 'python2.patch')
+md5sums=('604d2556ac01ca8f5d189ad8ffe2c8e5'
+ 'db1313e249d228ba34d9f161a220dd98')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -up1 -i "$srcdir/python2.patch"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/python2.patch b/python2.patch
new file mode 100755
index 000000000000..51d57caacf03
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,21 @@
+--- old/src/testoob/compatibility/trace.py 2009-10-07 17:08:46.000000000 -0500
++++ new/src/testoob/compatibility/trace.py 2014-03-16 21:53:53.332878659 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ # portions copyright 2001, Autonomous Zones Industries, Inc., all rights...
+ # err... reserved and offered to the public under the terms of the
+@@ -739,10 +739,10 @@
+
+ s = s.replace("$prefix",
+ os.path.join(sys.prefix, "lib",
+- "python" + sys.version[:3]))
++ "python2" + sys.version[:3]))
+ s = s.replace("$exec_prefix",
+ os.path.join(sys.exec_prefix, "lib",
+- "python" + sys.version[:3]))
++ "python2" + sys.version[:3]))
+ s = os.path.normpath(s)
+ ignore_dirs.append(s)
+ continue