summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO89
-rw-r--r--PKGBUILD35
-rw-r--r--texlive-full.install23
3 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbad97214f48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,89 @@
+pkgbase = texlive-full
+ pkgdesc = This packages provides texlive-full in /opt. It also tricks ArchLinux into thinking it has its texlive packages installed.
+ pkgver = 20190517
+ pkgrel = 1
+ url = http://www.tug.org/texlive/
+ install = texlive-full.install
+ arch = x86_64
+ license = GPL
+ makedepends = wget
+ makedepends = xz
+ provides = texlive-bin
+ provides = texlive-bibtexextra
+ provides = texlive-core
+ provides = texlive-fontsextra
+ provides = texlive-formatsextra
+ provides = texlive-games
+ provides = texlive-humanities
+ provides = texlive-latexextra
+ provides = texlive-music
+ provides = texlive-pictures
+ provides = texlive-pstricks
+ provides = texlive-publishers
+ provides = texlive-science
+ provides = texlive-bibtexextra
+ provides = texlive-core
+ provides = texlive-fontsextra
+ provides = texlive-formatsextra
+ provides = texlive-games
+ provides = texlive-humanities
+ provides = texlive-latexextra
+ provides = texlive-music
+ provides = texlive-pictures
+ provides = texlive-pstricks
+ provides = texlive-publishers
+ provides = texlive-science
+ provides = texlive-langchinese
+ provides = texlive-langcyrillic
+ provides = texlive-langextra
+ provides = texlive-langgreek
+ provides = texlive-langjapanese
+ provides = texlive-langkorean
+ provides = texlive-langchinese
+ provides = texlive-langcyrillic
+ provides = texlive-langextra
+ provides = texlive-langgreek
+ provides = texlive-langjapanese
+ provides = texlive-langkorean
+ conflicts = texlive-bin
+ conflicts = texlive-bibtexextra
+ conflicts = texlive-core
+ conflicts = texlive-fontsextra
+ conflicts = texlive-formatsextra
+ conflicts = texlive-games
+ conflicts = texlive-humanities
+ conflicts = texlive-latexextra
+ conflicts = texlive-music
+ conflicts = texlive-pictures
+ conflicts = texlive-pstricks
+ conflicts = texlive-publishers
+ conflicts = texlive-science
+ conflicts = texlive-bibtexextra
+ conflicts = texlive-core
+ conflicts = texlive-fontsextra
+ conflicts = texlive-formatsextra
+ conflicts = texlive-games
+ conflicts = texlive-humanities
+ conflicts = texlive-latexextra
+ conflicts = texlive-music
+ conflicts = texlive-pictures
+ conflicts = texlive-pstricks
+ conflicts = texlive-publishers
+ conflicts = texlive-science
+ conflicts = texlive-langchinese
+ conflicts = texlive-langcyrillic
+ conflicts = texlive-langextra
+ conflicts = texlive-langgreek
+ conflicts = texlive-langjapanese
+ conflicts = texlive-langkorean
+ conflicts = texlive-langchinese
+ conflicts = texlive-langcyrillic
+ conflicts = texlive-langextra
+ conflicts = texlive-langgreek
+ conflicts = texlive-langjapanese
+ conflicts = texlive-langkorean
+ source = http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz
+ sha256sums = SKIP
+
+pkgname = texlive-full
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfa35ab6c0bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+
+pkgname=texlive-full
+pkgver=$(date "+%Y%m%d")
+_year=$(date "+%Y")
+pkgrel=1
+pkgdesc="This packages provides texlive-full in /opt. It also tricks ArchLinux into thinking it has its texlive packages installed."
+url="http://www.tug.org/texlive/"
+arch=("x86_64")
+license=("GPL")
+makedepends=("wget" "xz")
+provides=('texlive-bin' $(pacman -Sgq texlive-most texlive-lang))
+conflicts=('texlive-bin' $(pacman -Sgq texlive-most texlive-lang))
+source=("http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz")
+sha256sums=('SKIP')
+install=${pkgname}.install
+#PKGEXT='.pkg.tar'
+
+package() {
+ # creating a profile for unattened installation
+ echo "selected_scheme scheme-full" > "${srcdir}/texlive.profile"
+ echo "TEXDIR ${pkgdir}/opt/texlive/${_year}" >> "${srcdir}/texlive.profile"
+ echo "TEXMFLOCAL ${pkgdir}/opt/texlive/texmf-local" >> "${srcdir}/texlive.profile"
+ echo "TEXMFSYSCONFIG ${pkgdir}/opt/texlive/${_year}/texmf-config" >> "${srcdir}/texlive.profile"
+ echo "TEXMFSYSVAR ${pkgdir}/opt/texlive/${_year}/texmf-var" >> "${srcdir}/texlive.profile"
+ echo "TEXMFHOME ~/.texmf" >> "${srcdir}/texlive.profile"
+
+ # start the installer and install
+ "${srcdir}/install-tl-${pkgver}/install-tl" -profile "${srcdir}/texlive.profile"
+ # remove profile file and installation log
+ rm -vf "${pkgdir}/opt/texlive/${_year}/tlpkg/texlive.profile"
+ rm -vf "${pkgdir}/opt/texlive/${_year}/install-tl.log"
+}
+# vim:set ts=2 sw=2 et:
+
diff --git a/texlive-full.install b/texlive-full.install
new file mode 100644
index 000000000000..1cab89a77a2b
--- /dev/null
+++ b/texlive-full.install
@@ -0,0 +1,23 @@
+post_install()
+{
+ _year=$(date "+%Y")
+ echo "======================================================================="
+ echo "This packages provides texlive-full in /opt. It also tricks ArchLinux"
+ echo "into thinking it has its texlive packages installed."
+ echo "-----------------------------------------------------------------------"
+ echo "Add"
+ echo " /opt/texlive/${_year}/bin/x86_64-linux"
+ echo "to your PATH"
+ echo "Add"
+ echo " /opt/texlive/${_year}/texmf-dist/doc/man"
+ echo "to your MANPATH"
+ echo "Add"
+ echo " /opt/texlive/${_year}/texmf-dist/doc/info"
+ echo "to your INFOPATH"
+ echo "======================================================================="
+}
+
+post_upgrade()
+{
+ post_install
+}