summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
-rw-r--r--tllocalmgr.install7
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6d392b85bf8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = texlive-localmanager-git
+ pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
+ pkgver = v0.4.5.r3.g8c9f9e4
+ pkgrel = 1
+ url = http://wiki.archlinux.org/index.php?title=TeXLive#TeXLive_Local_Manager
+ install = tllocalmgr.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = texlive-core>=2011
+ depends = perl-libwww
+ depends = perl-term-shellui
+ depends = perl-term-readline-gnu
+ depends = perl-list-moreutils
+ depends = perl-http-message
+ provides = texlive-localmanager=v0.4.5.r3.g8c9f9e4
+ conflicts = texlive-localmanager
+ replaces = texlive-localmanager
+ source = texlive-localmanager::git://projects.archlinux.org/users/remy/texlive-localmanager.git
+ md5sums = SKIP
+
+pkgname = texlive-localmanager-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee18f467e7cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: XZS <d dot f dot fischer at web dot de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Rémy Oudompheng <remy@archlinux.org>
+# Contributor: Firmicus <francois . archlinux . org>
+
+_pkgname=texlive-localmanager
+pkgname=${_pkgname}-git
+pkgver=v0.4.5.r3.g8c9f9e4
+pkgrel=1
+pkgdesc="A shell and command-line utility to manage TeXLive on Arch Linux"
+arch=('any')
+url="http://wiki.archlinux.org/index.php?title=TeXLive#TeXLive_Local_Manager"
+license=('GPL')
+depends=('texlive-core>=2011' 'perl-libwww' 'perl-term-shellui' 'perl-term-readline-gnu' 'perl-list-moreutils' 'perl-http-message')
+conflicts=("${_pkgname}")
+replaces=("${_pkgname}")
+provides=("${_pkgname}=${pkgver}")
+makedepends=('git')
+source=("$_pkgname::git://projects.archlinux.org/users/remy/${_pkgname}.git")
+md5sums=('SKIP')
+install='tllocalmgr.install'
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ git describe --long --tags | sed -r 's/^foo-//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/lib/texmf/arch/tlpkg/TeXLive
+ install -m755 tllocalmgr $pkgdir/usr/bin/
+ cd tlpkg/TeXLive
+ for _f in *; do
+ install -m644 $_f $pkgdir/var/lib/texmf/arch/tlpkg/TeXLive/
+ done
+}
diff --git a/tllocalmgr.install b/tllocalmgr.install
new file mode 100644
index 000000000000..9a05beb5ac5a
--- /dev/null
+++ b/tllocalmgr.install
@@ -0,0 +1,7 @@
+post_install() {
+ cat <<WARNING
+Notice that tllocalmgr only manages packages from the texlive distribution.
+It also often leaves you with very cryptic error messages normally just
+indicating that it could not find the package you were asking it for.
+WARNING
+}