summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--texlive-newtx.install14
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32a611271bb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = texlive-newtx
+ pkgdesc = Alternative uses of the TX fonts, with improved metrics.
+ pkgver = 1.466
+ pkgrel = 1
+ url = http://ctan.org/pkg/newtx
+ install = texlive-newtx.install
+ arch = any
+ license = custom: LaTeX Project Public License 1.3c
+ makedepends = unzip
+ depends = texlive-bin
+ noextract = newtx.tds.zip
+ source = http://mirrors.ctan.org/install/fonts/newtx.tds.zip
+ source = http://latex-project.org/lppl.txt
+ sha1sums = ded2e1077edec121a1ddae058963cdec7676a376
+ sha1sums = 47438d5b2ab351796b64b62da105432ab71369ab
+
+pkgname = texlive-newtx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5825c4e4b6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
+
+_basename=newtx
+pkgname=texlive-"$_basename"
+pkgver=1.466
+pkgrel=1
+pkgdesc="Alternative uses of the TX fonts, with improved metrics."
+arch=('any')
+depends=('texlive-bin')
+makedepends=('unzip')
+url="http://ctan.org/pkg/$_basename"
+license=('custom: LaTeX Project Public License 1.3c')
+source=("http://mirrors.ctan.org/install/fonts/$_basename.tds.zip"
+ # LaTeX Project Public License
+ "http://latex-project.org/lppl.txt")
+noextract=("$_basename.tds.zip")
+install=$pkgname.install
+sha1sums=('ded2e1077edec121a1ddae058963cdec7676a376'
+ '47438d5b2ab351796b64b62da105432ab71369ab')
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/texmf/
+ unzip "$srcdir/$_basename".tds.zip -d "$pkgdir"/usr/share/texmf/
+ find "$pkgdir" -type f -exec chmod 644 {} \;
+ find "$pkgdir" -type d -exec chmod 755 {} \;
+ install -Dm644 "$srcdir"/lppl.txt \
+ "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}
+
diff --git a/texlive-newtx.install b/texlive-newtx.install
new file mode 100644
index 000000000000..9ad68f217d03
--- /dev/null
+++ b/texlive-newtx.install
@@ -0,0 +1,14 @@
+# from the texlive-bin package
+post_install() {
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+# echo -n "creating all formats..."
+# usr/bin/fmtutil-sys --all 1>/dev/null
+# echo " done."
+# echo " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
+}
+
+post_upgrade() {
+ post_install "$@"
+}
+