summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14af4222ebc1..7927d5f667d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = texlive-pgf-pie
pkgdesc = Some LaTeX macros for pie chart by using PGF/Tikz package.
- pkgver = 0.2.1
+ pkgver = 0.3
pkgrel = 1
url = https://github.com/xuyuan/pgf-pie/
install = texlive-pgf-pie.install
arch = any
- license = GPL3
+ license = GPL2
+ license = custom:LPPLv1.3c
depends = texlive-core
- source = https://raw.githubusercontent.com/xuyuan/pgf-pie/master/release/pgf-pie-0.2.1/pgf-pie.sty
- sha256sums = 72786b844537dea67a7b2468d2828241fc17d56351f47c68e82d3054dfeabf28
+ source = https://github.com/pgf-tikz/pgf-pie/releases/download/0.3/pgf-pie.zip
+ sha256sums = a80a9a499c666164c7bfa4bf5751f5eae1378691f7246f952f803e43ddce1174
pkgname = texlive-pgf-pie
diff --git a/PKGBUILD b/PKGBUILD
index 183a444c6755..3c71edaaec1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,22 @@
# Brought to you by: xu yuan, mohammed alfaki, lukas drude
pkgname=texlive-pgf-pie
-pkgver=0.2.1
+pkgver=0.3
pkgrel=1
pkgdesc="Some LaTeX macros for pie chart by using PGF/Tikz package."
arch=('any')
url="https://github.com/xuyuan/pgf-pie/"
-license=('GPL3')
+license=('GPL2' 'custom:LPPLv1.3c')
depends=('texlive-core')
install=${pkgname}.install
-source=("https://raw.githubusercontent.com/xuyuan/${pkgname#texlive-}/master/release/${pkgname#texlive-}-${pkgver}/${pkgname#texlive-}.sty")
-sha256sums=('72786b844537dea67a7b2468d2828241fc17d56351f47c68e82d3054dfeabf28')
+source=("https://github.com/pgf-tikz/pgf-pie/releases/download/${pkgver}/pgf-pie.zip")
+sha256sums=('a80a9a499c666164c7bfa4bf5751f5eae1378691f7246f952f803e43ddce1174')
package() {
- mkdir -p ${pkgdir}/usr/share/texmf/tex/latex/${pkgname#texlive-}
- cp ${srcdir}/${pkgname#texlive-}.sty ${pkgdir}/usr/share/texmf/tex/latex/${pkgname#texlive-}
+ mkdir -p "${pkgdir}/usr/share/texmf/tex/latex/${pkgname#texlive-}"
+ install -D -m644 "${srcdir}/pgf-pie.sty" "${pkgdir}/usr/share/texmf/tex/latex/${pkgname#texlive-}/pgf-pie.sty"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 "${srcdir}/LICENSE-GPL2.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-GPL2.txt"
+ install -D -m644 "${srcdir}/LICENSE-LPPL1.3c.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-LPPL1.3c.txt"
}