summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore18
-rw-r--r--DIN_Bd_PS.zip0
-rw-r--r--LICENSE5
-rw-r--r--PKGBUILD143
-rw-r--r--Univers_ps.zip0
-rw-r--r--font_archives.md52
-rw-r--r--texlive-tudscr-fonts.maps1
-rw-r--r--texlive.install52
9 files changed, 248 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02162f1dad4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Jan 23 18:42:09 UTC 2016
+pkgbase = texlive-tudscr-fonts
+ pkgdesc = TeX Live - TU Dresden corporate design fonts for tudscr
+ pkgver = 2.04
+ pkgrel = 1
+ url = http://latex.wcms-file3.tu-dresden.de/phpBB3/index.php
+ install = texlive.install
+ arch = any
+ license = custom:tud-cd-fonts
+ depends = texlive-core
+ depends = texlive-fontsextra
+ source = font_archives.md5
+ source = https://github.com/tud-cd/tudscr/releases/download/fonts/TUD-KOMA-Script_fonts_Unix.zip
+ source = texlive-tudscr-fonts.maps
+ source = LICENSE
+ source = DIN_Bd_PS.zip
+ source = Univers_ps.zip
+ md5sums = 23ecd5b966b5ca1e422c26b68db02021
+ md5sums = 12726ea55b40bd533c2525da5316db80
+ md5sums = 5d7289d1280ea193c1bd76a188f28a17
+ md5sums = 6cfb9405ed5429fb03883fad19153fdc
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = texlive-tudscr-fonts
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..679bb01dcec8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+# LaTeX crap
+*.aux
+*.bbl
+*.blg
+*.log
+*.toc
+*.nav
+*.out
+*.snm
+*.vrb
+
+pkg/
+src/
+texlive-tudscr-fonts-*.pkg.tar.xz
+texlive-tudscr-fonts/
+TUD-KOMA-Script*.zip
+.AURINFO
+
diff --git a/DIN_Bd_PS.zip b/DIN_Bd_PS.zip
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/DIN_Bd_PS.zip
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..7981ed5db884
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,5 @@
+Die versendete Schriftsoftware darf nur im Rahmen einer Tätigkeit an der TU Dresden benutzt werden.
+Endet Ihre Tätigkeit an der TU, sind Sie verpflichtet, die Schriften von Ihrem Rechner zu löschen.
+Eine Weitergabe der Schriftsoftware an Dritte ist nicht gestattet.
+Bei Verteilung der Schriftsoftware an mehrere Mitarbeiter müssen diese ebenfalls als Lizenznehmer registriert werden.
+Für Rechnerpools mit ständig wechselnden Nutzern bitte die Anzahl der Arbeitsplätze angeben, auf denen die Schrift eingesetzt wird.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26473864df06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,143 @@
+# Maintainer: Kevin Mäder <kmaeder[AT]kevin-maeder[dot]de>
+# TU Dresden corporate design font install
+
+# ###################################################
+# MANDATORY ACTION BEFORE package creation:
+# Copy DIN_Bd_PS.zip and Univers_ps.zip to directory with PKGBUILD
+# (overwriting placeholder files with same name)!!!
+
+pkgname=texlive-tudscr-fonts
+pkgver=2.04
+pkgrel=1
+pkgdesc="TeX Live - TU Dresden corporate design fonts for tudscr"
+license=('custom:tud-cd-fonts')
+arch=('any')
+depends=('texlive-core' 'texlive-fontsextra')
+url=("http://latex.wcms-file3.tu-dresden.de/phpBB3/index.php")
+install=texlive.install
+source=("font_archives.md5"
+ "https://github.com/tud-cd/tudscr/releases/download/fonts/TUD-KOMA-Script_fonts_Unix.zip"
+ "texlive-tudscr-fonts.maps"
+ "LICENSE"
+ "DIN_Bd_PS.zip"
+ "Univers_ps.zip")
+md5sums=('23ecd5b966b5ca1e422c26b68db02021'
+ '12726ea55b40bd533c2525da5316db80'
+ '5d7289d1280ea193c1bd76a188f28a17'
+ '6cfb9405ed5429fb03883fad19153fdc'
+ 'SKIP'
+ 'SKIP')
+
+# if you change the path here make sure to change it in texlive.install too
+TEXPATH=/usr/share/texmf
+
+FONTSPRESENT=1
+
+prepare() {
+ cd $srcdir/..
+
+ if ! md5sum -c font_archives.md5
+ then
+ echo "==========================================================================================================="
+ echo "The build process was aborted. The created package is empty."
+ echo ""
+ echo "You need to exchange the placeholder files ${source[4]} and ${source[3]} before starting the build process."
+ echo "If you did so, your font archives might be corrupted. If you can rule that out, a \"new\" version of font"
+ echo "archives might be out. Please contact the maintainer in that case."
+ echo "==========================================================================================================="
+ FONTSPRESENT=0
+ else
+ bsdtar -xf DIN_Bd_PS.zip -C $srcdir
+ bsdtar -xf Univers_ps.zip -C $srcdir
+
+ cd $srcdir
+ bsdtar -xf TUD-KOMA-Script_fonts_Unix.zip -C $srcdir tudscr_fonts_install.zip
+ bsdtar -xf $srcdir/tudscr_fonts_install.zip
+ fi
+}
+
+build() {
+ if [ ${FONTSPRESENT} -eq 1 ]
+ then
+ echo ">>> rename font files"
+ mv -f DINBd___.pfb 0m6b8a.pfb
+ mv -f DINBd___.afm 0m6b8a.afm
+ mv -f uvceb___.pfb lunb8a.pfb
+ mv -f uvceb___.afm lunb8a.afm
+ mv -f uvcel___.pfb lunl8a.pfb
+ mv -f uvcel___.afm lunl8a.afm
+ mv -f uvceo___.pfb lunro8a.pfb
+ mv -f uvceo___.afm lunro8a.afm
+ mv -f uvxbo___.pfb lunbo8a.pfb
+ mv -f uvxbo___.afm lunbo8a.afm
+ mv -f uvxlo___.pfb lunlo8a.pfb
+ mv -f uvxlo___.afm lunlo8a.afm
+ mv -f uvce____.pfb lunr8a.pfb
+ mv -f uvce____.afm lunr8a.afm
+ mv -f uvczo___.pfb lunco8a.pfb
+ mv -f uvczo___.afm lunco8a.afm
+ mv -f uvcz____.pfb lunc8a.pfb
+ mv -f uvcz____.afm lunc8a.afm
+
+ echo ">>> create virtual fonts"
+ tftopl cmbr10.tfm cmbr10.pl
+ tftopl cmbrsl10.tfm cmbrsl10.pl
+ tftopl cmbrbx10.tfm cmbrbx10.pl
+ tftopl tbmr10.tfm tbmr10.pl
+ tftopl tbmo10.tfm tbmo10.pl
+ tftopl tbsr10.tfm tbsr10.pl
+ tftopl tbso10.tfm tbso10.pl
+ tftopl tbbx10.tfm tbbx10.pl
+ tftopl cmbrmi10.tfm cmbrmi10.pl
+ tftopl cmbrmb10.tfm cmbrmb10.pl
+ tftopl cmbrsy10.tfm cmbrsy10.pl
+ tftopl sy-iwonamz.tfm sy-iwonamz.pl
+ tftopl sy-iwonahz.tfm sy-iwonahz.pl
+ tftopl rm-iwonach.tfm rm-iwonach.pl
+ tftopl rm-iwonachi.tfm rm-iwonachi.pl
+ tftopl ts1-iwonach.tfm ts1-iwonach.pl
+ tftopl ts1-iwonachi.tfm ts1-iwonachi.pl
+ tftopl mi-iwonachi.tfm mi-iwonachi.pl
+ tftopl sy-iwonachz.tfm sy-iwonachz.pl
+ latex installfonts.tex
+
+# now we have files of type .afm .fd, .mtx, .pfb, .pl, .vpl
+ echo ">>> convert font and metric files to machine readable format"
+ for f in *.pl ; do
+ pltotf $f
+ done
+
+ for f in *.vpl ; do
+ vptovf $f
+ done
+
+ echo ">>> create map files"
+ latex createmap.tex
+ fi
+}
+
+package() {
+ if [ ${FONTSPRESENT} -eq 1 ]
+ then
+ install -m755 -d $pkgdir/var/lib/texmf/arch/installedpkgs
+ install -m644 $pkgname.maps $pkgdir/var/lib/texmf/arch/installedpkgs/
+ touch $pkgdir/var/lib/texmf/arch/installedpkgs/${pkgname}_${pkgver}-${pkgrel}.pkgs
+ chmod 644 $pkgdir/var/lib/texmf/arch/installedpkgs/${pkgname}_${pkgver}-${pkgrel}.pkgs
+
+ install -m755 -d $pkgdir$TEXPATH/tex/latex/tudscr-fonts
+ install -m755 -d $pkgdir$TEXPATH/fonts/tfm/adobe/tudscr-fonts
+ install -m755 -d $pkgdir$TEXPATH/fonts/afm/adobe/tudscr-fonts
+ install -m755 -d $pkgdir$TEXPATH/fonts/vf/adobe/tudscr-fonts
+ install -m755 -d $pkgdir$TEXPATH/fonts/type1/adobe/tudscr-fonts
+ install -m755 -d $pkgdir$TEXPATH/fonts/map
+
+ install -m644 *.fd $pkgdir$TEXPATH/tex/latex/tudscr-fonts/
+ install -m644 *.tfm $pkgdir$TEXPATH/fonts/tfm/adobe/tudscr-fonts/
+ install -m644 *.afm $pkgdir$TEXPATH/fonts/afm/adobe/tudscr-fonts/
+ install -m644 *.vf $pkgdir$TEXPATH/fonts/vf/adobe/tudscr-fonts/
+ install -m644 *.pfb $pkgdir$TEXPATH/fonts/type1/adobe/tudscr-fonts/
+ install -m644 tudscr.map $pkgdir$TEXPATH/fonts/map
+
+ install -D -m 644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE:tud-cd-fonts"
+ fi
+}
diff --git a/Univers_ps.zip b/Univers_ps.zip
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/Univers_ps.zip
diff --git a/font_archives.md5 b/font_archives.md5
new file mode 100644
index 000000000000..d6172a99d071
--- /dev/null
+++ b/font_archives.md5
@@ -0,0 +1,2 @@
+9a8dbc15591bb7b5e53d3871746efb53 Univers_ps.zip
+53d4b9ca49a0966132d818b44fcc8ef4 DIN_Bd_PS.zip
diff --git a/texlive-tudscr-fonts.maps b/texlive-tudscr-fonts.maps
new file mode 100644
index 000000000000..25a0a4235e2f
--- /dev/null
+++ b/texlive-tudscr-fonts.maps
@@ -0,0 +1 @@
+Map tudscr.map
diff --git a/texlive.install b/texlive.install
new file mode 100644
index 000000000000..16e7552e039b
--- /dev/null
+++ b/texlive.install
@@ -0,0 +1,52 @@
+PKGNAME="texlive-tudscr-fonts"
+UPDMAP="etc/texmf/web2c/updmap.cfg"
+UPDMAPLOCAL="etc/texmf/web2c/updmap-local.cfg"
+SYNCWITHTREES=''
+
+MAPFILE="var/lib/texmf/arch/installedpkgs/$PKGNAME.maps"
+
+post_install() {
+ TMPFILE=`mktemp`
+ echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
+ cp "$UPDMAP" "$TMPFILE"
+ echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
+ echo " into /etc/texmf/web2c/updmap-local.cfg"
+ cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
+ cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
+ [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash
+ echo " done."
+}
+
+post_upgrade() {
+ TMPFILE=`mktemp`
+ echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
+ cp "$UPDMAP" "$TMPFILE"
+ echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
+ echo " into /etc/texmf/web2c/updmap-local.cfg"
+ cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
+ cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
+ [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash $SYNCWITHTREES
+ echo " done."
+}
+
+pre_remove() {
+for m in `cut -d' ' -f2 $MAPFILE`; do
+ sed -i "/\s$m/d" $UPDMAP ;
+done
+}
+
+post_remove() {
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash
+ echo " done."
+}