summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
-rw-r--r--texlive.install12
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e6fee7d4262
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = texlive-usenix
+ pkgdesc = TeX Live - LaTeX package for USENIX conferences
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://www.usenix.org
+ install = texlive.install
+ arch = any
+ license = GPL
+ depends = texlive-core
+ source = http://www.usenix.org/events/samples/usenix.sty
+ source = http://www.usenix.org/events/samples/template.la
+ sha256sums = 2f60e059b2bb7f75d67c9ecd1fe3ba494e5f342a44079678f5b7da569ce97157
+ sha256sums = 6f5de8be9143ce91ce99b508025d67624479b42ebdd6fd5afe715d4fda666677
+
+pkgname = texlive-usenix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18869971b34e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Devin J. Pohly <djpohly+arch@gmail.com>
+pkgname=texlive-usenix
+pkgver=1.2
+pkgrel=1
+pkgdesc="TeX Live - LaTeX package for USENIX conferences"
+arch=(any)
+url="http://www.usenix.org"
+license=('GPL')
+depends=('texlive-core')
+install=texlive.install
+source=("http://www.usenix.org/events/samples/usenix.sty"
+ "http://www.usenix.org/events/samples/template.la")
+sha256sums=('2f60e059b2bb7f75d67c9ecd1fe3ba494e5f342a44079678f5b7da569ce97157'
+ '6f5de8be9143ce91ce99b508025d67624479b42ebdd6fd5afe715d4fda666677')
+
+package() {
+ install -Dm644 "$srcdir/usenix.sty" "$pkgdir/usr/share/texmf-dist/tex/latex/usenix/usenix.sty"
+ install -Dm644 "$srcdir/template.la" "$pkgdir/usr/share/doc/texlive-usenix/template.la"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/texlive.install b/texlive.install
new file mode 100644
index 000000000000..c92b88262d02
--- /dev/null
+++ b/texlive.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo ">>> texlive: updating the filename database..."
+ /usr/bin/mktexlsr
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}