summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0004-Sage-plugin-fix-which-not-found.patch34
-rw-r--r--PKGBUILD8
3 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 296b07918323..45c0ba2076ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Jun 8 03:18:53 UTC 2016
+# Wed Jun 8 03:33:26 UTC 2016
pkgbase = texmacs-svn
pkgdesc = Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor and CAS-interface.
pkgver = 20160607.10447
@@ -32,10 +32,12 @@ pkgbase = texmacs-svn
source = 0001-R-plugin-fix-preprocessor.patch
source = 0002-Fix-macro-name-for-guile.patch
source = 0003-Fix-mktemp-too-few-X-s-in-template-texmacs.patch
+ source = 0004-Sage-plugin-fix-which-not-found.patch
sha1sums = SKIP
sha1sums = 6fdcd7f01fc6ab3725b43ae96f673e87e4559600
sha1sums = 2c548e064a7ffd767a81feeb05bbfb87c1948db1
sha1sums = 32d2890347d498f02c2ab7ee74021ab62b099436
+ sha1sums = f1f0e5d53091cdfe74142f7dfb7180e20f3eb10d
pkgname = texmacs-svn
diff --git a/0004-Sage-plugin-fix-which-not-found.patch b/0004-Sage-plugin-fix-which-not-found.patch
new file mode 100644
index 000000000000..356ccd2b589c
--- /dev/null
+++ b/0004-Sage-plugin-fix-which-not-found.patch
@@ -0,0 +1,34 @@
+From f447e4add3b0a2473b227c5a32b689d1834fe08d Mon Sep 17 00:00:00 2001
+From: wangjiezhe <wangjiezhe@gmail.com>
+Date: Wed, 8 Jun 2016 11:20:42 +0800
+Subject: [PATCH 4/4] Sage plugin: fix `which` not found
+
+---
+ plugins/sage/progs/init-sage.scm | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/plugins/sage/progs/init-sage.scm b/plugins/sage/progs/init-sage.scm
+index f3fb922..b18bf07 100644
+--- a/plugins/sage/progs/init-sage.scm
++++ b/plugins/sage/progs/init-sage.scm
+@@ -12,10 +12,16 @@
+ ;;
+ ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
+
++(define (sage-launcher)
++ (with path "$TEXMACS_BIN_PATH/bin/tm_sage"
++ (string-append
++ "sage -python "
++ (url-concretize (unix->url path)))))
++
+ (plugin-configure sage
+ (:macpath "Sage*" "Contents/Resources/sage")
+ (:require (url-exists-in-path? "sage"))
+- (:launch "sage -python `which tm_sage`")
++ (:launch ,(sage-launcher))
+ (:tab-completion #t)
+ (:session "Sage")
+ (:scripts "Sage"))
+--
+2.8.3
+
diff --git a/PKGBUILD b/PKGBUILD
index e4b8ad9e98af..c5de56dca827 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,11 +23,13 @@ source=("${_pkgname}::svn://svn.savannah.gnu.org/texmacs/trunk/src"
"0001-R-plugin-fix-preprocessor.patch"
"0002-Fix-macro-name-for-guile.patch"
"0003-Fix-mktemp-too-few-X-s-in-template-texmacs.patch"
+ "0004-Sage-plugin-fix-which-not-found.patch"
)
sha1sums=('SKIP'
'6fdcd7f01fc6ab3725b43ae96f673e87e4559600'
'2c548e064a7ffd767a81feeb05bbfb87c1948db1'
- '32d2890347d498f02c2ab7ee74021ab62b099436')
+ '32d2890347d498f02c2ab7ee74021ab62b099436'
+ 'f1f0e5d53091cdfe74142f7dfb7180e20f3eb10d')
options=('!emptydirs' '!ccache')
provides=('texmacs')
conflicts=('texmacs')
@@ -46,6 +48,7 @@ prepare() {
patch -Np1 -i ../0001-R-plugin-fix-preprocessor.patch
patch -Np1 -i ../0002-Fix-macro-name-for-guile.patch
patch -Np1 -i ../0003-Fix-mktemp-too-few-X-s-in-template-texmacs.patch
+ patch -Np1 -i ../0004-Sage-plugin-fix-which-not-found.patch
sed -i 's/env python/env python2/' \
plugins/{mathematica/bin/realpath.py,python/bin/tm_python,sage/bin/tm_sage} \
@@ -86,9 +89,6 @@ package() {
sed -i 's|${prefix}|/usr|' "${pkgdir}/usr/bin/fig2ps"
# fix FS#37518
sed -i '/^Path=/d' "${pkgdir}/usr/share/applications/texmacs.desktop"
-
- # fix sage plugin
- sed -i 's|`which tm_sage`|/usr/lib/TeXmacs/bin/tm_sage|' "${pkgdir}/usr/share/TeXmacs/plugins/sage/progs/init-sage.scm"
}
# vim:set ts=2 sw=2 et: