summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD9
-rw-r--r--fix-m4.patch16
2 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc3d6f10a7d6..2d7783486ca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=texmacs-svn
_pkgname=texmacs
-pkgver=20160514.10334
+pkgver=20160515.10342
pkgrel=1
pkgdesc="Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor and CAS-interface."
arch=('i686' 'x86_64')
@@ -22,13 +22,13 @@ makedepends=('ghostscript')
source=("${_pkgname}::svn://svn.savannah.gnu.org/texmacs/trunk/src"
"fix-m4.patch")
sha1sums=('SKIP'
- '7157af255642d08a37b518957b10050bb4fc9672')
+ 'e575a43c20ccf230602511be1b2f3917abb9d67f')
options=('!emptydirs' '!ccache')
provides=('texmacs')
conflicts=('texmacs')
pkgver() {
- cd ${srcdir}/${_pkgname}
+ cd "${srcdir}/${_pkgname}"
svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
}
@@ -80,6 +80,9 @@ package() {
sed -i 's|${prefix}|/usr|' "${pkgdir}/usr/bin/fig2ps"
# fix FS#37518
sed -i '/^Path=/d' "${pkgdir}/usr/share/applications/texmacs.desktop"
+
+ # fix sage plugin
+ sed -i 's|`which tm_sage`|/usr/lib/TeXmacs/bin/tm_sage|' "${pkgdir}/usr/share/TeXmacs/plugins/sage/progs/init-sage.scm"
}
# vim:set ts=2 sw=2 et:
diff --git a/fix-m4.patch b/fix-m4.patch
index 3d0569acbc44..d9c9307fa424 100644
--- a/fix-m4.patch
+++ b/fix-m4.patch
@@ -344,10 +344,10 @@ index 5eab086..cf74379 100644
+])
\ No newline at end of file
diff --git a/misc/m4/iconv.m4 b/misc/m4/iconv.m4
-index 4d1f46e..2a4c78f 100644
+index 9062d20..2a4c78f 100644
--- a/misc/m4/iconv.m4
+++ b/misc/m4/iconv.m4
-@@ -1,48 +1,67 @@
+@@ -1,52 +1,67 @@
-#--------------------------------------------------------------------
-# Checks for iconv library
-#--------------------------------------------------------------------
@@ -432,16 +432,20 @@ index 4d1f46e..2a4c78f 100644
- unset i_failure
- unset [$0]_LIBPATH
- ], [
-- AC_MSG_ERROR([you may have several versions of iconv installed,
-- use with-iconv=iconv_base_path (i.e /usr/local) to specify one location])
+- echo configure: warning, failed to link with iconv
+-# AC_MSG_ERROR([you may have several versions of iconv installed,
+-# use with-iconv=iconv_base_path (i.e /usr/local) to specify one location])
- ])],[
- LC_GET_ARG_VALUE([$0]_LIBPATHS, [-L], [$0]_LIBPATH)
- STRIP_ARG([[$0]_LIBPATHS], -L$[$0]_LIBPATH)
- ])
- done
- if [[ $i_failure ]]
-- then AC_MSG_ERROR([absence of iconv may crash HTML import or prevent the build
-- but it is possible to run configure --with-iconv=no])
+- then
+- echo configure: warning, iconv support does not seem to work
+- echo configure: warning, absence of iconv may crash HTML import among others
+-# AC_MSG_ERROR([absence of iconv may crash HTML import or prevent the build
+-# but it is possible to run configure --with-iconv=no])
+ ICONV_LDFLAGS="${ICONV_LDFLAGS/-liconv} -liconv"
+ ],[
+ AC_MSG_RESULT(no)