summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..371bb6d1156c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = textlint-rule-max-comma
+ pkgdesc = textlint rule that limit maxinum comma(,) count of sentence.
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/azu/textlint-rule-max-comma#readme
+ arch = any
+ depends = nodejs
+ depends = npm
+ noextract = textlint-rule-max-comma-1.0.4.tgz
+ source = http://registry.npmjs.org/textlint-rule-max-comma/-/textlint-rule-max-comma-1.0.4.tgz
+ sha1sums = f555c97e0d3039ca7da06cfd1afad0e5f5899a37
+
+pkgname = textlint-rule-max-comma
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8236e2a1fc06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=textlint-rule-max-comma
+_npmver=1.0.4
+pkgname=textlint-rule-max-comma # All lowercase
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="textlint rule that limit maxinum comma(,) count of sentence."
+arch=(any)
+url="https://github.com/azu/textlint-rule-max-comma#readme"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(f555c97e0d3039ca7da06cfd1afad0e5f5899a37)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: