summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5734157afa73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = textlint-rule-period-in-list-item
+ pkgdesc = textlint rule that check with or without period in list item.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/azu/textlint-rule-period-in-list-item
+ arch = any
+ depends = nodejs
+ depends = npm
+ noextract = textlint-rule-period-in-list-item-0.2.0.tgz
+ source = http://registry.npmjs.org/textlint-rule-period-in-list-item/-/textlint-rule-period-in-list-item-0.2.0.tgz
+ sha1sums = e09da271c5c4e57301f98f2da607c51afbd15ed3
+
+pkgname = textlint-rule-period-in-list-item
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab5c2ded1401
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_npmname=textlint-rule-period-in-list-item
+_npmver=0.2.0
+pkgname=textlint-rule-period-in-list-item # All lowercase
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="textlint rule that check with or without period in list item."
+arch=(any)
+url="https://github.com/azu/textlint-rule-period-in-list-item"
+license=()
+depends=('nodejs' 'npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
+noextract=($_npmname-$_npmver.tgz)
+sha1sums=(e09da271c5c4e57301f98f2da607c51afbd15ed3)
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+}
+
+# vim:set ts=2 sw=2 et: