summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
-rw-r--r--fix-build.patch12
3 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a93f592c01f..c1303ba42100 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,21 +13,20 @@ pkgbase = textosaurus
license = GPL3
makedepends = git
makedepends = qt5-tools
+ depends = hicolor-icon-theme
depends = qt5-base
depends = qt5-svg
- replaces = textilosaurus
source = git+https://github.com/martinrotter/textosaurus.git#commit=6e2e86d45eebc37ca6992ab17b3acbc3840f5967
source = git+https://github.com/martinrotter/transka.git
source = git+https://github.com/martinrotter/7za.git
source = git+https://github.com/martinrotter/nsis.git
source = git+https://github.com/martinrotter/sed.git
- source = git+https://github.com/martinrotter/scintilla
- sha256sums = SKIP
+ source = fix-build.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = b41a0538e3da266c8e7bd67eca2dd6e8c2495521596fced4d3d3d496cfd135bc
pkgname = textosaurus
-
diff --git a/PKGBUILD b/PKGBUILD
index 1f0119974e40..0513569b562f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,20 @@ pkgdesc="Simple cross-platform text editor based on Qt and Scintilla"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://github.com/martinrotter/textosaurus"
license=(GPL3)
-depends=(qt5-base qt5-svg)
+depends=(hicolor-icon-theme qt5-base qt5-svg)
makedepends=(git qt5-tools)
-replaces=(textilosaurus)
source=("git+https://github.com/martinrotter/textosaurus.git#commit=6e2e86d45eebc37ca6992ab17b3acbc3840f5967"
"git+https://github.com/martinrotter/transka.git"
"git+https://github.com/martinrotter/7za.git"
"git+https://github.com/martinrotter/nsis.git"
"git+https://github.com/martinrotter/sed.git"
- "git+https://github.com/martinrotter/scintilla")
+ "fix-build.patch")
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'b41a0538e3da266c8e7bd67eca2dd6e8c2495521596fced4d3d3d496cfd135bc')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -37,8 +36,8 @@ prepare() {
git config 'submodule.resources/scripts/7za.url' "${srcdir}/7za"
git config 'submodule.resources/scripts/nsis.url' "${srcdir}/nsis"
git config 'submodule.resources/scripts/sed.url' "${srcdir}/sed"
- git config 'submodule.src/libtextosaurus/3rd-party/scintilla.url' "${srcdir}/scintilla"
- git submodule update
+ git -c protocol.file.allow=always submodule update
+ git apply ../fix-build.patch
}
build() {
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..bb2eec99999d
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,12 @@
+diff --git a/src/libtextosaurus/definitions/definitions.h b/src/libtextosaurus/definitions/definitions.h
+index abe18765..d007838c 100755
+--- a/src/libtextosaurus/definitions/definitions.h
++++ b/src/libtextosaurus/definitions/definitions.h
+@@ -3,6 +3,7 @@
+ #ifndef DEFINITIONS_H
+ #define DEFINITIONS_H
+
++#include <limits>
+ #include <QtGlobal>
+
+ // *INDENT-OFF*