summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd5dfac0737c..3888d6f6ef5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = textosaurus
pkgdesc = Simple cross-platform text editor based on Qt and Scintilla
- pkgver = 0.9.2
+ pkgver = 0.9.3.1
pkgrel = 1
epoch = 1
url = https://github.com/martinrotter/textosaurus
@@ -15,7 +15,7 @@ pkgbase = textosaurus
conflicts = textosaurus
conflicts = textosaurus-git
replaces = textilosaurus
- source = git+https://github.com/martinrotter/textosaurus#commit=513ce234eef077902e24196d3fb93773e1eff0d5
+ source = git+https://github.com/martinrotter/textosaurus#commit=1710f53c81dbcf4788fd23ebaabf6ec77a4a3fb6
md5sums = SKIP
pkgname = textosaurus
diff --git a/PKGBUILD b/PKGBUILD
index 64b2948888d7..f80eff72bad7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=textosaurus
epoch=1
-pkgver=0.9.2
+pkgver=0.9.3.1
pkgrel=1
pkgdesc="Simple cross-platform text editor based on Qt and Scintilla"
arch=('x86_64' 'i686')
@@ -13,10 +13,15 @@ makedepends=('git' 'qt5-tools')
provides=('textosaurus')
conflicts=('textosaurus' 'textosaurus-git')
replaces=('textilosaurus')
-_commit=513ce234eef077902e24196d3fb93773e1eff0d5
+_commit=1710f53c81dbcf4788fd23ebaabf6ec77a4a3fb6
source=("git+https://github.com/martinrotter/textosaurus#commit=$_commit")
md5sums=('SKIP')
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
prepare() {
cd "${srcdir}/${pkgname}"
install -d build